aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/py-4suite-xml/Makefile11
-rw-r--r--textproc/py-4suite-xml/distinfo5
-rw-r--r--textproc/py-4suite-xml/pkg-plist12
3 files changed, 17 insertions, 11 deletions
diff --git a/textproc/py-4suite-xml/Makefile b/textproc/py-4suite-xml/Makefile
index 9c6b930202dc..29a7661342b1 100644
--- a/textproc/py-4suite-xml/Makefile
+++ b/textproc/py-4suite-xml/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= 4Suite-XML
-PORTVERSION= 1.0.b2
+PORTVERSION= 1.0.b3
CATEGORIES= textproc python
MASTER_SITES= ftp://ftp.4suite.org/pub/4Suite/ \
${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= foursuite
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= 4Suite-XML-1.0b2
+DISTNAME= 4Suite-XML-1.0b3
MAINTAINER= mike@skew.org
COMMENT= A collection of Python tools for XML processing
@@ -23,15 +23,11 @@ REINPLACE_ARGS= -i "" -E
USE_PYTHON= 2.2.1+
USE_PYDISTUTILS= yes
-WRKSRC= ${WRKDIR}/4Suite-1.0b2
+WRKSRC= ${WRKDIR}/4Suite-1.0b3
CONFLICTS= py*-4suite-[01]* py*-xml-0.7*
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386"
-BROKEN= "Does not build on !i386"
-.endif
-
BINDIR= bin
SYSCONFDIR= etc/4Suite
LIBDIR= lib/4Suite
@@ -72,6 +68,5 @@ post-install:
.if !defined(NOPORTDOCS)
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/${DOCSDIR}
.endif
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/textproc/py-4suite-xml/distinfo b/textproc/py-4suite-xml/distinfo
index ec30b5273429..f604f95fae87 100644
--- a/textproc/py-4suite-xml/distinfo
+++ b/textproc/py-4suite-xml/distinfo
@@ -1,3 +1,2 @@
-MD5 (4Suite-XML-1.0b2.tar.bz2) = 9674031e9cc372504a047411d4d7cdf7
-SHA256 (4Suite-XML-1.0b2.tar.bz2) = 7703871a33a22f55ae2ee79e8be81bd59707764a66376e245bfd5a309819d63e
-SIZE (4Suite-XML-1.0b2.tar.bz2) = 1051469
+MD5 (4Suite-XML-1.0b3.tar.bz2) = 9decb8b1032415ae155fe9a917fe8126
+SIZE (4Suite-XML-1.0b3.tar.bz2) = 1053430
diff --git a/textproc/py-4suite-xml/pkg-plist b/textproc/py-4suite-xml/pkg-plist
index a54b695ef2b2..bba7108e2999 100644
--- a/textproc/py-4suite-xml/pkg-plist
+++ b/textproc/py-4suite-xml/pkg-plist
@@ -12,7 +12,9 @@
%%LIBDIR%%/tests/Lib/test_uri.py
%%LIBDIR%%/tests/README
%%LIBDIR%%/tests/Xml/Borrowed/__init__.py
+%%LIBDIR%%/tests/Xml/Borrowed/ie-050515.py
%%LIBDIR%%/tests/Xml/Borrowed/rs-030516.py
+%%LIBDIR%%/tests/Xml/Borrowed/uo-051205.py
%%LIBDIR%%/tests/Xml/Core/.#test_catalog.py.1.3
%%LIBDIR%%/tests/Xml/Core/4suite.xsa
%%LIBDIR%%/tests/Xml/Core/__init__.py
@@ -41,6 +43,7 @@
%%LIBDIR%%/tests/Xml/Core/relaxng_datatypes.py
%%LIBDIR%%/tests/Xml/Core/test_catalog.py
%%LIBDIR%%/tests/Xml/Core/test_convenience_parse.py
+%%LIBDIR%%/tests/Xml/Core/test_convenience_parse.py.~1.1.~
%%LIBDIR%%/tests/Xml/Core/test_domlette.py
%%LIBDIR%%/tests/Xml/Core/test_domlette_interfaces.py
%%LIBDIR%%/tests/Xml/Core/test_domlette_memory.py
@@ -51,6 +54,8 @@
%%LIBDIR%%/tests/Xml/Core/test_nss.py
%%LIBDIR%%/tests/Xml/Core/test_printers.py
%%LIBDIR%%/tests/Xml/Core/test_ranges.py
+%%LIBDIR%%/tests/Xml/Core/test_saxlette.py
+%%LIBDIR%%/tests/Xml/Core/test_saxlette_scenarios.py
%%LIBDIR%%/tests/Xml/Core/test_xinclude.py
%%LIBDIR%%/tests/Xml/Core/test_xmlstring.py
%%LIBDIR%%/tests/Xml/Core/test_xmlstring.py.~1.1.~
@@ -158,6 +163,7 @@
%%LIBDIR%%/tests/Xml/Xslt/Borrowed/gkh_20001016.py
%%LIBDIR%%/tests/Xml/Xslt/Borrowed/ie5default.xslt
%%LIBDIR%%/tests/Xml/Xslt/Borrowed/jd_20000911.py
+%%LIBDIR%%/tests/Xml/Xslt/Borrowed/jk_20050406.py
%%LIBDIR%%/tests/Xml/Xslt/Borrowed/js_20001004.py
%%LIBDIR%%/tests/Xml/Xslt/Borrowed/js_20001012.py
%%LIBDIR%%/tests/Xml/Xslt/Borrowed/js_20001016.py
@@ -326,6 +332,10 @@
%%LIBDIR%%/tests/Xml/Xslt/Exslt/test_regexp.py
%%LIBDIR%%/tests/Xml/Xslt/Exslt/test_sets.py
%%LIBDIR%%/tests/Xml/Xslt/Exslt/test_strings.py
+%%LIBDIR%%/tests/Xml/Xslt/Manual/__init__.py
+%%LIBDIR%%/tests/Xml/Xslt/Manual/extfuncs_demo.py
+%%LIBDIR%%/tests/Xml/Xslt/Manual/ord.py
+%%LIBDIR%%/tests/Xml/Xslt/Manual/test_xpath_xslt_extensions.py
%%LIBDIR%%/tests/Xml/Xslt/__init__.py
%%LIBDIR%%/tests/Xml/Xslt/test_harness.py
%%LIBDIR%%/tests/Xml/__init__.py
@@ -1065,6 +1075,7 @@
%%PORTDOCS%%%%DOCSDIR%%/html/sdocbook_html.css
%%PORTDOCS%%%%DOCSDIR%%/xml/CoreManual.doc
%%PORTDOCS%%%%DOCSDIR%%/xml/CoreManualSections/Domlette.xml
+%%PORTDOCS%%%%DOCSDIR%%/xml/CoreManualSections/Examples.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/CoreManualSections/Installation.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/CoreManualSections/Introduction.xml
%%PORTDOCS%%%%DOCSDIR%%/xml/CoreManualSections/MarkupWriter.xml
@@ -1352,6 +1363,7 @@
@dirrm %%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/Lib/CommandLine
@dirrm %%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%/Lib
@dirrm %%PYTHON_SITELIBDIR%%/%%PACKAGE_DIR%%
+@dirrm %%LIBDIR%%/tests/Xml/Xslt/Manual
@dirrm %%LIBDIR%%/tests/Xml/Xslt/Exslt
@dirrm %%LIBDIR%%/tests/Xml/Xslt/Core/etc
@dirrm %%LIBDIR%%/tests/Xml/Xslt/Core