aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/ntpsec/Makefile19
-rw-r--r--net/ntpsec/distinfo3
-rw-r--r--net/ntpsec/pkg-descr21
-rw-r--r--net/ntpsec/pkg-plist43
5 files changed, 87 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index fcd95f2ce09c..fc46dda3f2b7 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -516,6 +516,7 @@
SUBDIR += ntp
SUBDIR += ntp-devel
SUBDIR += ntpa
+ SUBDIR += ntpsec
SUBDIR += ntraceroute
SUBDIR += nusoap
SUBDIR += nuster
diff --git a/net/ntpsec/Makefile b/net/ntpsec/Makefile
new file mode 100644
index 000000000000..dfdc08c33218
--- /dev/null
+++ b/net/ntpsec/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= ntpsec
+DISTVERSION= 1.1.4
+CATEGORIES= net
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Network Time Protocol suite, refactored
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= bison gettext-runtime python:2.7 shebangfix ssl waf # python-3.6 has 2 issues: plist differences, and terminal-related failure: https://gitlab.com/NTPsec/ntpsec/issues/599
+SHEBANG_FILES= ${WRKSRC}/ntpclients/ntp*.py
+USE_GITLAB= yes
+GL_ACCOUNT= NTPsec
+GL_COMMIT= 79cd18fc56fc902c3a7fd78bcc32ee72f52eb396
+
+.include <bsd.port.mk>
diff --git a/net/ntpsec/distinfo b/net/ntpsec/distinfo
new file mode 100644
index 000000000000..4e4996a5c53f
--- /dev/null
+++ b/net/ntpsec/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1561774063
+SHA256 (NTPsec-ntpsec-79cd18fc56fc902c3a7fd78bcc32ee72f52eb396_GL0.tar.gz) = 14eda0af80be125c4ac937c529f0973414c51bf691333b3950e08f3a5f282409
+SIZE (NTPsec-ntpsec-79cd18fc56fc902c3a7fd78bcc32ee72f52eb396_GL0.tar.gz) = 2536708
diff --git a/net/ntpsec/pkg-descr b/net/ntpsec/pkg-descr
new file mode 100644
index 000000000000..b0861da257a3
--- /dev/null
+++ b/net/ntpsec/pkg-descr
@@ -0,0 +1,21 @@
+A reimplementation of the NNTP protocol daemon and tools in a secure way.
+
+A major new feature is that it implements IETF's Network Time Security standard
+for strong cryptographic authentication of time service.
+
+Security improvements:
+* Network Time Security is implemented.
+* The deprecated ntpdc utility, long a chronic locus of security
+ vulnerabilities, has been removed
+* Autokey is not supported; that code has been removed, as it was chronically
+ prone to security vulnerabilities.
+* Peer mode has been removed. The keyword peer in ntp.conf is now just an alias
+ for keyword server.
+* Broadcast- and multicast modes, which are impossible to secure, have been
+ removed.
+* The authentication requirement for remote configuration commands (e.g., via
+ ntpq) can no longer be disabled.
+* The deprecated and vulnerability-prone ntpdate program has been replaced with
+ a shell wrapper around ntpdig.
+
+WWW: https://gitlab.com/NTPsec/ntpsec/
diff --git a/net/ntpsec/pkg-plist b/net/ntpsec/pkg-plist
new file mode 100644
index 000000000000..79ec90874e6e
--- /dev/null
+++ b/net/ntpsec/pkg-plist
@@ -0,0 +1,43 @@
+bin/ntpdig
+bin/ntpfrob
+bin/ntpkeygen
+bin/ntpleapfetch
+bin/ntplogtemp
+bin/ntpmon
+bin/ntpq
+bin/ntpsnmpd
+bin/ntpsweep
+bin/ntptime
+bin/ntptrace
+bin/ntpviz
+bin/ntpwait
+%%PYTHON_SITELIBDIR%%/ntp-1.1.4.egg-info
+%%PYTHON_SITELIBDIR%%/ntp/__init__.py
+%%PYTHON_SITELIBDIR%%/ntp/__init__.pyc
+%%PYTHON_SITELIBDIR%%/ntp/__init__.pyo
+%%PYTHON_SITELIBDIR%%/ntp/agentx.py
+%%PYTHON_SITELIBDIR%%/ntp/agentx.pyc
+%%PYTHON_SITELIBDIR%%/ntp/agentx.pyo
+%%PYTHON_SITELIBDIR%%/ntp/agentx_packet.py
+%%PYTHON_SITELIBDIR%%/ntp/agentx_packet.pyc
+%%PYTHON_SITELIBDIR%%/ntp/agentx_packet.pyo
+%%PYTHON_SITELIBDIR%%/ntp/control.py
+%%PYTHON_SITELIBDIR%%/ntp/control.pyc
+%%PYTHON_SITELIBDIR%%/ntp/control.pyo
+%%PYTHON_SITELIBDIR%%/ntp/magic.py
+%%PYTHON_SITELIBDIR%%/ntp/magic.pyc
+%%PYTHON_SITELIBDIR%%/ntp/magic.pyo
+%%PYTHON_SITELIBDIR%%/ntp/ntpc.so
+%%PYTHON_SITELIBDIR%%/ntp/packet.py
+%%PYTHON_SITELIBDIR%%/ntp/packet.pyc
+%%PYTHON_SITELIBDIR%%/ntp/packet.pyo
+%%PYTHON_SITELIBDIR%%/ntp/poly.py
+%%PYTHON_SITELIBDIR%%/ntp/poly.pyc
+%%PYTHON_SITELIBDIR%%/ntp/poly.pyo
+%%PYTHON_SITELIBDIR%%/ntp/statfiles.py
+%%PYTHON_SITELIBDIR%%/ntp/statfiles.pyc
+%%PYTHON_SITELIBDIR%%/ntp/statfiles.pyo
+%%PYTHON_SITELIBDIR%%/ntp/util.py
+%%PYTHON_SITELIBDIR%%/ntp/util.pyc
+%%PYTHON_SITELIBDIR%%/ntp/util.pyo
+sbin/ntpd