aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/open-vm-tools/Makefile6
-rw-r--r--emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h13
2 files changed, 18 insertions, 1 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index 0c25bc0995c6..2db822f9ccc8 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -4,7 +4,7 @@
PORTNAME= open-vm-tools
PORTVERSION= ${RELEASE_VER}
DISTVERSIONPREFIX= stable-
-PORTREVISION= 5
+PORTREVISION= 6
PORTEPOCH= 2
CATEGORIES= emulators
@@ -65,6 +65,10 @@ INSTALL_TARGET= install-strip
.include <bsd.port.options.mk>
+.if ${OPSYS} == FreeBSD && ${OSVERSION} > 1200063
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-modules_freebsd_vmxnet_net__compat.h
+.endif
+
.if ${PORT_OPTIONS:MX11}
CONFLICTS= open-vm-tools-nox11-[0-9]*
.else
diff --git a/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h b/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h
new file mode 100644
index 000000000000..bcb2b969c792
--- /dev/null
+++ b/emulators/open-vm-tools/files/extra-patch-modules_freebsd_vmxnet_net__compat.h
@@ -0,0 +1,13 @@
+--- modules/freebsd/vmxnet/net_compat.h.orig 2018-05-23 22:11:09 UTC
++++ modules/freebsd/vmxnet/net_compat.h
+@@ -38,8 +38,8 @@
+ #define VXN_IFMULTI_FIRST LIST_FIRST
+ #define VXN_IFMULTI_NEXT LIST_NEXT
+ #else /* >= 500016 */
+- #define VXN_IFMULTI_FIRST TAILQ_FIRST
+- #define VXN_IFMULTI_NEXT TAILQ_NEXT
++ #define VXN_IFMULTI_FIRST CK_STAILQ_FIRST
++ #define VXN_IFMULTI_NEXT CK_STAILQ_NEXT
+ #endif /* 500016 */
+
+ #if __FreeBSD_version < 500043