aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/frei0r-plugins-gavl/Makefile1
-rw-r--r--graphics/frei0r-plugins-opencv/Makefile1
-rw-r--r--graphics/frei0r-plugins/Makefile1
-rw-r--r--graphics/frei0r/Makefile4
4 files changed, 2 insertions, 5 deletions
diff --git a/graphics/frei0r-plugins-gavl/Makefile b/graphics/frei0r-plugins-gavl/Makefile
index 4da853a61595..c3ca6c28d5c4 100644
--- a/graphics/frei0r-plugins-gavl/Makefile
+++ b/graphics/frei0r-plugins-gavl/Makefile
@@ -4,5 +4,4 @@ MASTERDIR= ${.CURDIR}/../frei0r
BUILDING_FREI0R_GAVL= yes
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/frei0r-plugins-opencv/Makefile b/graphics/frei0r-plugins-opencv/Makefile
index 44333da78d41..ee4310eb508c 100644
--- a/graphics/frei0r-plugins-opencv/Makefile
+++ b/graphics/frei0r-plugins-opencv/Makefile
@@ -4,5 +4,4 @@ MASTERDIR= ${.CURDIR}/../frei0r
BUILDING_FREI0R_OPENCV= yes
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/graphics/frei0r-plugins/Makefile b/graphics/frei0r-plugins/Makefile
index c90da5a33d6b..cc2f59e9d396 100644
--- a/graphics/frei0r-plugins/Makefile
+++ b/graphics/frei0r-plugins/Makefile
@@ -24,7 +24,6 @@ OPTIONS_DEFAULT= GAVL OPENCV
GAVL_DESC= Install gavl plugins
OPENCV_DESC= Install OpenCV plugins
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
.include <bsd.port.options.mk>
diff --git a/graphics/frei0r/Makefile b/graphics/frei0r/Makefile
index a69894531ed3..c66f57748a27 100644
--- a/graphics/frei0r/Makefile
+++ b/graphics/frei0r/Makefile
@@ -91,10 +91,10 @@ post-patch:
${WRKSRC}/doc/Makefile.in
.else
do-install:
- @${MKDIR} ${PREFIX}/lib/frei0r-1
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/frei0r-1
. for FILE in ${FREI0R_PLUGINS}
@${INSTALL_LIB} ${BUILD_WRKSRC}/.libs/${FILE}.so \
- ${PREFIX}/lib/frei0r-1/${FILE}.so
+ ${STAGEDIR}${PREFIX}/lib/frei0r-1/${FILE}.so
. endfor
.endif #!defined(FREI0R_PLUGINS)