aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-url-mount/Makefile22
-rw-r--r--www/rubygem-url-mount/distinfo2
-rw-r--r--www/rubygem-url-mount/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 7197b6123346..1fc0022e18f1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1669,6 +1669,7 @@
SUBDIR += rubygem-uglifier
SUBDIR += rubygem-unicorn
SUBDIR += rubygem-url_escape
+ SUBDIR += rubygem-url-mount
SUBDIR += rubygem-webmock
SUBDIR += rubygem-webrobots
SUBDIR += rubygem-yapra
diff --git a/www/rubygem-url-mount/Makefile b/www/rubygem-url-mount/Makefile
new file mode 100644
index 000000000000..6b24d6189b56
--- /dev/null
+++ b/www/rubygem-url-mount/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: rubygem-url_mount
+# Date created: 2 January 2012
+# Whom: Rodrigo Nicola Lombardo <rodnic@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= url_mount
+PORTVERSION= 0.2.1
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= rodnic@gmail.com
+COMMENT= Glue to allow mounted rack applications to know where they're mounted
+
+RUN_DEPENDS= rubygem-rack>=0:${PORTSDIR}/www/rubygem-rack
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-url-mount/distinfo b/www/rubygem-url-mount/distinfo
new file mode 100644
index 000000000000..a166568f11e7
--- /dev/null
+++ b/www/rubygem-url-mount/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/url_mount-0.2.1.gem) = 44b98f9d08ed550a1421679fdf2e1c112bce66950f87a63c6205d4783a0566ad
+SIZE (rubygem/url_mount-0.2.1.gem) = 16896
diff --git a/www/rubygem-url-mount/pkg-descr b/www/rubygem-url-mount/pkg-descr
new file mode 100644
index 000000000000..2ce3b10606a0
--- /dev/null
+++ b/www/rubygem-url-mount/pkg-descr
@@ -0,0 +1,7 @@
+UrlMount is a universal mount point designed for use in rack applications.
+It provides a simple way to pass a url mounting point to the mounted application.
+
+This means that when you mount an application in the url space, it's a simple call to url to get the mount point of where
+the application is.
+
+WWW: https://github.com/hassox/url_mount