aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/p5-Audio-MPD/Makefile8
-rw-r--r--security/p5-Authen-Bitcard/Makefile8
-rw-r--r--security/p5-Crypt-OpenSSL-CA/Makefile8
-rw-r--r--security/p5-Crypt-SSLeay/Makefile8
-rw-r--r--security/p5-Data-Entropy/Makefile8
-rw-r--r--security/p5-Digest-SHA/Makefile11
-rw-r--r--security/p5-Digest-SHA1/Makefile9
-rw-r--r--security/p5-Module-Signature/Makefile5
-rw-r--r--security/p5-POE-Component-SSLify/Makefile14
9 files changed, 9 insertions, 70 deletions
diff --git a/audio/p5-Audio-MPD/Makefile b/audio/p5-Audio-MPD/Makefile
index 8541a2c6445c..afd6db401209 100644
--- a/audio/p5-Audio-MPD/Makefile
+++ b/audio/p5-Audio-MPD/Makefile
@@ -38,10 +38,4 @@ MAN3= Audio::MPD.3 \
Audio::MPD::Playlist.3 \
Audio::MPD::Types.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-Bitcard/Makefile b/security/p5-Authen-Bitcard/Makefile
index 491014a7daf0..169135294f27 100644
--- a/security/p5-Authen-Bitcard/Makefile
+++ b/security/p5-Authen-Bitcard/Makefile
@@ -23,10 +23,4 @@ PERL_CONFIGURE= yes
MAN3= Authen::Bitcard.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501000
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-OpenSSL-CA/Makefile b/security/p5-Crypt-OpenSSL-CA/Makefile
index 8e99fe234406..9fe3271ecf66 100644
--- a/security/p5-Crypt-OpenSSL-CA/Makefile
+++ b/security/p5-Crypt-OpenSSL-CA/Makefile
@@ -34,10 +34,4 @@ MAN3= Crypt::OpenSSL::CA.3 \
Crypt::OpenSSL::CA::Inline::C.3 \
Crypt::OpenSSL::CA::Resources.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-Module-Build>=0.2900:${PORTSDIR}/devel/p5-Module-Build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-SSLeay/Makefile b/security/p5-Crypt-SSLeay/Makefile
index f8f5fefcbfbb..f44486c4a1d2 100644
--- a/security/p5-Crypt-SSLeay/Makefile
+++ b/security/p5-Crypt-SSLeay/Makefile
@@ -27,14 +27,8 @@ USE_OPENSSL= yes
MAN3= Crypt::SSLeay.3 Net::SSL.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-TEST_DEPENDS+= p5-Test-Simple>=0.88:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
post-patch:
@${REINPLACE_CMD} -e '/LIBS/ s|-lssl32 -lssleay32 -leay32|-L${OPENSSLLIB}|' \
-e '/is_live_test_wanted()/d' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Data-Entropy/Makefile b/security/p5-Data-Entropy/Makefile
index ab87abeea908..247109281570 100644
--- a/security/p5-Data-Entropy/Makefile
+++ b/security/p5-Data-Entropy/Makefile
@@ -29,10 +29,4 @@ MAN3= Data::Entropy.3 \
Data::Entropy::RawSource::RandomnumbersInfo.3 \
Data::Entropy::Source.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-RUN_DEPENDS+= p5-parent>=0:${PORTSDIR}/devel/p5-parent
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-SHA/Makefile b/security/p5-Digest-SHA/Makefile
index 44eea6f59e27..316f42315696 100644
--- a/security/p5-Digest-SHA/Makefile
+++ b/security/p5-Digest-SHA/Makefile
@@ -20,18 +20,11 @@ PERL_CONFIGURE= yes
MAN3= Digest::SHA.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 501000
-PLIST_SUB+= EXE_FILES="@comment "
-.else
+# XXX:az - pkg-plist
PLIST_SUB+= EXE_FILES=""
MAN1= shasum.1
-.endif
post-patch:
-.if ${PERL_LEVEL} >= 501000
@${REINPLACE_CMD} -e '/EXE_FILES/d' ${WRKSRC}/Makefile.PL
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Digest-SHA1/Makefile b/security/p5-Digest-SHA1/Makefile
index 00b9670922e3..bc49602ad0a8 100644
--- a/security/p5-Digest-SHA1/Makefile
+++ b/security/p5-Digest-SHA1/Makefile
@@ -18,11 +18,4 @@ PERL_CONFIGURE= yes
MAN3= Digest::SHA1.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500803
-BUILD_DEPENDS+= p5-Digest>=1.00:${PORTSDIR}/security/p5-Digest
-RUN_DEPENDS+= p5-Digest>=1.00:${PORTSDIR}/security/p5-Digest
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/p5-Module-Signature/Makefile b/security/p5-Module-Signature/Makefile
index 94995b78343c..d9c02561e51c 100644
--- a/security/p5-Module-Signature/Makefile
+++ b/security/p5-Module-Signature/Makefile
@@ -39,9 +39,4 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/gpgv2:${PORTSDIR}/security/gnupg
RUN_DEPENDS+= ${LOCALBASE}/bin/gpgv2:${PORTSDIR}/security/gnupg
.endif
-.if ${PERL_LEVEL} < 501000
-BUILD_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-RUN_DEPENDS+= p5-Digest-SHA>=0:${PORTSDIR}/security/p5-Digest-SHA
-.endif
-
.include <bsd.port.post.mk>
diff --git a/security/p5-POE-Component-SSLify/Makefile b/security/p5-POE-Component-SSLify/Makefile
index b1352e2d81f2..a7d9c0a5c85b 100644
--- a/security/p5-POE-Component-SSLify/Makefile
+++ b/security/p5-POE-Component-SSLify/Makefile
@@ -28,16 +28,4 @@ MAN3= POE::Component::SSLify.3 \
POE::Component::SSLify::ClientHandle.3 \
POE::Component::SSLify::ServerHandle.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500809
-BUILD_DEPENDS+= p5-ExtUtils-MakeMaker>=6.31:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
-RUN_DEPENDS+= p5-ExtUtils-MakeMaker>=6.31:${PORTSDIR}/devel/p5-ExtUtils-MakeMaker
-.endif
-
-.if ${PERL_LEVEL} < 501001
-BUILD_DEPENDS+= p5-IO>=1.28:${PORTSDIR}/devel/p5-IO
-RUN_DEPENDS+= p5-IO>=1.28:${PORTSDIR}/devel/p5-IO
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>