aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/reminiscence/Makefile44
-rw-r--r--games/reminiscence/distinfo3
-rw-r--r--games/reminiscence/files/patch-main.cpp34
-rw-r--r--games/reminiscence/pkg-descr7
-rw-r--r--games/reminiscence/pkg-message18
-rw-r--r--games/reminiscence/pkg-plist4
7 files changed, 111 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 6f5dd927b738..2bdff241bdf9 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -521,6 +521,7 @@
SUBDIR += quit
SUBDIR += qwdtools
SUBDIR += race
+ SUBDIR += reminiscence
SUBDIR += rfksay
SUBDIR += robocode
SUBDIR += robotfindskitten
diff --git a/games/reminiscence/Makefile b/games/reminiscence/Makefile
new file mode 100644
index 000000000000..10a8e12b5f88
--- /dev/null
+++ b/games/reminiscence/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: REminiscence
+# Date created: 11 Feb 2005
+# Whom: Dmitry Marakasov <amdmi3@mail.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= REminiscence
+PORTVERSION= 0.1.8
+CATEGORIES= games
+MASTER_SITES= http://membres.lycos.fr/cyxdown/reminiscence/
+
+MAINTAINER= amdmi3@mail.ru
+COMMENT= A rewritten engine for Flashback
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_SDL= sdl
+
+ALL_TARGET= rs
+
+PORTDOCS= README
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^CXX =/ d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CXXFLAGS:=/ d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e '/^CXXFLAGS+=.*-W/ d' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|DATA|${DATADIR}/data|' ${WRKSRC}/main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rs ${PREFIX}/bin/remin
+ ${MKDIR} ${DATADIR}/data
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/games/reminiscence/distinfo b/games/reminiscence/distinfo
new file mode 100644
index 000000000000..3c52c8b19a71
--- /dev/null
+++ b/games/reminiscence/distinfo
@@ -0,0 +1,3 @@
+MD5 (REminiscence-0.1.8.tar.bz2) = fc4ca3aaec770573a7ba5513b2927d15
+SHA256 (REminiscence-0.1.8.tar.bz2) = 1d66f8abf26f9d7f5738d30276069395feab821533bb702e95e32ff478842d2f
+SIZE (REminiscence-0.1.8.tar.bz2) = 91722
diff --git a/games/reminiscence/files/patch-main.cpp b/games/reminiscence/files/patch-main.cpp
new file mode 100644
index 000000000000..ec8d2838091b
--- /dev/null
+++ b/games/reminiscence/files/patch-main.cpp
@@ -0,0 +1,34 @@
+--- main.cpp.orig Tue Aug 23 22:26:20 2005
++++ main.cpp Sat Feb 11 07:53:56 2006
+@@ -19,6 +19,7 @@
+ #include "file.h"
+ #include "game.h"
+ #include "systemstub.h"
++#include <sys/stat.h>
+
+ static const char *USAGE =
+ "REminiscence - Flashback Interpreter\n"
+@@ -59,8 +60,15 @@
+
+ #undef main
+ int main(int argc, char *argv[]) {
++ char *homedir = getenv("HOME");
++ char *dotdir = "/.REminiscence";
++ char *buf = (char*)malloc(strlen(homedir) + strlen(dotdir) + 1);
++ strcpy(buf, homedir);
++ strcat(buf, dotdir);
++ mkdir(buf, 0755);
++
+ const char *dataPath = "DATA";
+- const char *savePath = ".";
++ const char *savePath = buf;
+ for (int i = 1; i < argc; ++i) {
+ bool opt = false;
+ if (strlen(argv[i]) >= 2) {
+@@ -79,5 +87,6 @@
+ g->run();
+ delete g;
+ delete stub;
++ free(buf);
+ return 0;
+ }
diff --git a/games/reminiscence/pkg-descr b/games/reminiscence/pkg-descr
new file mode 100644
index 000000000000..447837b65723
--- /dev/null
+++ b/games/reminiscence/pkg-descr
@@ -0,0 +1,7 @@
+REminiscence is a rewrite of the engine used in the game Flashback
+from Delphine Software. This program is designed as a cross-platform
+replacement for the original executable and uses the SDL library.
+It allows you to rediscover and play it on modern machines using
+the original datafiles.
+
+WWW: http://membres.lycos.fr/cyxdown/reminiscence/
diff --git a/games/reminiscence/pkg-message b/games/reminiscence/pkg-message
new file mode 100644
index 000000000000..ff9e2e81fa44
--- /dev/null
+++ b/games/reminiscence/pkg-message
@@ -0,0 +1,18 @@
+==========================================================================
+
+REminiscence requires original Flashback datafiles. Copy the following
+files to ${PREFIX}/share/REminiscence/data/ directory:
+
+ FB_TXT.FNT GLOBAL.ICN GLOBAL.FIB GLOBAL.SPC *.OFF *.SPR *.MAP *.PAL
+ *.ANI *.CT *.MBK *.OBJ *.PGE *.RP *.TBN *.CMD *.POL *CINE.*
+
+If you have a version distributed by SSI, you'll have to rename some files :
+
+ logosssi.cmd -> logos.cmd
+ logosssi.pol -> logos.pol
+ menu1ssi.map -> menu1.map
+ menu1ssi.pal -> menu1.pal
+
+See README for details
+
+==========================================================================
diff --git a/games/reminiscence/pkg-plist b/games/reminiscence/pkg-plist
new file mode 100644
index 000000000000..6a6b9017860e
--- /dev/null
+++ b/games/reminiscence/pkg-plist
@@ -0,0 +1,4 @@
+bin/remin
+@exec mkdir -p %D/share/REminiscence/data
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%