aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/gcipher/Makefile75
-rw-r--r--security/gcipher/distinfo4
-rw-r--r--security/gcipher/files/patch-Const.py9
-rw-r--r--security/gcipher/files/patch-gcipher16
-rw-r--r--security/gcipher/pkg-descr11
-rw-r--r--security/gcipher/pkg-plist145
6 files changed, 127 insertions, 133 deletions
diff --git a/security/gcipher/Makefile b/security/gcipher/Makefile
index dedcac8a15c3..4dde9ec402dc 100644
--- a/security/gcipher/Makefile
+++ b/security/gcipher/Makefile
@@ -6,57 +6,58 @@
#
PORTNAME= gcipher
-PORTVERSION= 1.0
-PORTREVISION= 14
+PORTVERSION= 1.1
CATEGORIES= security gnome
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A simple encryption tool
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/gtk-2.0/gnome/__init__.py:${PORTSDIR}/x11-toolkits/py-gnome2
+LICENSE= BSD
+USE_GNOME= pygnome2
USE_PYTHON= yes
-USE_GNOME= libgnomeui
-GCIPHER_PREFIX= ${PREFIX}/share/gcipher
-
-MAN1= gcipher.1
+MAN1= gcipher.1
+LICENSE_FILES= ${WRKSRC}/LICENSE
post-patch:
- @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
- ${WRKSRC}/src/Const.py ${WRKSRC}/src/gcipher
+ @${REINPLACE_CMD} -e \
+ '/^VERSION/s|=.*|= "${PORTVERSION}"|g ; \
+ /^GLADEDIR/s|=.*|= "${DATADIR}/lib"|g' ${WRKSRC}/src/Const.py
+ @${REINPLACE_CMD} -e \
+ 's|/usr/bin/python|${SETENV} python|g ; \
+ s|^# sys.path.append|sys.path.append|g ; \
+ s|/usr/share/gcipher/lib|${DATADIR}/lib|' ${WRKSRC}/src/gcipher
do-build:
- (cd ${WRKSRC}/src; \
- ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py .)
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/src
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}/src
do-install:
- ${MKDIR} \
- ${GCIPHER_PREFIX}/lib/cipher \
- ${GCIPHER_PREFIX}/lib/ciphergui \
- ${GCIPHER_PREFIX}/plugins/cipher \
- ${GCIPHER_PREFIX}/plugins/ciphergui
-
- (cd ${WRKSRC}; \
- ${INSTALL_MAN} gcipher.1 ${PREFIX}/man/man1; \
- ${INSTALL_DATA} CONTRIB LICENSE README "${GCIPHER_PREFIX}")
-
- (cd ${WRKSRC}/src; \
- ${INSTALL_SCRIPT} gcipher ${PREFIX}/bin/gcipher; \
- ${INSTALL_DATA} gcipher.desktop ${PREFIX}/share/applications; \
- for i in `${FIND} . -name '*.py' \
- -o -name '*.pyc' \
- -o -name '*.glade' \
- -o -name '*.gladep'`; do \
- ${INSTALL_DATA} "$$i" "${GCIPHER_PREFIX}/lib/$$i"; \
- done)
-
- (cd ${WRKSRC}/plugins; \
- for i in `${FIND} . -name '*.py' \
- -o -name '*.glade' \
- -o -name '*.gladep'`; do \
- ${INSTALL_DATA} "$$i" "${GCIPHER_PREFIX}/plugins/$$i"; \
- done)
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/gcipher ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/gcipher.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/src/gcipher.desktop ${PREFIX}/share/applications
+ @${MKDIR} ${DATADIR}/lib
+ @(cd ${WRKSRC}/src && \
+ ${FIND} . -name '*.glade' \
+ -o -name '*.gladep' \
+ -o -name '*.py' \
+ -o -name '*.pyc' \
+ -o -name '*.pyo' | \
+ ${CPIO} -pdm -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}/lib)
+ @${MKDIR} ${DATADIR}/plugins
+ @(cd ${WRKSRC}/plugins && \
+ ${FIND} . -name '*.glade' \
+ -o -name '*.gladep' \
+ -o -name '*.py' | \
+ ${CPIO} -pdm -R ${SHAREOWN}:${SHAREGRP} ${DATADIR}/plugins)
+ @${FIND} ${DATADIR} -type d | ${XARGS} ${CHMOD} a+rx
+ @${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC} && \
+ ${INSTALL_DATA} CONTRIB README ${DOCSDIR})
+.endif
.include <bsd.port.mk>
diff --git a/security/gcipher/distinfo b/security/gcipher/distinfo
index 391885a8aec8..f0c391b016cc 100644
--- a/security/gcipher/distinfo
+++ b/security/gcipher/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gcipher-1.0.tar.gz) = a06b5b34dc88b00cd713e5834b5b240e7df344df41f3200f6e2b5693b28bc369
-SIZE (gcipher-1.0.tar.gz) = 18125
+SHA256 (gcipher-1.1.tar.gz) = 2f55367bd837baa614779ec9b5aca76c8b1f0866bd648b4bd30fe7db15cd3a7b
+SIZE (gcipher-1.1.tar.gz) = 20137
diff --git a/security/gcipher/files/patch-Const.py b/security/gcipher/files/patch-Const.py
deleted file mode 100644
index b4b94da306da..000000000000
--- a/security/gcipher/files/patch-Const.py
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -ur ../gcipher-1.0.orig/src/Const.py ./src/Const.py
---- ../gcipher-1.0.orig/src/Const.py Wed Jun 25 14:03:43 2003
-+++ ./src/Const.py Wed Jun 25 14:05:59 2003
-@@ -9,4 +9,4 @@
- Read Help/Contents to learn how to use gcipher
- as a command line filter or as a network proxy."""
- AUTHORS = ["Shannon -jj Behrens <jjinux@yahoo.com>"]
--GLADEDIR = "."
-+GLADEDIR = "%%PREFIX%%/share/gcipher/lib"
diff --git a/security/gcipher/files/patch-gcipher b/security/gcipher/files/patch-gcipher
deleted file mode 100644
index 2e7ba1abc059..000000000000
--- a/security/gcipher/files/patch-gcipher
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ur ../gcipher-1.0.orig/src/gcipher ./src/gcipher
---- ../gcipher-1.0.orig/src/gcipher Wed Jun 25 14:03:43 2003
-+++ ./src/gcipher Wed Jun 25 14:06:14 2003
-@@ -1,10 +1,10 @@
--#!/usr/bin/python
-+#!/usr/local/bin/python
-
- """This is the main executable script."""
-
- # Edit the path below if you need to port GCipher.
- import sys
--# sys.path.append("/usr/share/gcipher/lib")
-+sys.path.append("%%PREFIX%%/share/gcipher/lib")
-
- from os import environ
- from os.path import join
diff --git a/security/gcipher/pkg-descr b/security/gcipher/pkg-descr
index 0319dfec8e44..ac5c5ec0b8f1 100644
--- a/security/gcipher/pkg-descr
+++ b/security/gcipher/pkg-descr
@@ -1,7 +1,6 @@
-This is a simple encryption tool to work with home-grown encryption algorithms.
-It can run as either a GUI, a command-line application, or a network proxy.
+This is a simple encryption tool to work with home-grown encryption
+algorithms. It can run as either a GUI, a command-line application, or
+a network proxy.
-WWW: http://gcipher.sourceforge.net
-
-- Shannon -jj Behrens
-jjinux@yahoo.com
+Author: Shannon -jj Behrens <jjinux@yahoo.com>
+WWW: http://gcipher.sourceforge.net
diff --git a/security/gcipher/pkg-plist b/security/gcipher/pkg-plist
index 2e0d6874038b..7e743434b4c5 100644
--- a/security/gcipher/pkg-plist
+++ b/security/gcipher/pkg-plist
@@ -1,66 +1,85 @@
bin/gcipher
share/applications/gcipher.desktop
-share/gcipher/CONTRIB
-share/gcipher/LICENSE
-share/gcipher/README
-share/gcipher/lib/cipher/__init__.pyc
-share/gcipher/lib/cipher/Ceasar.py
-share/gcipher/lib/cipher/CharacterCipher.py
-share/gcipher/lib/cipher/Gie.py
-share/gcipher/lib/cipher/KeyedCipher.py
-share/gcipher/lib/cipher/Rot.py
-share/gcipher/lib/cipher/Tools.py
-share/gcipher/lib/cipher/Vigenere.py
-share/gcipher/lib/cipher/__init__.py
-share/gcipher/lib/cipher/KeyedCipher.pyc
-share/gcipher/lib/cipher/Vigenere.pyc
-share/gcipher/lib/cipher/CharacterCipher.pyc
-share/gcipher/lib/cipher/Tools.pyc
-share/gcipher/lib/cipher/Gie.pyc
-share/gcipher/lib/cipher/Ceasar.pyc
-share/gcipher/lib/cipher/Rot.pyc
-share/gcipher/lib/AutomaticClass.py
-share/gcipher/lib/Const.py
-share/gcipher/lib/GtkAttributesFacade.py
-share/gcipher/lib/LibGladeApplication.py
-share/gcipher/lib/MainCLI.py
-share/gcipher/lib/MainGUI.py
-share/gcipher/lib/Proxy.py
-share/gcipher/lib/gcipher.glade
-share/gcipher/lib/gcipher.gladep
-share/gcipher/lib/ciphergui/__init__.pyc
-share/gcipher/lib/ciphergui/Ceasar.py
-share/gcipher/lib/ciphergui/CipherGUIList.py
-share/gcipher/lib/ciphergui/Gie.py
-share/gcipher/lib/ciphergui/KeyDialog.py
-share/gcipher/lib/ciphergui/Rot.py
-share/gcipher/lib/ciphergui/Vigenere.py
-share/gcipher/lib/ciphergui/__init__.py
-share/gcipher/lib/ciphergui/rot.glade
-share/gcipher/lib/ciphergui/rot.gladep
-share/gcipher/lib/ciphergui/vigenere.glade
-share/gcipher/lib/ciphergui/vigenere.gladep
-share/gcipher/lib/ciphergui/CipherGUIList.pyc
-share/gcipher/lib/ciphergui/Vigenere.pyc
-share/gcipher/lib/ciphergui/KeyDialog.pyc
-share/gcipher/lib/ciphergui/Gie.pyc
-share/gcipher/lib/ciphergui/Ceasar.pyc
-share/gcipher/lib/ciphergui/Rot.pyc
-share/gcipher/lib/Const.pyc
-share/gcipher/lib/MainCLI.pyc
-share/gcipher/lib/AutomaticClass.pyc
-share/gcipher/lib/MainGUI.pyc
-share/gcipher/lib/LibGladeApplication.pyc
-share/gcipher/lib/GtkAttributesFacade.pyc
-share/gcipher/lib/Proxy.pyc
-share/gcipher/plugins/cipher/Identity.py
-share/gcipher/plugins/ciphergui/Identity.py
-share/gcipher/plugins/ciphergui/PluginCipherGUIList.py
-@dirrm share/gcipher/lib/cipher
-@dirrm share/gcipher/lib/ciphergui
-@dirrm share/gcipher/lib
-@dirrm share/gcipher/plugins/cipher
-@dirrm share/gcipher/plugins/ciphergui
-@dirrm share/gcipher/plugins
-@dirrm share/gcipher
+%%PORTDOCS%%%%DOCSDIR%%/CONTRIB
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/lib/AutomaticClass.py
+%%DATADIR%%/lib/AutomaticClass.pyc
+%%DATADIR%%/lib/AutomaticClass.pyo
+%%DATADIR%%/lib/Const.py
+%%DATADIR%%/lib/Const.pyc
+%%DATADIR%%/lib/Const.pyo
+%%DATADIR%%/lib/GtkAttributesFacade.py
+%%DATADIR%%/lib/GtkAttributesFacade.pyc
+%%DATADIR%%/lib/GtkAttributesFacade.pyo
+%%DATADIR%%/lib/LibGladeApplication.py
+%%DATADIR%%/lib/LibGladeApplication.pyc
+%%DATADIR%%/lib/LibGladeApplication.pyo
+%%DATADIR%%/lib/MainCLI.py
+%%DATADIR%%/lib/MainCLI.pyc
+%%DATADIR%%/lib/MainCLI.pyo
+%%DATADIR%%/lib/MainGUI.py
+%%DATADIR%%/lib/MainGUI.pyc
+%%DATADIR%%/lib/MainGUI.pyo
+%%DATADIR%%/lib/Proxy.py
+%%DATADIR%%/lib/Proxy.pyc
+%%DATADIR%%/lib/Proxy.pyo
+%%DATADIR%%/lib/cipher/Caesar.py
+%%DATADIR%%/lib/cipher/Caesar.pyc
+%%DATADIR%%/lib/cipher/Caesar.pyo
+%%DATADIR%%/lib/cipher/CharacterCipher.py
+%%DATADIR%%/lib/cipher/CharacterCipher.pyc
+%%DATADIR%%/lib/cipher/CharacterCipher.pyo
+%%DATADIR%%/lib/cipher/Gie.py
+%%DATADIR%%/lib/cipher/Gie.pyc
+%%DATADIR%%/lib/cipher/Gie.pyo
+%%DATADIR%%/lib/cipher/KeyedCipher.py
+%%DATADIR%%/lib/cipher/KeyedCipher.pyc
+%%DATADIR%%/lib/cipher/KeyedCipher.pyo
+%%DATADIR%%/lib/cipher/Rot.py
+%%DATADIR%%/lib/cipher/Rot.pyc
+%%DATADIR%%/lib/cipher/Rot.pyo
+%%DATADIR%%/lib/cipher/Tools.py
+%%DATADIR%%/lib/cipher/Tools.pyc
+%%DATADIR%%/lib/cipher/Tools.pyo
+%%DATADIR%%/lib/cipher/Vigenere.py
+%%DATADIR%%/lib/cipher/Vigenere.pyc
+%%DATADIR%%/lib/cipher/Vigenere.pyo
+%%DATADIR%%/lib/cipher/__init__.py
+%%DATADIR%%/lib/cipher/__init__.pyc
+%%DATADIR%%/lib/cipher/__init__.pyo
+%%DATADIR%%/lib/ciphergui/Caesar.py
+%%DATADIR%%/lib/ciphergui/Caesar.pyc
+%%DATADIR%%/lib/ciphergui/Caesar.pyo
+%%DATADIR%%/lib/ciphergui/CipherGUIList.py
+%%DATADIR%%/lib/ciphergui/CipherGUIList.pyc
+%%DATADIR%%/lib/ciphergui/CipherGUIList.pyo
+%%DATADIR%%/lib/ciphergui/Gie.py
+%%DATADIR%%/lib/ciphergui/Gie.pyc
+%%DATADIR%%/lib/ciphergui/Gie.pyo
+%%DATADIR%%/lib/ciphergui/KeyDialog.py
+%%DATADIR%%/lib/ciphergui/KeyDialog.pyc
+%%DATADIR%%/lib/ciphergui/KeyDialog.pyo
+%%DATADIR%%/lib/ciphergui/Rot.py
+%%DATADIR%%/lib/ciphergui/Rot.pyc
+%%DATADIR%%/lib/ciphergui/Rot.pyo
+%%DATADIR%%/lib/ciphergui/Vigenere.py
+%%DATADIR%%/lib/ciphergui/Vigenere.pyc
+%%DATADIR%%/lib/ciphergui/Vigenere.pyo
+%%DATADIR%%/lib/ciphergui/__init__.py
+%%DATADIR%%/lib/ciphergui/__init__.pyc
+%%DATADIR%%/lib/ciphergui/__init__.pyo
+%%DATADIR%%/lib/ciphergui/rot.glade
+%%DATADIR%%/lib/ciphergui/vigenere.glade
+%%DATADIR%%/lib/gcipher.glade
+%%DATADIR%%/plugins/cipher/Identity.py
+%%DATADIR%%/plugins/ciphergui/Identity.py
+%%DATADIR%%/plugins/ciphergui/PluginCipherGUIList.py
+@dirrm %%DATADIR%%/plugins/ciphergui
+@dirrm %%DATADIR%%/plugins/cipher
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/lib/ciphergui
+@dirrm %%DATADIR%%/lib/cipher
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications