aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/p5-B-Deobfuscate/Makefile4
-rw-r--r--devel/p5-DateTime-Format-HTTP/Makefile4
-rw-r--r--devel/p5-DateTime-Format-MySQL/Makefile4
-rw-r--r--devel/p5-Devel-RingBuffer/Makefile2
-rw-r--r--devel/p5-Getopt-Compact/Makefile6
-rw-r--r--devel/p5-Iterator/Makefile2
-rw-r--r--devel/p5-Log-Dispatch-Perl/Makefile4
-rw-r--r--devel/p5-POE-Component-RSSAggregator/Makefile4
-rw-r--r--devel/p5-Project-Gantt/Makefile4
-rw-r--r--devel/p5-SVN-ACL/Makefile4
-rw-r--r--devel/p5-SVN-Notify/Makefile4
-rw-r--r--devel/p5-Term-ReadLine-Zoid/Makefile2
-rw-r--r--devel/p5-Test-Dependencies/Makefile11
-rw-r--r--devel/p5-VCP-Source-cvsbk/Makefile2
-rw-r--r--math/p5-Math-Symbolic/Makefile6
15 files changed, 31 insertions, 32 deletions
diff --git a/devel/p5-B-Deobfuscate/Makefile b/devel/p5-B-Deobfuscate/Makefile
index 9c167e3b1d94..12d4a03808db 100644
--- a/devel/p5-B-Deobfuscate/Makefile
+++ b/devel/p5-B-Deobfuscate/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Extension to B::Deparse for use in de-obfuscating source code
-RUN_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
- ${SITE_PERL}/B/Keywords.pm:${PORTSDIR}/devel/p5-B-Keywords
+RUN_DEPENDS= p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML \
+ p5-B-Keywords>=0:${PORTSDIR}/devel/p5-B-Keywords
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-DateTime-Format-HTTP/Makefile b/devel/p5-DateTime-Format-HTTP/Makefile
index 7f1bdade1832..771d4e3de48f 100644
--- a/devel/p5-DateTime-Format-HTTP/Makefile
+++ b/devel/p5-DateTime-Format-HTTP/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= HTTP date conversion routines
BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_MODBUILD= yes
diff --git a/devel/p5-DateTime-Format-MySQL/Makefile b/devel/p5-DateTime-Format-MySQL/Makefile
index f37cc18f0778..b9ec6057f375 100644
--- a/devel/p5-DateTime-Format-MySQL/Makefile
+++ b/devel/p5-DateTime-Format-MySQL/Makefile
@@ -15,8 +15,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Parse and format MySQL dates and times
BUILD_DEPENDS= ${RUN_DEPENDS}
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/DateTime/Format/Builder.pm:${PORTSDIR}/devel/p5-DateTime-Format-Builder
+RUN_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-DateTime-Format-Builder>=0:${PORTSDIR}/devel/p5-DateTime-Format-Builder
PERL_MODBUILD= yes
diff --git a/devel/p5-Devel-RingBuffer/Makefile b/devel/p5-Devel-RingBuffer/Makefile
index bdf10d6f4441..b1dc43590011 100644
--- a/devel/p5-Devel-RingBuffer/Makefile
+++ b/devel/p5-Devel-RingBuffer/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Shared memory ring buffers for Perl scripts diagnosis/debug
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/Mmap.pm:${PORTSDIR}/devel/p5-IPC-Mmap
+RUN_DEPENDS= p5-IPC-Mmap>=0:${PORTSDIR}/devel/p5-IPC-Mmap
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Getopt-Compact/Makefile b/devel/p5-Getopt-Compact/Makefile
index b7baa512da7f..5f9f35e48406 100644
--- a/devel/p5-Getopt-Compact/Makefile
+++ b/devel/p5-Getopt-Compact/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Getopt processing in a compact statement with long and short options
-RUN_DEPENDS= ${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
- ${SITE_PERL}/Text/Table.pm:${PORTSDIR}/textproc/p5-Text-Table \
- ${SITE_PERL}/Env/Path.pm:${PORTSDIR}/devel/p5-Env-Path
+RUN_DEPENDS= p5-Getopt-Long>=0:${PORTSDIR}/devel/p5-Getopt-Long \
+ p5-Text-Table>=0:${PORTSDIR}/textproc/p5-Text-Table \
+ p5-Env-Path>=0:${PORTSDIR}/devel/p5-Env-Path
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Iterator/Makefile b/devel/p5-Iterator/Makefile
index 4afad82c05c7..df1acadacf1f 100644
--- a/devel/p5-Iterator/Makefile
+++ b/devel/p5-Iterator/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A general-purpose iterator class
-BUILD_DEPENDS= ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class
+BUILD_DEPENDS= p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class
RUN_DEPENDS+= ${BUILD_DEPENDS}
MAN3= Iterator.3
diff --git a/devel/p5-Log-Dispatch-Perl/Makefile b/devel/p5-Log-Dispatch-Perl/Makefile
index d324445c8045..93cb0f0c9436 100644
--- a/devel/p5-Log-Dispatch-Perl/Makefile
+++ b/devel/p5-Log-Dispatch-Perl/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= A Log::Dispatch plug-in using core Perl functions for logging
-BUILD_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
- ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+BUILD_DEPENDS= p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-POE-Component-RSSAggregator/Makefile b/devel/p5-POE-Component-RSSAggregator/Makefile
index 9905867e75f3..99595dcf13ca 100644
--- a/devel/p5-POE-Component-RSSAggregator/Makefile
+++ b/devel/p5-POE-Component-RSSAggregator/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Watch Muliple RSS Feeds for New Headlines
-BUILD_DEPENDS= ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/XML/RSS/Feed.pm:${PORTSDIR}/textproc/p5-XML-RSS-Feed \
+BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-XML-RSS-Feed>=0:${PORTSDIR}/textproc/p5-XML-RSS-Feed \
p5-POE-Component-Client-DNS>=0.98:${PORTSDIR}/dns/p5-POE-Component-Client-DNS \
p5-POE-Component-Client-HTTP>=0.51:${PORTSDIR}/www/p5-POE-Component-Client-HTTP
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-Project-Gantt/Makefile b/devel/p5-Project-Gantt/Makefile
index 950851bb4b22..0be67f734d56 100644
--- a/devel/p5-Project-Gantt/Makefile
+++ b/devel/p5-Project-Gantt/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Create Gantt charts to manage project scheduling
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Class/Date.pm:${PORTSDIR}/devel/p5-Class-Date \
- ${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick
+BUILD_DEPENDS= p5-Class-Date>=0:${PORTSDIR}/devel/p5-Class-Date \
+ ImageMagick>=0:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-SVN-ACL/Makefile b/devel/p5-SVN-ACL/Makefile
index 47e13a4dcbed..3d81a9ccd0c2 100644
--- a/devel/p5-SVN-ACL/Makefile
+++ b/devel/p5-SVN-ACL/Makefile
@@ -17,8 +17,8 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= A simple ACL frontend for subversion
BUILD_DEPENDS= \
- ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/p5-subversion \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+ p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-SVN-Notify/Makefile b/devel/p5-SVN-Notify/Makefile
index c2e4969696e9..8fa0ec390c5b 100644
--- a/devel/p5-SVN-Notify/Makefile
+++ b/devel/p5-SVN-Notify/Makefile
@@ -17,9 +17,9 @@ COMMENT= Subversion activity notification
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= ${SITE_PERL}/Net/SMTP_auth.pm:${PORTSDIR}/mail/p5-Net-SMTP_auth \
+RUN_DEPENDS= p5-Net-SMTP_auth>=0:${PORTSDIR}/mail/p5-Net-SMTP_auth \
p5-Text-Trac>=0.10:${PORTSDIR}/textproc/p5-Text-Trac \
- ${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser
+ p5-HTML-Parser>=0:${PORTSDIR}/www/p5-HTML-Parser
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Term-ReadLine-Zoid/Makefile b/devel/p5-Term-ReadLine-Zoid/Makefile
index 51ea888aaf59..c02932ab295c 100644
--- a/devel/p5-Term-ReadLine-Zoid/Makefile
+++ b/devel/p5-Term-ReadLine-Zoid/Makefile
@@ -16,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Provides an interactive input buffer written in plain PERL
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+BUILD_DEPENDS= p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Test-Dependencies/Makefile b/devel/p5-Test-Dependencies/Makefile
index c5ba65f8a698..27cc7aa36e56 100644
--- a/devel/p5-Test-Dependencies/Makefile
+++ b/devel/p5-Test-Dependencies/Makefile
@@ -15,12 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Ensure that your Makefile.PL specifies all module dependencies
-BUILD_DEPENDS= ${SITE_PERL}/B/PerlReq.pm:${PORTSDIR}/devel/p5-rpm-build-perl \
- ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
- ${SITE_PERL}/IPC/Cmd.pm:${PORTSDIR}/devel/p5-IPC-Cmd \
- ${SITE_PERL}/PerlReq/Utils.pm:${PORTSDIR}/devel/p5-rpm-build-perl \
- ${SITE_PERL}/Pod/Strip.pm:${PORTSDIR}/textproc/p5-Pod-Strip \
- ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+BUILD_DEPENDS= p5-rpm-build-perl>=0:${PORTSDIR}/devel/p5-rpm-build-perl \
+ p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-IPC-Cmd>=0:${PORTSDIR}/devel/p5-IPC-Cmd \
+ p5-Pod-Strip>=0:${PORTSDIR}/textproc/p5-Pod-Strip \
+ p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-VCP-Source-cvsbk/Makefile b/devel/p5-VCP-Source-cvsbk/Makefile
index 0fe00c155a45..f0c98188ffd3 100644
--- a/devel/p5-VCP-Source-cvsbk/Makefile
+++ b/devel/p5-VCP-Source-cvsbk/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= VCP source driver for bk exported cvs repository
-BUILD_DEPENDS= ${SITE_PERL}/VCP.pm:${PORTSDIR}/devel/p5-VCP-autrijus
+BUILD_DEPENDS= p5-VCP-autrijus>=0:${PORTSDIR}/devel/p5-VCP-autrijus
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/math/p5-Math-Symbolic/Makefile b/math/p5-Math-Symbolic/Makefile
index d0ee65370f09..fe0c53f340d0 100644
--- a/math/p5-Math-Symbolic/Makefile
+++ b/math/p5-Math-Symbolic/Makefile
@@ -15,9 +15,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Symbolic calculations
-BUILD_DEPENDS= ${SITE_PERL}/Parse/RecDescent.pm:${PORTSDIR}/devel/p5-Parse-RecDescent \
- ${SITE_PERL}/Test/Pod.pm:${PORTSDIR}/devel/p5-Test-Pod \
- ${SITE_PERL}/Test/Pod/Coverage.pm:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+BUILD_DEPENDS= p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent \
+ p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=0:${PORTSDIR}/devel/p5-Test-Pod-Coverage
RUN_DEPENDS:= ${BUILD_DEPENDS}
MAN3= Math::Symbolic.3 \