aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/cooledit/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/editors/cooledit/Makefile b/editors/cooledit/Makefile
index 9efe31c0fcae..80c58e82fe3e 100644
--- a/editors/cooledit/Makefile
+++ b/editors/cooledit/Makefile
@@ -14,13 +14,17 @@ MASTER_SITE_SUBDIR= apps/editors/X
MAINTAINER= brett@peloton.runet.edu
-BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm \
+ intl.1:${PORTSDIR}/devel/gettext
USE_LIBTOOL= yes
-CONFIGURE_ARGS= --disable-mail-author --with-libs='-lcrypt -lreadline'
+USE_XLIB= yes
+USE_GMAKE= yes
-USE_GMAKE= yes
+CONFIGURE_ARGS= --disable-mail-author --with-libs='-lcrypt -lreadline' \
+ --without-included-gettext
+CONFIGURE_ENV= CC="${CC} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1 = cooledit.1 smalledit.1 coolman.1 coolicon.1