aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/popup-stacks/Makefile39
-rw-r--r--textproc/popup-stacks/distinfo6
-rw-r--r--textproc/popup-stacks/pkg-descr6
4 files changed, 52 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b5565d0b300d..3ba5af45dca4 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -717,6 +717,7 @@
SUBDIR += po4a
SUBDIR += pocketreader
SUBDIR += popup
+ SUBDIR += popup-stacks
SUBDIR += ppower4
SUBDIR += print-n-times
SUBDIR += prosper
diff --git a/textproc/popup-stacks/Makefile b/textproc/popup-stacks/Makefile
new file mode 100644
index 000000000000..03b41942133e
--- /dev/null
+++ b/textproc/popup-stacks/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: popup
+# Date created: 18 Dec 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= popup
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://popup.sourceforge.net/files/cstack/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= -stacks${PKGNAMESUFFIX2}
+DISTFILES= English-German.cstack.gz German-French.cstack.gz
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Stacks for use with Popup
+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}
+STACKS= English-German.cstack German-French.cstack
+PLIST_DIRS= share/examples/popup
+.for i in ${STACKS}
+PLIST_FILES+= share/examples/popup/${i}
+.endfor
+
+do-extract:
+ ${MKDIR} ${WRKDIR}
+.for i in ${DISTFILES}
+ ${CP} ${DISTDIR}/${i} ${WRKDIR}/
+ ${GZIP_CMD} -d ${WRKDIR}/${i}
+.endfor
+
+do-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKDIR} && ${INSTALL_DATA} ${STACKS} ${EXAMPLESDIR}/)
+
+.include <bsd.port.mk>
diff --git a/textproc/popup-stacks/distinfo b/textproc/popup-stacks/distinfo
new file mode 100644
index 000000000000..4184c55740ac
--- /dev/null
+++ b/textproc/popup-stacks/distinfo
@@ -0,0 +1,6 @@
+MD5 (English-German.cstack.gz) = 7b73216b1833cf7fb2a114cfcc88b3d7
+SHA256 (English-German.cstack.gz) = eb6c871bb174f958971956fca5028ad0fec12603fbccfbc402798e6987947f5e
+SIZE (English-German.cstack.gz) = 67202
+MD5 (German-French.cstack.gz) = 2cc247484e4b48325f610c5b07437574
+SHA256 (German-French.cstack.gz) = 9c114f912e1ad225631f004028061c504d1ae5b089cb3976031bc3cca6bac482
+SIZE (German-French.cstack.gz) = 32554
diff --git a/textproc/popup-stacks/pkg-descr b/textproc/popup-stacks/pkg-descr
new file mode 100644
index 000000000000..0b8aa1e3018f
--- /dev/null
+++ b/textproc/popup-stacks/pkg-descr
@@ -0,0 +1,6 @@
+User Contributed Cardstacks for Popup
+
+ * English-German (3910 cards)
+ * German-French (4006 cards)
+
+WWW: http://popup.sourceforge.net/