aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--converters/Makefile1
-rw-r--r--converters/p5-Unicode-MapUTF8/Makefile27
-rw-r--r--converters/p5-Unicode-MapUTF8/distinfo1
-rw-r--r--converters/p5-Unicode-MapUTF8/pkg-comment1
-rw-r--r--converters/p5-Unicode-MapUTF8/pkg-descr11
-rw-r--r--converters/p5-Unicode-MapUTF8/pkg-plist5
6 files changed, 46 insertions, 0 deletions
diff --git a/converters/Makefile b/converters/Makefile
index 60e56004f9fc..640dbffba33a 100644
--- a/converters/Makefile
+++ b/converters/Makefile
@@ -38,6 +38,7 @@
SUBDIR += p5-Text-Iconv
SUBDIR += p5-Unicode-Map
SUBDIR += p5-Unicode-Map8
+ SUBDIR += p5-Unicode-MapUTF8
SUBDIR += p5-Unicode-String
SUBDIR += psiconv
SUBDIR += py-iconv
diff --git a/converters/p5-Unicode-MapUTF8/Makefile b/converters/p5-Unicode-MapUTF8/Makefile
new file mode 100644
index 000000000000..b413e5f345ff
--- /dev/null
+++ b/converters/p5-Unicode-MapUTF8/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-Unicode-MapUTF8
+# Date created: 28 February 2002
+# Whom: Ryan T. Dean <rtdean@cytherianage.net>
+#
+# $FreeBSD$
+
+PORTNAME= Unicode-MapUTF8
+PORTVERSION= 1.09
+CATEGORIES= converters perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unicode
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rtdean@cytherianage.net
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/Map.pm:${PORTSDIR}/converters/p5-Unicode-Map \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/String.pm:${PORTSDIR}/converters/p5-Unicode-String \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Unicode/Map8.pm:${PORTSDIR}/converters/p5-Unicode-Map8 \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Unicode::MapUTF8.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+.include <bsd.port.mk>
diff --git a/converters/p5-Unicode-MapUTF8/distinfo b/converters/p5-Unicode-MapUTF8/distinfo
new file mode 100644
index 000000000000..349dc2d21191
--- /dev/null
+++ b/converters/p5-Unicode-MapUTF8/distinfo
@@ -0,0 +1 @@
+MD5 (Unicode-MapUTF8-1.09.tar.gz) = 32b2593bb38b24b5f5fef2aaf444a367
diff --git a/converters/p5-Unicode-MapUTF8/pkg-comment b/converters/p5-Unicode-MapUTF8/pkg-comment
new file mode 100644
index 000000000000..36091d6c3174
--- /dev/null
+++ b/converters/p5-Unicode-MapUTF8/pkg-comment
@@ -0,0 +1 @@
+Perl class that implements conversion between arbitrary charsets
diff --git a/converters/p5-Unicode-MapUTF8/pkg-descr b/converters/p5-Unicode-MapUTF8/pkg-descr
new file mode 100644
index 000000000000..cc27dd5c650e
--- /dev/null
+++ b/converters/p5-Unicode-MapUTF8/pkg-descr
@@ -0,0 +1,11 @@
+Unicode::MapUTF8
+----------------
+
+Provides an adapter layer between core routines for converting
+to and from UTF8 and other encodings. In essence, a way to give
+multiple existing Unicode modules a single common interface so
+you don't have to know the underlaying implementations to do
+simple UTF8 to-from other character set string conversions.
+As such, it wraps the Unicode::String, Unicode::Map8,
+Unicode::Map and Jcode modules in a standardized and simple
+API.
diff --git a/converters/p5-Unicode-MapUTF8/pkg-plist b/converters/p5-Unicode-MapUTF8/pkg-plist
new file mode 100644
index 000000000000..15cd18f4c397
--- /dev/null
+++ b/converters/p5-Unicode-MapUTF8/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Unicode/MapUTF8.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode/MapUTF8/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode/MapUTF8
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Unicode
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/Unicode