aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--archivers/ark/Makefile10
-rw-r--r--comms/kremotecontrol/Makefile10
-rw-r--r--deskutils/kcharselect/Makefile10
-rw-r--r--math/kcalc/Makefile10
-rw-r--r--misc/kdeutils4/Makefile10
-rw-r--r--security/kgpg-kde4/Makefile10
-rw-r--r--security/kwallet/Makefile10
-rw-r--r--sysutils/kdf/Makefile10
-rw-r--r--sysutils/kfloppy/Makefile10
-rw-r--r--sysutils/sweeper/Makefile10
10 files changed, 90 insertions, 10 deletions
diff --git a/archivers/ark/Makefile b/archivers/ark/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/archivers/ark/Makefile
+++ b/archivers/ark/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/comms/kremotecontrol/Makefile b/comms/kremotecontrol/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/comms/kremotecontrol/Makefile
+++ b/comms/kremotecontrol/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/deskutils/kcharselect/Makefile b/deskutils/kcharselect/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/deskutils/kcharselect/Makefile
+++ b/deskutils/kcharselect/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/math/kcalc/Makefile b/math/kcalc/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/math/kcalc/Makefile
+++ b/math/kcalc/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/kdeutils4/Makefile b/misc/kdeutils4/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/misc/kdeutils4/Makefile
+++ b/misc/kdeutils4/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/kgpg-kde4/Makefile b/security/kgpg-kde4/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/security/kgpg-kde4/Makefile
+++ b/security/kgpg-kde4/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/kwallet/Makefile b/security/kwallet/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/security/kwallet/Makefile
+++ b/security/kwallet/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kdf/Makefile b/sysutils/kdf/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/sysutils/kdf/Makefile
+++ b/sysutils/kdf/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/kfloppy/Makefile b/sysutils/kfloppy/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/sysutils/kfloppy/Makefile
+++ b/sysutils/kfloppy/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/sweeper/Makefile b/sysutils/sweeper/Makefile
index 1c4ed38f34da..b1cb76a28610 100644
--- a/sysutils/sweeper/Makefile
+++ b/sysutils/sweeper/Makefile
@@ -32,6 +32,14 @@ MAKE_JOBS_UNSAFE= yes
MAN1= ark.1
+OPTIONS= PRINTER_APPLET "Install printer system tray utility" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PRINTER_APPLET)
+RUN_DEPENDS+= ${KDE4_PREFIX}/bin/printer-applet:${PORTSDIR}/print/kdeutils4-printer-applet
+.endif
+
post-extract:
${MKDIR} ${WRKSRC}
@@ -40,4 +48,4 @@ post-patch:
${REINPLACE_CMD} -e '/add_subdirectory.*printer-applet/d' \
${WRKSRC}/../CMakeLists.txt
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>