aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/atlas-devel/Makefile3
-rw-r--r--devel/atlas-devel/distinfo4
-rw-r--r--devel/atlas-devel/pkg-plist14
-rw-r--r--devel/eris/Makefile2
-rw-r--r--devel/mercator/Makefile1
-rw-r--r--games/ember/Makefile3
-rw-r--r--graphics/ogre3d/Makefile1
-rw-r--r--net/cyphesis/Makefile2
8 files changed, 17 insertions, 13 deletions
diff --git a/devel/atlas-devel/Makefile b/devel/atlas-devel/Makefile
index 19d048600f4a..fdca9fbbfc77 100644
--- a/devel/atlas-devel/Makefile
+++ b/devel/atlas-devel/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= Atlas
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.3
CATEGORIES= devel
MASTER_SITES= SF/worldforge/${PORTNAME}-C%2B%2B%20%28protocol%20lib%29/${PORTVERSION}
DISTNAME= ${PORTNAME}-C++-${PORTVERSION:S/.r/rc/}
@@ -15,6 +15,7 @@ USE_AUTOTOOLS= libtool
USE_LDCONFIG= YES
USE_BZIP2= YES
USES= pathfix
+USE_GCC= 4.7+
CONFIGURE_ARGS+=--program-transform-name=
diff --git a/devel/atlas-devel/distinfo b/devel/atlas-devel/distinfo
index d4291ed2f7f4..c97bca77a824 100644
--- a/devel/atlas-devel/distinfo
+++ b/devel/atlas-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Atlas-C++-0.6.2.tar.bz2) = a060997c1c0259de39f0ce663a6fb86fc1756a8121b79bc7d8bbe1e659fbf633
-SIZE (Atlas-C++-0.6.2.tar.bz2) = 344813
+SHA256 (Atlas-C++-0.6.3.tar.bz2) = 5b8401a3b1182eb413b7fe4e6791c14343e7d7b7af6426d5279c6b9cf681f6a3
+SIZE (Atlas-C++-0.6.3.tar.bz2) = 527537
diff --git a/devel/atlas-devel/pkg-plist b/devel/atlas-devel/pkg-plist
index aae7c9d7edcf..9f826e0a664a 100644
--- a/devel/atlas-devel/pkg-plist
+++ b/devel/atlas-devel/pkg-plist
@@ -39,31 +39,31 @@ include/Atlas-C++-0.6/Atlas/Version.h
lib/libAtlas-0.6.a
lib/libAtlas-0.6.la
lib/libAtlas-0.6.so
-lib/libAtlas-0.6.so.1
+lib/libAtlas-0.6.so.2
lib/libAtlasCodecs-0.6.a
lib/libAtlasCodecs-0.6.la
lib/libAtlasCodecs-0.6.so
-lib/libAtlasCodecs-0.6.so.1
+lib/libAtlasCodecs-0.6.so.2
lib/libAtlasFilters-0.6.a
lib/libAtlasFilters-0.6.la
lib/libAtlasFilters-0.6.so
-lib/libAtlasFilters-0.6.so.1
+lib/libAtlasFilters-0.6.so.2
lib/libAtlasFunky-0.6.a
lib/libAtlasFunky-0.6.la
lib/libAtlasFunky-0.6.so
-lib/libAtlasFunky-0.6.so.1
+lib/libAtlasFunky-0.6.so.2
lib/libAtlasMessage-0.6.a
lib/libAtlasMessage-0.6.la
lib/libAtlasMessage-0.6.so
-lib/libAtlasMessage-0.6.so.1
+lib/libAtlasMessage-0.6.so.2
lib/libAtlasNet-0.6.a
lib/libAtlasNet-0.6.la
lib/libAtlasNet-0.6.so
-lib/libAtlasNet-0.6.so.1
+lib/libAtlasNet-0.6.so.2
lib/libAtlasObjects-0.6.a
lib/libAtlasObjects-0.6.la
lib/libAtlasObjects-0.6.so
-lib/libAtlasObjects-0.6.so.1
+lib/libAtlasObjects-0.6.so.2
libdata/pkgconfig/atlascpp-0.6.pc
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/COPYING
diff --git a/devel/eris/Makefile b/devel/eris/Makefile
index 23ccaa24a87a..ba62dc6e0eac 100644
--- a/devel/eris/Makefile
+++ b/devel/eris/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/worldforge/Eris%201.4%20%28client%20lib%29/${PORTVERSION}/
MAINTAINER= oliver@FreeBSD.org
COMMENT= WorldForge client entity library
-LIB_DEPENDS= Atlas-0.6.1:${PORTSDIR}/devel/atlas-devel \
+LIB_DEPENDS= Atlas-0.6.2:${PORTSDIR}/devel/atlas-devel \
skstream-0.3.7:${PORTSDIR}/net/skstream \
wfmath-1.0.1:${PORTSDIR}/math/wfmath \
sigc-2.0:${PORTSDIR}/devel/libsigc++20 \
diff --git a/devel/mercator/Makefile b/devel/mercator/Makefile
index 2284eb278fb2..54216d2e9cc0 100644
--- a/devel/mercator/Makefile
+++ b/devel/mercator/Makefile
@@ -18,7 +18,6 @@ USE_LDCONFIG= yes
USE_GCC= yes
CXXFLAGS+= -include wchar.h
-CONFIGURE_ARGS+="CXXFLAGS=${CXXFLAGS}"
NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/games/ember/Makefile b/games/ember/Makefile
index 3dbb8ddd72f8..37e5245b5295 100644
--- a/games/ember/Makefile
+++ b/games/ember/Makefile
@@ -39,6 +39,7 @@ USE_OPENAL= al alut
USES= pathfix pkgconfig
USE_BZIP2= YES
CPPFLAGS+= -DBR_NO_MACROS
+USE_GCC= 4.7+
NO_STAGE= yes
.include <bsd.port.options.mk>
@@ -55,6 +56,8 @@ post-patch:
s|,Plugin_CgProgramManager||g' \
${WRKSRC}/ember.conf
@${REINPLACE_CMD} -e 's|/bash|/sh|g' ${WRKSRC}/ember.in
+ @${REINPLACE_CMD} -e 's|BOOST_THREAD_LIB =|& -L${_GCC_RUNTIME} -lstdc++ |g' \
+ ${WRKSRC}/src/main/Makefile.in
post-install:
(cd ${WRKDIR}/ember-media-${PORTVERSION}/media && ${FIND} . -type f -print | \
diff --git a/graphics/ogre3d/Makefile b/graphics/ogre3d/Makefile
index 4dc55910f9a7..832abfedd6c5 100644
--- a/graphics/ogre3d/Makefile
+++ b/graphics/ogre3d/Makefile
@@ -21,6 +21,7 @@ USE_BZIP2= YES
USES= cmake
USE_SDL= sdl
USE_XORG= xaw
+USE_GCC= 4.7+
NO_STAGE= yes
.include <bsd.port.options.mk>
diff --git a/net/cyphesis/Makefile b/net/cyphesis/Makefile
index b0591be96c16..f27bf4002b1f 100644
--- a/net/cyphesis/Makefile
+++ b/net/cyphesis/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= SF/worldforge/${PORTNAME}%20%28server%29/${PORTVERSION}
MAINTAINER= oliver@FreeBSD.org
COMMENT= Server for WorldForge games
-LIB_DEPENDS= Atlas-0.6.1:${PORTSDIR}/devel/atlas-devel \
+LIB_DEPENDS= Atlas-0.6.2:${PORTSDIR}/devel/atlas-devel \
varconf-1.0.8:${PORTSDIR}/devel/varconf \
wfmath-1.0.1:${PORTSDIR}/math/wfmath \
mercator-0.3.3:${PORTSDIR}/devel/mercator \