aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--converters/php5-recode/Makefile1
-rw-r--r--databases/php5-oci8/files/patch-oci8_lob.c20
-rw-r--r--databases/php5-pdo_pgsql/Makefile1
-rw-r--r--databases/php5-pdo_sqlite/files/patch-sqlite_statement.c50
-rw-r--r--databases/php5-pgsql/Makefile1
-rw-r--r--devel/php5-gettext/Makefile1
-rw-r--r--devel/php5-pcre/Makefile14
-rw-r--r--devel/php5-pcre/files/patch-php_pcre.c13
-rw-r--r--lang/php5-extensions/Makefile6
-rw-r--r--lang/php5/Makefile16
-rw-r--r--lang/php5/Makefile.ext43
-rw-r--r--lang/php5/distinfo12
-rw-r--r--lang/php5/files/patch-configure.in16
-rw-r--r--lang/php5/files/patch-main_safe_mode.c17
-rw-r--r--lang/php5/pkg-plist2
-rw-r--r--lang/php53/Makefile16
-rw-r--r--lang/php53/Makefile.ext43
-rw-r--r--lang/php53/distinfo12
-rw-r--r--lang/php53/files/patch-configure.in16
-rw-r--r--lang/php53/files/patch-main_safe_mode.c17
-rw-r--r--lang/php53/pkg-plist2
-rw-r--r--mail/php5-imap/Makefile1
-rw-r--r--textproc/php5-pspell/Makefile1
24 files changed, 119 insertions, 203 deletions
diff --git a/MOVED b/MOVED
index 2f169a5a7c7b..a02bbb391381 100644
--- a/MOVED
+++ b/MOVED
@@ -3668,3 +3668,4 @@ databases/firebird2-server|databases/firebird20-server|2008-11-24|Renamed
emulators/linux_base-gentoo-stage2||2008-11-24|Removed
emulators/linux_dist-gentoo-stage2||2008-11-24|Removed
mail/libspf-alt||2008-12-03|Removed
+devel/php5-pcre|lang/php5|2008-12-07|Integrated in base php
diff --git a/converters/php5-recode/Makefile b/converters/php5-recode/Makefile
index 908017ff0f7e..a1044cb76fec 100644
--- a/converters/php5-recode/Makefile
+++ b/converters/php5-recode/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= converters
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/databases/php5-oci8/files/patch-oci8_lob.c b/databases/php5-oci8/files/patch-oci8_lob.c
deleted file mode 100644
index 113c216e0c8a..000000000000
--- a/databases/php5-oci8/files/patch-oci8_lob.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- oci8_lob.c.orig Sat May 26 09:41:51 2007
-+++ oci8_lob.c Sat May 26 09:45:36 2007
-@@ -301,6 +301,7 @@
- }
-
- if (is_clob) {
-+#ifdef OCI_NLS_CHARSET_MAXBYTESZ
- PHP_OCI_CALL_RETURN(connection->errcode, OCINlsNumericInfoGet, (connection->env, connection->err, &bytes_per_char, OCI_NLS_CHARSET_MAXBYTESZ));
-
- if (connection->errcode != OCI_SUCCESS) {
-@@ -308,6 +309,9 @@
- PHP_OCI_HANDLE_ERROR(connection, connection->errcode);
- return 1;
- }
-+#else
-+ bytes_per_char = 4;
-+#endif
- } else {
- /* BLOBs don't have encoding, so bytes_per_char == 1 */
- }
diff --git a/databases/php5-pdo_pgsql/Makefile b/databases/php5-pdo_pgsql/Makefile
index 4d6461ec100d..f8afb5c012b2 100644
--- a/databases/php5-pdo_pgsql/Makefile
+++ b/databases/php5-pdo_pgsql/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/databases/php5-pdo_sqlite/files/patch-sqlite_statement.c b/databases/php5-pdo_sqlite/files/patch-sqlite_statement.c
new file mode 100644
index 000000000000..8785b86ecff0
--- /dev/null
+++ b/databases/php5-pdo_sqlite/files/patch-sqlite_statement.c
@@ -0,0 +1,50 @@
+--- sqlite_statement.c.orig 2007-12-31 08:20:10.000000000 +0100
++++ sqlite_statement.c 2008-12-07 11:50:35.000000000 +0100
+@@ -104,6 +104,21 @@
+ pdo_sqlite_error_stmt(stmt);
+ return 0;
+
++ case PDO_PARAM_INT:
++ case PDO_PARAM_BOOL:
++ if (Z_TYPE_P(param->parameter) == IS_NULL) {
++ if (sqlite3_bind_null(S->stmt, param->paramno + 1) == SQLITE_OK) {
++ return 1;
++ }
++ } else {
++ convert_to_long(param->parameter);
++ if (SQLITE_OK == sqlite3_bind_int(S->stmt, param->paramno + 1, Z_LVAL_P(param->parameter))) {
++ return 1;
++ }
++ }
++ pdo_sqlite_error_stmt(stmt);
++ return 0;
++
+ case PDO_PARAM_LOB:
+ if (Z_TYPE_P(param->parameter) == IS_RESOURCE) {
+ php_stream *stm;
+@@ -117,8 +132,24 @@
+ pdo_raise_impl_error(stmt->dbh, stmt, "HY105", "Expected a stream resource" TSRMLS_CC);
+ return 0;
+ }
++ } else if (Z_TYPE_P(param->parameter) == IS_NULL) {
++ if (sqlite3_bind_null(S->stmt, param->paramno + 1) == SQLITE_OK) {
++ return 1;
++ }
++ pdo_sqlite_error_stmt(stmt);
++ return 0;
++ } else {
++ convert_to_string(param->parameter);
++ }
++
++ if (SQLITE_OK == sqlite3_bind_blob(S->stmt, param->paramno + 1,
++ Z_STRVAL_P(param->parameter),
++ Z_STRLEN_P(param->parameter),
++ SQLITE_STATIC)) {
++ return 1;
+ }
+- /* fall through */
++ pdo_sqlite_error_stmt(stmt);
++ return 0;
+
+ case PDO_PARAM_STR:
+ default:
diff --git a/databases/php5-pgsql/Makefile b/databases/php5-pgsql/Makefile
index 5ace360df491..a34252804bc2 100644
--- a/databases/php5-pgsql/Makefile
+++ b/databases/php5-pgsql/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= databases
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/devel/php5-gettext/Makefile b/devel/php5-gettext/Makefile
index ceb52e086d7a..20b22d6b3e6f 100644
--- a/devel/php5-gettext/Makefile
+++ b/devel/php5-gettext/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/devel/php5-pcre/Makefile b/devel/php5-pcre/Makefile
deleted file mode 100644
index bfa9970c03c3..000000000000
--- a/devel/php5-pcre/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-# New ports collection makefile for: php5-pcre
-# Date created: 7 Jul 2004
-# Whom: Alex Dupre <ale@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-CATEGORIES= devel
-
-MASTERDIR= ${.CURDIR}/../../lang/php5
-
-PKGNAMESUFFIX= -pcre
-
-.include "${MASTERDIR}/Makefile"
diff --git a/devel/php5-pcre/files/patch-php_pcre.c b/devel/php5-pcre/files/patch-php_pcre.c
deleted file mode 100644
index 0a44d8ecdc0f..000000000000
--- a/devel/php5-pcre/files/patch-php_pcre.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- php_pcre.c.orig 2007-11-14 08:11:40.000000000 +0100
-+++ php_pcre.c 2007-11-14 08:11:50.000000000 +0100
-@@ -18,6 +18,10 @@
-
- /* $Id: php_pcre.c,v 1.168.2.9.2.21 2007/09/20 08:10:44 tony2001 Exp $ */
-
-+#ifdef HAVE_CONFIG_H
-+#include "config.h"
-+#endif
-+
- #include "php.h"
- #include "php_ini.h"
- #include "php_globals.h"
diff --git a/lang/php5-extensions/Makefile b/lang/php5-extensions/Makefile
index b691f0326fbd..e6b1bf36ac63 100644
--- a/lang/php5-extensions/Makefile
+++ b/lang/php5-extensions/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= php5
-PORTVERSION= 1.1
+PORTVERSION= 1.2
CATEGORIES= lang
MASTER_SITES= # none
PKGNAMESUFFIX= -extensions
@@ -28,7 +28,6 @@ WITH_FILTER= yes
WITH_HASH= yes
WITH_ICONV= yes
WITH_JSON= yes
-WITH_PCRE= yes
WITH_PDO= yes
WITH_PDO_SQLITE=yes
WITH_POSIX= yes
@@ -74,7 +73,6 @@ OPTIONS= BCMATH "bc style precision math functions" off \
ODBC "unixODBC support" off \
OPENSSL "OpenSSL support" off \
PCNTL "pcntl support (CLI only)" off \
- PCRE "Perl Compatible Regular Expression support" on \
PDF "PDFlib support (implies GD)" off \
PDO "PHP Data Objects Interface (PDO)" on \
PDO_SQLITE "PDO sqlite driver" on \
@@ -119,7 +117,7 @@ ALL_OPTIONS= BCMATH BZ2 CALENDAR CTYPE CURL DBA DBASE \
DOM EXIF FILEINFO FILTER FRIBIDI FTP GD GETTEXT \
GMP HASH ICONV IMAP INTERBASE JSON LDAP MBSTRING MCRYPT \
MHASH MING MSSQL MYSQL MYSQLI NCURSES \
- ODBC OPENSSL PCNTL PCRE PDF PDO PDO_SQLITE PGSQL POSIX \
+ ODBC OPENSSL PCNTL PDF PDO PDO_SQLITE PGSQL POSIX \
PSPELL READLINE RECODE SESSION SHMOP SIMPLEXML SNMP SOAP \
SOCKETS SPL SQLITE SYBASE_CT SYSVMSG SYSVSEM SYSVSHM \
TIDY TOKENIZER WDDX XML XMLREADER XMLRPC XMLWRITER XSL \
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index b0354884ee5b..c3c5df8e0a28 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.6
-PORTREVISION?= 2
+PORTVERSION= 5.2.7
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -22,12 +22,15 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf:262
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
CONFIGURE_ARGS= \
--with-layout=GNU \
--with-config-file-scan-dir=${PREFIX}/etc/php \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --with-pcre-regex=${LOCALBASE} \
--enable-reflection \
--program-prefix=""
@@ -55,7 +58,7 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.2.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.3.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
@@ -63,7 +66,8 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+PATCHFILES+= php-5.2.6-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -158,6 +162,10 @@ post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
+ @${ECHO_CMD} "PHP_EXT_INC=pcre" >> ${WRKDIR}/php.conf
+
+test: build
+ @(cd ${WRKSRC} && ${MAKE} test)
post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
diff --git a/lang/php5/Makefile.ext b/lang/php5/Makefile.ext
index c1554bb9dc84..0d70b753b2e8 100644
--- a/lang/php5/Makefile.ext
+++ b/lang/php5/Makefile.ext
@@ -233,12 +233,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--enable-pcntl
.endif
-.if ${PHP_MODNAME} == "pcre"
-CONFIGURE_ARGS+=--with-pcre-regex=yes
-
-PHP_HEADER_DIRS=pcrelib
-.endif
-
.if ${PHP_MODNAME} == "pdo"
CONFIGURE_ARGS+=--enable-pdo
.endif
@@ -386,7 +380,7 @@ CONFIGURE_ARGS+=--enable-spl \
USE_GNOME= libxml2
-USE_PHP= pcre simplexml
+USE_PHP= simplexml
USE_PHP_BUILD= yes
.endif
@@ -502,33 +496,11 @@ CONFIGURE_ARGS+=--with-zlib=/usr
CONFIGURE_ARGS+=--without-cdb
. endif
. if defined(WITH_DB4)
-WITH_DB4_VER?= 46
-. if ${WITH_DB4_VER} == 45
-LIB_DEPENDS+= db-4.5.0:${PORTSDIR}/databases/db45
-. else
-. if ${WITH_DB4_VER} == 44
-LIB_DEPENDS+= db-4.4.0:${PORTSDIR}/databases/db44
-. else
-. if ${WITH_DB4_VER} == 43
-LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
-. else
-. if ${WITH_DB4_VER} == 42
-LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
-. else
-. if ${WITH_DB4_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-. else
-. if ${WITH_DB4_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-. else
-LIB_DEPENDS+= db-4.6.0:${PORTSDIR}/databases/db46
-. endif
-. endif
-. endif
-. endif
-. endif
-. endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
+
+USE_BDB= yes
+WITH_BDB_HIGHEST= yes
+INVALID_BDB_VER= 2 3
. endif
. if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
@@ -577,11 +549,6 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
-.if ${PHP_MODNAME} == "pcre"
-post-extract:
- @${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
-.endif
-
.if ${PHP_MODNAME} == "oci8" || ${PHP_MODNAME} == "pdo_oci"
pre-configure:
@cd ${WRKSRC}; \
diff --git a/lang/php5/distinfo b/lang/php5/distinfo
index 3a8289e70e01..f07d8a9d7734 100644
--- a/lang/php5/distinfo
+++ b/lang/php5/distinfo
@@ -1,9 +1,9 @@
-MD5 (php-5.2.6.tar.bz2) = 7380ffecebd95c6edb317ef861229ebd
-SHA256 (php-5.2.6.tar.bz2) = 1892b2dd50b56ae2c9aec027fcd9035b76673f113555bc2bc1007bab8ae4db81
-SIZE (php-5.2.6.tar.bz2) = 9571312
-MD5 (suhosin-patch-5.2.6-0.9.6.2.patch.gz) = f2ec986341a314c271259dbe4d940858
-SHA256 (suhosin-patch-5.2.6-0.9.6.2.patch.gz) = dfdae803778e6ed6854ea3ad2948bbfedbfffc5a32dbc75a657b99092a9cc5e4
-SIZE (suhosin-patch-5.2.6-0.9.6.2.patch.gz) = 22986
+MD5 (php-5.2.7.tar.bz2) = 9ffc42edbb7faad965699666ddd559bc
+SHA256 (php-5.2.7.tar.bz2) = 19389875a728b753480995a8a8a3f7debdd0f46c76bbd4f6fd716f4b881a5368
+SIZE (php-5.2.7.tar.bz2) = 9826432
+MD5 (suhosin-patch-5.2.7-0.9.6.3.patch.gz) = d455c3dd5b652046dbac2951a58f64fa
+SHA256 (suhosin-patch-5.2.7-0.9.6.3.patch.gz) = 85e6262f53014e393977d1efed2d3a7e686767a07f96b14b2c3f126f694aee46
+SIZE (suhosin-patch-5.2.7-0.9.6.3.patch.gz) = 23125
MD5 (php-5.2.6-mail-header.patch) = eb26be2469a173a3476220342c5fcd58
SHA256 (php-5.2.6-mail-header.patch) = 7e546c22a19386c4d93bebddfb64ace9447774f748070794c7c41419c5c474ac
SIZE (php-5.2.6-mail-header.patch) = 3420
diff --git a/lang/php5/files/patch-configure.in b/lang/php5/files/patch-configure.in
index 98264d6155d2..f5f5c5a113c9 100644
--- a/lang/php5/files/patch-configure.in
+++ b/lang/php5/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Mon Jun 4 08:08:43 2007
-+++ configure.in Mon Jun 4 08:13:47 2007
-@@ -233,7 +233,6 @@
+--- configure.in.orig 2008-12-05 07:58:47.000000000 +0100
++++ configure.in 2008-12-05 08:02:26.000000000 +0100
+@@ -270,7 +270,6 @@
dnl .
dnl -------------------------------------------------------------------------
@@ -8,7 +8,7 @@
PHP_HELP_SEPARATOR([SAPI modules:])
PHP_SHLIB_SUFFIX_NAMES
PHP_SAPI=default
-@@ -258,7 +257,6 @@
+@@ -295,7 +294,6 @@
if test "$enable_maintainer_zts" = "yes"; then
PTHREADS_ASSIGN_VARS
@@ -16,7 +16,7 @@
fi
divert(3)
-@@ -1123,7 +1121,7 @@
+@@ -1136,7 +1134,7 @@
EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
@@ -25,13 +25,13 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1295,22 +1293,19 @@
+@@ -1344,22 +1342,19 @@
INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
--all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET)"
+-all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET)"
-install_targets="$install_modules install-build install-headers install-programs $install_pear"
-+all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET)"
++all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET)"
+install_targets="$PHP_INSTALL_CLI_TARGET $PHP_INSTALL_CGI_TARGET $install_modules install-build install-headers install-programs $install_pear"
case $PHP_SAPI in
diff --git a/lang/php5/files/patch-main_safe_mode.c b/lang/php5/files/patch-main_safe_mode.c
deleted file mode 100644
index 4b0d4e1c531c..000000000000
--- a/lang/php5/files/patch-main_safe_mode.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- main/safe_mode.c.orig 2008-09-04 15:52:19.000000000 +0200
-+++ main/safe_mode.c 2008-09-04 15:52:35.000000000 +0200
-@@ -74,14 +74,6 @@
- }
- }
-
-- /*
-- * If given filepath is a URL, allow - safe mode stuff
-- * related to URL's is checked in individual functions
-- */
-- wrapper = php_stream_locate_url_wrapper(filename, NULL, STREAM_LOCATE_WRAPPERS_ONLY TSRMLS_CC);
-- if (wrapper != NULL)
-- return 1;
--
- /* First we see if the file is owned by the same user...
- * If that fails, passthrough and check directory...
- */
diff --git a/lang/php5/pkg-plist b/lang/php5/pkg-plist
index 17c9fdaaf18f..59cc8b83c2b2 100644
--- a/lang/php5/pkg-plist
+++ b/lang/php5/pkg-plist
@@ -72,6 +72,7 @@ include/php/ext/date/lib/timelib_config.h
include/php/ext/date/lib/timelib_structs.h
include/php/ext/date/php_date.h
include/php/ext/libxml/php_libxml.h
+include/php/ext/pcre/php_pcre.h
include/php/ext/standard/base64.h
include/php/ext/standard/basic_functions.h
include/php/ext/standard/crc32.h
@@ -199,6 +200,7 @@ lib/php/build/shtool
@dirrm include/php/ext/date/lib
@dirrm include/php/ext/date
@dirrm include/php/ext/libxml
+@dirrm include/php/ext/pcre
@dirrm include/php/ext/standard
@dirrmtry include/php/ext
@dirrm include/php/main/streams
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index b0354884ee5b..c3c5df8e0a28 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= php5
-PORTVERSION= 5.2.6
-PORTREVISION?= 2
+PORTVERSION= 5.2.7
+PORTREVISION?= 0
CATEGORIES?= lang devel www
MASTER_SITES= ${MASTER_SITE_PHP}
MASTER_SITE_SUBDIR= distributions
@@ -22,12 +22,15 @@ USE_BZIP2= yes
.if !defined(PKGNAMESUFFIX)
USE_AUTOTOOLS= autoconf:262
+LIB_DEPENDS+= pcre.0:${PORTSDIR}/devel/pcre
+
CONFIGURE_ARGS= \
--with-layout=GNU \
--with-config-file-scan-dir=${PREFIX}/etc/php \
--disable-all \
--enable-libxml \
--with-libxml-dir=${LOCALBASE} \
+ --with-pcre-regex=${LOCALBASE} \
--enable-reflection \
--program-prefix=""
@@ -55,7 +58,7 @@ MAN1= php-config.1 phpize.1
PATCH_DIST_STRIP= -p1
.if !defined(WITHOUT_SUHOSIN)
-PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.2.patch.gz:suhosin
+PATCHFILES+= suhosin-patch-${PORTVERSION}-0.9.6.3.patch.gz:suhosin
PATCH_SITES+= http://download.suhosin.org/:suhosin
PLIST_SUB+= SUHOSIN=""
.else
@@ -63,7 +66,8 @@ PLIST_SUB+= SUHOSIN="@comment "
.endif
.if defined(WITH_MAILHEAD)
-PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+#PATCHFILES+= php-${PORTVERSION}-mail-header.patch:mail
+PATCHFILES+= php-5.2.6-mail-header.patch:mail
PATCH_SITES+= http://choon.net/opensource/php/:mail
.endif
@@ -158,6 +162,10 @@ post-build:
@${ECHO_CMD} "PHP_VER=5" > ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_VERSION=${PORTVERSION}" >> ${WRKDIR}/php.conf
@${ECHO_CMD} "PHP_SAPI=${PHP_SAPI}" >> ${WRKDIR}/php.conf
+ @${ECHO_CMD} "PHP_EXT_INC=pcre" >> ${WRKDIR}/php.conf
+
+test: build
+ @(cd ${WRKSRC} && ${MAKE} test)
post-install:
@${INSTALL_DATA} ${WRKSRC}/php.ini-dist ${PREFIX}/etc
diff --git a/lang/php53/Makefile.ext b/lang/php53/Makefile.ext
index c1554bb9dc84..0d70b753b2e8 100644
--- a/lang/php53/Makefile.ext
+++ b/lang/php53/Makefile.ext
@@ -233,12 +233,6 @@ USE_OPENSSL= yes
CONFIGURE_ARGS+=--enable-pcntl
.endif
-.if ${PHP_MODNAME} == "pcre"
-CONFIGURE_ARGS+=--with-pcre-regex=yes
-
-PHP_HEADER_DIRS=pcrelib
-.endif
-
.if ${PHP_MODNAME} == "pdo"
CONFIGURE_ARGS+=--enable-pdo
.endif
@@ -386,7 +380,7 @@ CONFIGURE_ARGS+=--enable-spl \
USE_GNOME= libxml2
-USE_PHP= pcre simplexml
+USE_PHP= simplexml
USE_PHP_BUILD= yes
.endif
@@ -502,33 +496,11 @@ CONFIGURE_ARGS+=--with-zlib=/usr
CONFIGURE_ARGS+=--without-cdb
. endif
. if defined(WITH_DB4)
-WITH_DB4_VER?= 46
-. if ${WITH_DB4_VER} == 45
-LIB_DEPENDS+= db-4.5.0:${PORTSDIR}/databases/db45
-. else
-. if ${WITH_DB4_VER} == 44
-LIB_DEPENDS+= db-4.4.0:${PORTSDIR}/databases/db44
-. else
-. if ${WITH_DB4_VER} == 43
-LIB_DEPENDS+= db-4.3.0:${PORTSDIR}/databases/db43
-. else
-. if ${WITH_DB4_VER} == 42
-LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
-. else
-. if ${WITH_DB4_VER} == 41
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-. else
-. if ${WITH_DB4_VER} == 4
-LIB_DEPENDS+= db4.0:${PORTSDIR}/databases/db4
-. else
-LIB_DEPENDS+= db-4.6.0:${PORTSDIR}/databases/db46
-. endif
-. endif
-. endif
-. endif
-. endif
-. endif
CONFIGURE_ARGS+=--with-db4=${LOCALBASE}
+
+USE_BDB= yes
+WITH_BDB_HIGHEST= yes
+INVALID_BDB_VER= 2 3
. endif
. if defined(WITH_GDBM)
LIB_DEPENDS+= gdbm.3:${PORTSDIR}/databases/gdbm
@@ -577,11 +549,6 @@ post-extract:
@${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
.endif
-.if ${PHP_MODNAME} == "pcre"
-post-extract:
- @${MV} ${WRKSRC}/config0.m4 ${WRKSRC}/config.m4
-.endif
-
.if ${PHP_MODNAME} == "oci8" || ${PHP_MODNAME} == "pdo_oci"
pre-configure:
@cd ${WRKSRC}; \
diff --git a/lang/php53/distinfo b/lang/php53/distinfo
index 3a8289e70e01..f07d8a9d7734 100644
--- a/lang/php53/distinfo
+++ b/lang/php53/distinfo
@@ -1,9 +1,9 @@
-MD5 (php-5.2.6.tar.bz2) = 7380ffecebd95c6edb317ef861229ebd
-SHA256 (php-5.2.6.tar.bz2) = 1892b2dd50b56ae2c9aec027fcd9035b76673f113555bc2bc1007bab8ae4db81
-SIZE (php-5.2.6.tar.bz2) = 9571312
-MD5 (suhosin-patch-5.2.6-0.9.6.2.patch.gz) = f2ec986341a314c271259dbe4d940858
-SHA256 (suhosin-patch-5.2.6-0.9.6.2.patch.gz) = dfdae803778e6ed6854ea3ad2948bbfedbfffc5a32dbc75a657b99092a9cc5e4
-SIZE (suhosin-patch-5.2.6-0.9.6.2.patch.gz) = 22986
+MD5 (php-5.2.7.tar.bz2) = 9ffc42edbb7faad965699666ddd559bc
+SHA256 (php-5.2.7.tar.bz2) = 19389875a728b753480995a8a8a3f7debdd0f46c76bbd4f6fd716f4b881a5368
+SIZE (php-5.2.7.tar.bz2) = 9826432
+MD5 (suhosin-patch-5.2.7-0.9.6.3.patch.gz) = d455c3dd5b652046dbac2951a58f64fa
+SHA256 (suhosin-patch-5.2.7-0.9.6.3.patch.gz) = 85e6262f53014e393977d1efed2d3a7e686767a07f96b14b2c3f126f694aee46
+SIZE (suhosin-patch-5.2.7-0.9.6.3.patch.gz) = 23125
MD5 (php-5.2.6-mail-header.patch) = eb26be2469a173a3476220342c5fcd58
SHA256 (php-5.2.6-mail-header.patch) = 7e546c22a19386c4d93bebddfb64ace9447774f748070794c7c41419c5c474ac
SIZE (php-5.2.6-mail-header.patch) = 3420
diff --git a/lang/php53/files/patch-configure.in b/lang/php53/files/patch-configure.in
index 98264d6155d2..f5f5c5a113c9 100644
--- a/lang/php53/files/patch-configure.in
+++ b/lang/php53/files/patch-configure.in
@@ -1,6 +1,6 @@
---- configure.in.orig Mon Jun 4 08:08:43 2007
-+++ configure.in Mon Jun 4 08:13:47 2007
-@@ -233,7 +233,6 @@
+--- configure.in.orig 2008-12-05 07:58:47.000000000 +0100
++++ configure.in 2008-12-05 08:02:26.000000000 +0100
+@@ -270,7 +270,6 @@
dnl .
dnl -------------------------------------------------------------------------
@@ -8,7 +8,7 @@
PHP_HELP_SEPARATOR([SAPI modules:])
PHP_SHLIB_SUFFIX_NAMES
PHP_SAPI=default
-@@ -258,7 +257,6 @@
+@@ -295,7 +294,6 @@
if test "$enable_maintainer_zts" = "yes"; then
PTHREADS_ASSIGN_VARS
@@ -16,7 +16,7 @@
fi
divert(3)
-@@ -1123,7 +1121,7 @@
+@@ -1136,7 +1134,7 @@
EXPANDED_DATADIR=$datadir
EXPANDED_PHP_CONFIG_FILE_PATH=`eval echo "$PHP_CONFIG_FILE_PATH"`
EXPANDED_PHP_CONFIG_FILE_SCAN_DIR=`eval echo "$PHP_CONFIG_FILE_SCAN_DIR"`
@@ -25,13 +25,13 @@
exec_prefix=$old_exec_prefix
libdir=$old_libdir
-@@ -1295,22 +1293,19 @@
+@@ -1344,22 +1342,19 @@
INLINE_CFLAGS="$INLINE_CFLAGS $standard_libtool_flag"
CXXFLAGS="$CXXFLAGS $standard_libtool_flag"
--all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET)"
+-all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET)"
-install_targets="$install_modules install-build install-headers install-programs $install_pear"
-+all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET)"
++all_targets="$lcov_target \$(OVERALL_TARGET) \$(PHP_MODULES) \$(PHP_ZEND_EX) \$(PHP_CLI_TARGET) \$(PHP_CGI_TARGET)"
+install_targets="$PHP_INSTALL_CLI_TARGET $PHP_INSTALL_CGI_TARGET $install_modules install-build install-headers install-programs $install_pear"
case $PHP_SAPI in
diff --git a/lang/php53/files/patch-main_safe_mode.c b/lang/php53/files/patch-main_safe_mode.c
deleted file mode 100644
index 4b0d4e1c531c..000000000000
--- a/lang/php53/files/patch-main_safe_mode.c
+++ /dev/null
@@ -1,17 +0,0 @@
---- main/safe_mode.c.orig 2008-09-04 15:52:19.000000000 +0200
-+++ main/safe_mode.c 2008-09-04 15:52:35.000000000 +0200
-@@ -74,14 +74,6 @@
- }
- }
-
-- /*
-- * If given filepath is a URL, allow - safe mode stuff
-- * related to URL's is checked in individual functions
-- */
-- wrapper = php_stream_locate_url_wrapper(filename, NULL, STREAM_LOCATE_WRAPPERS_ONLY TSRMLS_CC);
-- if (wrapper != NULL)
-- return 1;
--
- /* First we see if the file is owned by the same user...
- * If that fails, passthrough and check directory...
- */
diff --git a/lang/php53/pkg-plist b/lang/php53/pkg-plist
index 17c9fdaaf18f..59cc8b83c2b2 100644
--- a/lang/php53/pkg-plist
+++ b/lang/php53/pkg-plist
@@ -72,6 +72,7 @@ include/php/ext/date/lib/timelib_config.h
include/php/ext/date/lib/timelib_structs.h
include/php/ext/date/php_date.h
include/php/ext/libxml/php_libxml.h
+include/php/ext/pcre/php_pcre.h
include/php/ext/standard/base64.h
include/php/ext/standard/basic_functions.h
include/php/ext/standard/crc32.h
@@ -199,6 +200,7 @@ lib/php/build/shtool
@dirrm include/php/ext/date/lib
@dirrm include/php/ext/date
@dirrm include/php/ext/libxml
+@dirrm include/php/ext/pcre
@dirrm include/php/ext/standard
@dirrmtry include/php/ext
@dirrm include/php/main/streams
diff --git a/mail/php5-imap/Makefile b/mail/php5-imap/Makefile
index 666df03bb0ec..859dccbc4a6e 100644
--- a/mail/php5-imap/Makefile
+++ b/mail/php5-imap/Makefile
@@ -6,7 +6,6 @@
#
CATEGORIES= mail
-PORTREVISION= 1
MASTERDIR= ${.CURDIR}/../../lang/php5
diff --git a/textproc/php5-pspell/Makefile b/textproc/php5-pspell/Makefile
index 2e4d900bf6f4..c7098115ee1f 100644
--- a/textproc/php5-pspell/Makefile
+++ b/textproc/php5-pspell/Makefile
@@ -5,7 +5,6 @@
# $FreeBSD$
#
-PORTREVISION= 1
CATEGORIES= textproc
MASTERDIR= ${.CURDIR}/../../lang/php5