aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/see-devel/Makefile2
-rw-r--r--lang/see-devel/files/patch-libsee_input__utf8.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/lang/see-devel/Makefile b/lang/see-devel/Makefile
index d031237f3282..999c9ad8d757 100644
--- a/lang/see-devel/Makefile
+++ b/lang/see-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= see
PORTVERSION= 2.0.1131
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= lang devel
MASTER_SITES= http://www.powerband.net.au/~david.leonard/ \
http://freshmeat.net/redir/see/45974/url_tgz/
diff --git a/lang/see-devel/files/patch-libsee_input__utf8.c b/lang/see-devel/files/patch-libsee_input__utf8.c
new file mode 100644
index 000000000000..d86e4286f7f5
--- /dev/null
+++ b/lang/see-devel/files/patch-libsee_input__utf8.c
@@ -0,0 +1,20 @@
+--- libsee/input_utf8.c.orig Wed Jan 18 12:40:19 2006
++++ libsee/input_utf8.c Tue Dec 12 08:48:44 2006
+@@ -63,7 +63,7 @@
+
+ struct input_utf8 {
+ struct SEE_input inp;
+- const char * s;
++ const unsigned char * s;
+ };
+
+ static SEE_unicode_t
+@@ -141,7 +141,7 @@
+ inpu->inp.inputclass = &input_utf8_class;
+ inpu->inp.filename = NULL;
+ inpu->inp.first_lineno = 1;
+- inpu->s = s;
++ inpu->s = (const unsigned char *)s;
+ SEE_INPUT_NEXT((struct SEE_input *)inpu); /* prime */
+ return (struct SEE_input *)inpu;
+ }