aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Exception/Makefile37
-rw-r--r--devel/p5-Test-Exception/distinfo1
-rw-r--r--devel/p5-Test-Exception/pkg-comment1
-rw-r--r--devel/p5-Test-Exception/pkg-descr8
-rw-r--r--devel/p5-Test-Exception/pkg-plist4
6 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 93fc79430190..62902c146e8b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -617,6 +617,7 @@
SUBDIR += p5-Term-Screen
SUBDIR += p5-Term-Size
SUBDIR += p5-Test-Builder-Tester
+ SUBDIR += p5-Test-Exception
SUBDIR += p5-Test-Harness
SUBDIR += p5-Test-Inline
SUBDIR += p5-Test-Simple
diff --git a/devel/p5-Test-Exception/Makefile b/devel/p5-Test-Exception/Makefile
new file mode 100644
index 000000000000..22d7a4f647aa
--- /dev/null
+++ b/devel/p5-Test-Exception/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: p5-Test-Exception
+# Date created: January 27th 2003
+# Whom: Erwin Lansing <erwin@lansing.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Exception
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Test
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= erwin@lansing.dk
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Builder-Tester \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Test::Exception.3
+
+.include <bsd.port.pre.mk>
+
+##
+## this port depends on devel/p5-Sub-Uplevel which
+## requires PERL 5.6.x or later
+##
+.if ${PERL_LEVEL} < 500600
+BROKEN= Port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Exception/distinfo b/devel/p5-Test-Exception/distinfo
new file mode 100644
index 000000000000..1f28f8d98b8b
--- /dev/null
+++ b/devel/p5-Test-Exception/distinfo
@@ -0,0 +1 @@
+MD5 (Test-Exception-0.13.tar.gz) = 24c9f63c467dac437b2b047fa24a5834
diff --git a/devel/p5-Test-Exception/pkg-comment b/devel/p5-Test-Exception/pkg-comment
new file mode 100644
index 000000000000..4dc54942f4b6
--- /dev/null
+++ b/devel/p5-Test-Exception/pkg-comment
@@ -0,0 +1 @@
+Test::Exception - test functions for exception based code
diff --git a/devel/p5-Test-Exception/pkg-descr b/devel/p5-Test-Exception/pkg-descr
new file mode 100644
index 000000000000..3bf189a0744a
--- /dev/null
+++ b/devel/p5-Test-Exception/pkg-descr
@@ -0,0 +1,8 @@
+This module provides a few convenience methods for testing
+exception based code. It is built with Test::Builder and
+plays happily with Test::Simple, Test::More and friends.
+
+If you are not familiar with Test::Simple or Test::More
+now would be the time to go take a look.
+
+WWW: http://search.cpan.org/dist/Test-Exception/
diff --git a/devel/p5-Test-Exception/pkg-plist b/devel/p5-Test-Exception/pkg-plist
new file mode 100644
index 000000000000..f00cb3fe1bd2
--- /dev/null
+++ b/devel/p5-Test-Exception/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Test/Exception/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Test/Exception.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/mach/auto/Test/Exception
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Test 2>/dev/null || true