aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/rhythmbox/Makefile7
-rw-r--r--audio/rhythmbox/pkg-plist8
2 files changed, 8 insertions, 7 deletions
diff --git a/audio/rhythmbox/Makefile b/audio/rhythmbox/Makefile
index faf40aebd0f7..031be47b2b0c 100644
--- a/audio/rhythmbox/Makefile
+++ b/audio/rhythmbox/Makefile
@@ -122,11 +122,12 @@ PLIST_SUB+= IPOD="@comment "
.endif
.if ${PORT_OPTIONS:MITMS_PLUGIN}
-USES+= webplugin:gecko
-WEBPLUGIN_FILES=librhythmbox-itms-detection-plugin.so
+USE_WEBPLUGINS= gecko18
+WEBPLUGINS_FILES=librhythmbox-itms-detection-plugin.so
+.include "${PORTSDIR}/www/firefox/Makefile.webplugins"
CONFIGURE_ARGS+=--enable-browser-plugin
-CONFIGURE_ENV+= MOZILLA_PLUGINDIR=${WEBPLUGIN_DIR}
+CONFIGURE_ENV+= MOZILLA_PLUGINDIR=${WEBPLUGINS_DIR}
PLIST_SUB+= ITMS_PLUGIN=""
.else
CONFIGURE_ARGS+=--disable-browser-plugin
diff --git a/audio/rhythmbox/pkg-plist b/audio/rhythmbox/pkg-plist
index 4acd653be966..be4c9a38f07a 100644
--- a/audio/rhythmbox/pkg-plist
+++ b/audio/rhythmbox/pkg-plist
@@ -1,8 +1,8 @@
bin/rhythmbox
bin/rhythmbox-client
-%%ITMS_PLUGIN%%%%WEBPLUGINS_DIR%%/librhythmbox-itms-detection-plugin.a
-%%ITMS_PLUGIN%%%%WEBPLUGINS_DIR%%/librhythmbox-itms-detection-plugin.la
-%%ITMS_PLUGIN%%%%WEBPLUGINS_DIR%%/librhythmbox-itms-detection-plugin.so
+%%ITMS_PLUGIN%%%%WEBPLUGIN_DIR%%/librhythmbox-itms-detection-plugin.a
+%%ITMS_PLUGIN%%%%WEBPLUGIN_DIR%%/librhythmbox-itms-detection-plugin.la
+%%ITMS_PLUGIN%%%%WEBPLUGIN_DIR%%/librhythmbox-itms-detection-plugin.so
lib/librhythmbox-core.la
lib/librhythmbox-core.so
lib/librhythmbox-core.so.0
@@ -761,7 +761,7 @@ share/rhythmbox/uri-new.ui
%%PYTHON%%@dirrm lib/rhythmbox/plugins/artdisplay
@dirrm lib/rhythmbox/plugins
@dirrm lib/rhythmbox
-%%ITMS_PLUGIN%%@dirrmtry %%WEBPLUGINS_DIR%%
+%%ITMS_PLUGIN%%@dirrmtry %%WEBPLUGIN_DIR%%
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/te/LC_MESSAGES