aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--irc/ircservices/Makefile2
-rw-r--r--irc/ircservices/files/patch-modules::Makerules14
2 files changed, 15 insertions, 1 deletions
diff --git a/irc/ircservices/Makefile b/irc/ircservices/Makefile
index 2ae0d4b2ef5b..d8f9f53bcb72 100644
--- a/irc/ircservices/Makefile
+++ b/irc/ircservices/Makefile
@@ -27,7 +27,7 @@ USE_GMAKE= yes
DIST_SUBDIR= ${PORTNAME}
-CONFIGURE_ARGS= -prefix ${PREFIX} -cflags "${CFLAGS} -fPIC" -cc "${CC}"
+CONFIGURE_ARGS= -prefix ${PREFIX} -cflags "${CFLAGS}" -cc "${CC}"
post-install:
@${ECHO_CMD} "Installing ${PREFIX}/etc/rc.d/ircservices.sh.sample startup file."
diff --git a/irc/ircservices/files/patch-modules::Makerules b/irc/ircservices/files/patch-modules::Makerules
new file mode 100644
index 000000000000..c59df60cd7cc
--- /dev/null
+++ b/irc/ircservices/files/patch-modules::Makerules
@@ -0,0 +1,14 @@
+--- modules/Makerules.orig Wed Mar 10 03:22:00 2004
++++ modules/Makerules Wed Mar 10 03:14:17 2004
+@@ -168,6 +168,11 @@
+ @rm -f $@
+ @ln -s $(TARGET).o $@
+
++.compiled-check.o .compiled-extsyms.o .compiled-main.o: $(TARGET).c $(DEPS) $(INCLUDES2)
++ $(CC) $(CFLAGS) -fPIC -I$(TOPDIR) -c $< -o $(TARGET).o
++ @rm -f $@
++ @ln -s $(TARGET).o $@
++
+ # Compile a source file into an object file suitable for use in a static
+ # module. This is used with the main object file of a module to generate
+ # unique names for exported module symbols (init_module and the like).