aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-MooX-StrictConstructor/Makefile28
-rw-r--r--devel/p5-MooX-StrictConstructor/distinfo2
-rw-r--r--devel/p5-MooX-StrictConstructor/pkg-descr5
-rw-r--r--devel/p5-MooX-StrictConstructor/pkg-plist9
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6a11479f2289..931b349df171 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2335,6 +2335,7 @@
SUBDIR += p5-MooX-ConfigFromFile
SUBDIR += p5-MooX-File-ConfigDir
SUBDIR += p5-MooX-Options
+ SUBDIR += p5-MooX-StrictConstructor
SUBDIR += p5-MooX-Types-MooseLike
SUBDIR += p5-MooX-Types-MooseLike-Numeric
SUBDIR += p5-MooX-late
diff --git a/devel/p5-MooX-StrictConstructor/Makefile b/devel/p5-MooX-StrictConstructor/Makefile
new file mode 100644
index 000000000000..3f3708f90bb0
--- /dev/null
+++ b/devel/p5-MooX-StrictConstructor/Makefile
@@ -0,0 +1,28 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= MooX-StrictConstructor
+PORTVERSION= 0.006
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Make your Moo-based object constructors blow up on unknown attributes
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Class-Method-Modifiers>=0:${PORTSDIR}/devel/p5-Class-Method-Modifiers \
+ p5-Moo>=1.001000:${PORTSDIR}/devel/p5-Moo \
+ p5-strictures>=1:${PORTSDIR}/devel/p5-strictures
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-Fatal>=0:${PORTSDIR}/devel/p5-Test-Fatal \
+ p5-bareword-filehandles>=0:${PORTSDIR}/devel/p5-bareword-filehandles \
+ p5-indirect>=0:${PORTSDIR}/devel/p5-indirect \
+ p5-multidimensional>=0:${PORTSDIR}/devel/p5-multidimensional
+
+USE_PERL5= modbuild
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-MooX-StrictConstructor/distinfo b/devel/p5-MooX-StrictConstructor/distinfo
new file mode 100644
index 000000000000..f0aecd7d0e10
--- /dev/null
+++ b/devel/p5-MooX-StrictConstructor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (MooX-StrictConstructor-0.006.tar.gz) = e49ed409586c6a6adf03992fe386e5797c4d9e6bbc65763ca539463cc3dd1b9f
+SIZE (MooX-StrictConstructor-0.006.tar.gz) = 14252
diff --git a/devel/p5-MooX-StrictConstructor/pkg-descr b/devel/p5-MooX-StrictConstructor/pkg-descr
new file mode 100644
index 000000000000..dcdb75ea5475
--- /dev/null
+++ b/devel/p5-MooX-StrictConstructor/pkg-descr
@@ -0,0 +1,5 @@
+Simply loading this module makes your constructors "strict". If your constructor
+is called with an attribute init argument that your class does not declare, then
+it dies. This is a great way to catch small typos.
+
+WWW: http://search.cpan.org/dist/MooX-StrictConstructor/
diff --git a/devel/p5-MooX-StrictConstructor/pkg-plist b/devel/p5-MooX-StrictConstructor/pkg-plist
new file mode 100644
index 000000000000..90cff4c08630
--- /dev/null
+++ b/devel/p5-MooX-StrictConstructor/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Method/Generate/Constructor/Role/StrictConstructor.pm
+%%SITE_PERL%%/MooX/StrictConstructor.pm
+%%PERL5_MAN3%%/Method::Generate::Constructor::Role::StrictConstructor.3.gz
+%%PERL5_MAN3%%/MooX::StrictConstructor.3.gz
+@dirrmtry %%SITE_PERL%%/MooX
+@dirrm %%SITE_PERL%%/Method/Generate/Constructor/Role
+@dirrm %%SITE_PERL%%/Method/Generate/Constructor
+@dirrmtry %%SITE_PERL%%/Method/Generate
+@dirrmtry %%SITE_PERL%%/Method