aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/squid30/Makefile5
-rw-r--r--www/squid30/files/patch-tools-Makefile.in66
-rw-r--r--www/squid31/Makefile5
-rw-r--r--www/squid31/files/patch-tools-Makefile.in66
4 files changed, 120 insertions, 22 deletions
diff --git a/www/squid30/Makefile b/www/squid30/Makefile
index 34abae34de95..4e803449e9ce 100644
--- a/www/squid30/Makefile
+++ b/www/squid30/Makefile
@@ -63,6 +63,7 @@
PORTNAME= squid
PORTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
@@ -425,10 +426,6 @@ pre-su-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
-# Create cachemgr.conf.default manually since Squid-3's install routine
-# unfortunately fails to do so (as it did in the old 2.5 days...):
- ${INSTALL_DATA} ${WRKSRC}/tools/cachemgr.conf \
- ${PREFIX}/etc/squid/cachemgr.conf.default
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/helpers/basic_auth/DB/passwd.sql ${EXAMPLESDIR}
diff --git a/www/squid30/files/patch-tools-Makefile.in b/www/squid30/files/patch-tools-Makefile.in
index 3daee0c17c82..a340337d0aa2 100644
--- a/www/squid30/files/patch-tools-Makefile.in
+++ b/www/squid30/files/patch-tools-Makefile.in
@@ -1,11 +1,63 @@
---- tools/Makefile.in.orig Sun May 14 18:30:04 2006
-+++ tools/Makefile.in Sun May 14 18:31:02 2006
-@@ -297,7 +297,7 @@
+This patch is mostly a patch for Squid bug #2346; the default location of the
+cachemgr.cgi configuration file was not correctly passed to the preprocessor
+during compilation.
+
+--- tools/Makefile.in.orig 2008-05-10 16:54:15.000000000 +0200
++++ tools/Makefile.in 2008-05-10 16:56:22.000000000 +0200
+@@ -61,7 +61,7 @@
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ libexecPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS) $(libexec_PROGRAMS)
+-am_cachemgr__CGIEXT__OBJECTS = cachemgr.$(OBJEXT)
++am_cachemgr__CGIEXT__OBJECTS = cachemgr__CGIEXT_-cachemgr.$(OBJEXT)
+ cachemgr__CGIEXT__OBJECTS = $(am_cachemgr__CGIEXT__OBJECTS)
+ cachemgr__CGIEXT__LDADD = $(LDADD)
+ am__DEPENDENCIES_1 =
+@@ -318,7 +318,7 @@
+ SUBDIRS =
+ squidclient_SOURCES = squidclient.cc
+ cachemgr__CGIEXT__SOURCES = cachemgr.cc
+-cachemgr__CGIEXT__CFLAGS = -DDEFAULT_CACHEMGR_CONFIG=\"$(DEFAULT_CACHEMGR_CONFIG)\" $(AM_CFLAGS)
++cachemgr__CGIEXT__CXXFLAGS = -DDEFAULT_CACHEMGR_CONFIG=\"$(DEFAULT_CACHEMGR_CONFIG)\" $(AM_CFLAGS)
+ LDADD = -L../lib -lmiscutil $(XTRA_LIBS)
EXTRA_DIST = \
cachemgr.conf
+@@ -440,7 +440,7 @@
+ distclean-compile:
+ -rm -f *.tab.c
--DEFAULT_CACHEMGR_CONFIG = $(sysconfdir)/cachemgr.conf
-+DEFAULT_CACHEMGR_CONFIG = $(sysconfdir)/cachemgr.conf.default
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cachemgr.Po@am__quote@
++@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/squidclient.Po@am__quote@
- # Don't automatically uninstall config files
- # @if test -f $(DESTDIR)$(DEFAULT_CONFIG_FILE) ; then \
+ .cc.o:
+@@ -467,6 +467,20 @@
+ @AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCXX_FALSE@ $(LTCXXCOMPILE) -c -o $@ $<
+
++cachemgr__CGIEXT_-cachemgr.o: cachemgr.cc
++@am__fastdepCXX_TRUE@ if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -MT cachemgr__CGIEXT_-cachemgr.o -MD -MP -MF "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" -c -o cachemgr__CGIEXT_-cachemgr.o `test -f 'cachemgr.cc' || echo '$(srcdir)/'`cachemgr.cc; \
++@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Po"; else rm -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo"; exit 1; fi
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='cachemgr.cc' object='cachemgr__CGIEXT_-cachemgr.o' libtool=no @AMDEPBACKSLASH@
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
++@am__fastdepCXX_FALSE@ $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -c -o cachemgr__CGIEXT_-cachemgr.o `test -f 'cachemgr.cc' || echo '$(srcdir)/'`cachemgr.cc
++
++cachemgr__CGIEXT_-cachemgr.obj: cachemgr.cc
++@am__fastdepCXX_TRUE@ if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -MT cachemgr__CGIEXT_-cachemgr.obj -MD -MP -MF "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" -c -o cachemgr__CGIEXT_-cachemgr.obj `if test -f 'cachemgr.cc'; then $(CYGPATH_W) 'cachemgr.cc'; else $(CYGPATH_W) '$(srcdir)/cachemgr.cc'; fi`; \
++@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Po"; else rm -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo"; exit 1; fi
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='cachemgr.cc' object='cachemgr__CGIEXT_-cachemgr.obj' libtool=no @AMDEPBACKSLASH@
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
++@am__fastdepCXX_FALSE@ $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -c -o cachemgr__CGIEXT_-cachemgr.obj `if test -f 'cachemgr.cc'; then $(CYGPATH_W) 'cachemgr.cc'; else $(CYGPATH_W) '$(srcdir)/cachemgr.cc'; fi`
++
+ mostlyclean-libtool:
+ -rm -f *.lo
+
+@@ -835,6 +849,8 @@
+ $(OBJS): $(top_srcdir)/include/version.h ../include/autoconf.h
+
+ install-data-local:
++ @echo "$(INSTALL_DATA) $(srcdir)/cachemgr.conf $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG).default"; \
++ $(INSTALL_DATA) $(srcdir)/cachemgr.conf $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG).default;
+ @if test -f $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG) ; then \
+ echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG)" ; \
+ else \
diff --git a/www/squid31/Makefile b/www/squid31/Makefile
index 34abae34de95..4e803449e9ce 100644
--- a/www/squid31/Makefile
+++ b/www/squid31/Makefile
@@ -63,6 +63,7 @@
PORTNAME= squid
PORTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= ftp://ftp.squid-cache.org/pub/%SUBDIR%/ \
ftp://mirrors.24-7-solutions.net/pub/squid/%SUBDIR%/ \
@@ -425,10 +426,6 @@ pre-su-install:
${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
-# Create cachemgr.conf.default manually since Squid-3's install routine
-# unfortunately fails to do so (as it did in the old 2.5 days...):
- ${INSTALL_DATA} ${WRKSRC}/tools/cachemgr.conf \
- ${PREFIX}/etc/squid/cachemgr.conf.default
.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/helpers/basic_auth/DB/passwd.sql ${EXAMPLESDIR}
diff --git a/www/squid31/files/patch-tools-Makefile.in b/www/squid31/files/patch-tools-Makefile.in
index 3daee0c17c82..a340337d0aa2 100644
--- a/www/squid31/files/patch-tools-Makefile.in
+++ b/www/squid31/files/patch-tools-Makefile.in
@@ -1,11 +1,63 @@
---- tools/Makefile.in.orig Sun May 14 18:30:04 2006
-+++ tools/Makefile.in Sun May 14 18:31:02 2006
-@@ -297,7 +297,7 @@
+This patch is mostly a patch for Squid bug #2346; the default location of the
+cachemgr.cgi configuration file was not correctly passed to the preprocessor
+during compilation.
+
+--- tools/Makefile.in.orig 2008-05-10 16:54:15.000000000 +0200
++++ tools/Makefile.in 2008-05-10 16:56:22.000000000 +0200
+@@ -61,7 +61,7 @@
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ libexecPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS) $(libexec_PROGRAMS)
+-am_cachemgr__CGIEXT__OBJECTS = cachemgr.$(OBJEXT)
++am_cachemgr__CGIEXT__OBJECTS = cachemgr__CGIEXT_-cachemgr.$(OBJEXT)
+ cachemgr__CGIEXT__OBJECTS = $(am_cachemgr__CGIEXT__OBJECTS)
+ cachemgr__CGIEXT__LDADD = $(LDADD)
+ am__DEPENDENCIES_1 =
+@@ -318,7 +318,7 @@
+ SUBDIRS =
+ squidclient_SOURCES = squidclient.cc
+ cachemgr__CGIEXT__SOURCES = cachemgr.cc
+-cachemgr__CGIEXT__CFLAGS = -DDEFAULT_CACHEMGR_CONFIG=\"$(DEFAULT_CACHEMGR_CONFIG)\" $(AM_CFLAGS)
++cachemgr__CGIEXT__CXXFLAGS = -DDEFAULT_CACHEMGR_CONFIG=\"$(DEFAULT_CACHEMGR_CONFIG)\" $(AM_CFLAGS)
+ LDADD = -L../lib -lmiscutil $(XTRA_LIBS)
EXTRA_DIST = \
cachemgr.conf
+@@ -440,7 +440,7 @@
+ distclean-compile:
+ -rm -f *.tab.c
--DEFAULT_CACHEMGR_CONFIG = $(sysconfdir)/cachemgr.conf
-+DEFAULT_CACHEMGR_CONFIG = $(sysconfdir)/cachemgr.conf.default
+-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cachemgr.Po@am__quote@
++@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Po@am__quote@
+ @AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/squidclient.Po@am__quote@
- # Don't automatically uninstall config files
- # @if test -f $(DESTDIR)$(DEFAULT_CONFIG_FILE) ; then \
+ .cc.o:
+@@ -467,6 +467,20 @@
+ @AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+ @am__fastdepCXX_FALSE@ $(LTCXXCOMPILE) -c -o $@ $<
+
++cachemgr__CGIEXT_-cachemgr.o: cachemgr.cc
++@am__fastdepCXX_TRUE@ if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -MT cachemgr__CGIEXT_-cachemgr.o -MD -MP -MF "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" -c -o cachemgr__CGIEXT_-cachemgr.o `test -f 'cachemgr.cc' || echo '$(srcdir)/'`cachemgr.cc; \
++@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Po"; else rm -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo"; exit 1; fi
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='cachemgr.cc' object='cachemgr__CGIEXT_-cachemgr.o' libtool=no @AMDEPBACKSLASH@
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
++@am__fastdepCXX_FALSE@ $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -c -o cachemgr__CGIEXT_-cachemgr.o `test -f 'cachemgr.cc' || echo '$(srcdir)/'`cachemgr.cc
++
++cachemgr__CGIEXT_-cachemgr.obj: cachemgr.cc
++@am__fastdepCXX_TRUE@ if $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -MT cachemgr__CGIEXT_-cachemgr.obj -MD -MP -MF "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" -c -o cachemgr__CGIEXT_-cachemgr.obj `if test -f 'cachemgr.cc'; then $(CYGPATH_W) 'cachemgr.cc'; else $(CYGPATH_W) '$(srcdir)/cachemgr.cc'; fi`; \
++@am__fastdepCXX_TRUE@ then mv -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo" "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Po"; else rm -f "$(DEPDIR)/cachemgr__CGIEXT_-cachemgr.Tpo"; exit 1; fi
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ source='cachemgr.cc' object='cachemgr__CGIEXT_-cachemgr.obj' libtool=no @AMDEPBACKSLASH@
++@AMDEP_TRUE@@am__fastdepCXX_FALSE@ DEPDIR=$(DEPDIR) $(CXXDEPMODE) $(depcomp) @AMDEPBACKSLASH@
++@am__fastdepCXX_FALSE@ $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(cachemgr__CGIEXT__CXXFLAGS) $(CXXFLAGS) -c -o cachemgr__CGIEXT_-cachemgr.obj `if test -f 'cachemgr.cc'; then $(CYGPATH_W) 'cachemgr.cc'; else $(CYGPATH_W) '$(srcdir)/cachemgr.cc'; fi`
++
+ mostlyclean-libtool:
+ -rm -f *.lo
+
+@@ -835,6 +849,8 @@
+ $(OBJS): $(top_srcdir)/include/version.h ../include/autoconf.h
+
+ install-data-local:
++ @echo "$(INSTALL_DATA) $(srcdir)/cachemgr.conf $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG).default"; \
++ $(INSTALL_DATA) $(srcdir)/cachemgr.conf $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG).default;
+ @if test -f $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG) ; then \
+ echo "$@ will not overwrite existing $(DESTDIR)$(DEFAULT_CACHEMGR_CONFIG)" ; \
+ else \