aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/scons/Makefile7
-rw-r--r--devel/scons/files/patch-script__scons8
2 files changed, 5 insertions, 10 deletions
diff --git a/devel/scons/Makefile b/devel/scons/Makefile
index 5ba7263ee0e5..7fe1da468075 100644
--- a/devel/scons/Makefile
+++ b/devel/scons/Makefile
@@ -10,13 +10,16 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Build tool alternative to make
LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4
-USES= python:2
+USES= python:2 shebangfix
+SHEBANG_FILES= script/scons
USE_PYTHON= distutils autoplist
+NO_ARCH= yes
-PLIST_SUB+= SCONS_VER=${PORTVERSION}
+PLIST_SUB= SCONS_VER=${PORTVERSION}
post-patch:
@${REINPLACE_CMD} \
diff --git a/devel/scons/files/patch-script__scons b/devel/scons/files/patch-script__scons
deleted file mode 100644
index 0284c4531535..000000000000
--- a/devel/scons/files/patch-script__scons
+++ /dev/null
@@ -1,8 +0,0 @@
---- script/scons.orig 2015-11-09 11:25:09 UTC
-+++ script/scons
-@@ -1,4 +1,4 @@
--#! /usr/bin/env python
-+#! /usr/bin/env python2
- #
- # SCons - a Software Constructor
- #