aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/exim/Makefile18
-rw-r--r--mail/exim/files/wishlist-suppress-received.patch26
2 files changed, 43 insertions, 1 deletions
diff --git a/mail/exim/Makefile b/mail/exim/Makefile
index c9d14a17c7dc..6dc5355cec4b 100644
--- a/mail/exim/Makefile
+++ b/mail/exim/Makefile
@@ -145,7 +145,10 @@ DB_LIB_VERSION?=1
#
# Disable support for the LMTP (RFC 2033 "SMTP over command pipe")
# transport.
-#WITHOUT_LMTP
+#WITHOUT_LMTP= yes
+#
+# Include the unsupported patches in ${PATCHDIR}/wishlist-*.patch
+#WITH_WISHLIST= yes
# You should not need to fiddle with anything below this point.
@@ -153,6 +156,10 @@ DB_LIB_VERSION?=1
RUN_DEPENDS= ${LOCALBASE}/sbin/eximon:${PORTSDIR}/mail/exim-monitor
.endif
+.if defined(WITH_WISHLIST)
+EXTRA_PATCHES+= `${FIND} ${PATCHDIR} -name 'wishlist-*.patch'`
+.endif
+
.include <bsd.port.pre.mk>
PORTDOC_FILES= Exim3.upgrade Exim4.upgrade OptionLists.txt README \
@@ -338,6 +345,15 @@ SEDLIST+= -e 's,^\# LOOKUP_NIS=,LOOKUP_NIS=,'
SEDLIST+= -e 's,^\# TRANSPORT_LMTP=,TRANSPORT_LMTP=,'
.endif
+pre-everything::
+.if empty(.MAKEFLAGS:M-s) && defined(WITH_WISHLIST)
+ @${ECHO} ''
+ @${ECHO} 'Included extra patches:'
+ @${FIND} ${PATCHDIR} -name 'wishlist-*.patch' \
+ -exec ${SED} -ne 's,^# , ,p' {} \;
+ @${ECHO} ''
+.endif
+
post-patch:
.if defined(WITH_EXISCAN_ACL)
${BZCAT} ${DISTDIR}/${DIST_SUBDIR}/exiscan-acl-${EXISCAN_ACL_VERSION}.patch.bz2 \
diff --git a/mail/exim/files/wishlist-suppress-received.patch b/mail/exim/files/wishlist-suppress-received.patch
new file mode 100644
index 000000000000..cbd23c1bb8d4
--- /dev/null
+++ b/mail/exim/files/wishlist-suppress-received.patch
@@ -0,0 +1,26 @@
+#
+# (Exim 4 wish list #163) suppress the "Received:" header if
+# received_header_text is empty.
+#
+--- src/receive.c.orig Mon May 12 15:39:21 2003
++++ src/receive.c Fri Jun 13 03:17:26 2003
+@@ -1915,9 +1915,17 @@
+ /* The first element on the header chain is reserved for the Received
+ header, so all we have to do is fill in the text pointer. */
+
+-header_list->text = string_sprintf("%s; %s\n", received, timestamp);
++if (received[0] == 0)
++ {
++ header_list->text = string_sprintf("Received: ; %s\n", timestamp);
++ header_list->type = htype_old;
++ }
++else
++ {
++ header_list->text = string_sprintf("%s; %s\n", received, timestamp);
++ header_list->type = htype_received;
++ }
+ header_list->slen = Ustrlen(header_list->text);
+-header_list->type = htype_received;
+
+
+ /* If there is no From: header, generate one. If there is no sender address,