aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mhwaveedit/Makefile3
-rw-r--r--audio/mhwaveedit/distinfo4
-rw-r--r--audio/mhwaveedit/files/patch-src::recorddialog.c12
3 files changed, 15 insertions, 4 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index ece6079d1e5c..6f4a328e1403 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.8
-PORTREVISION= 1
+PORTVERSION= 1.2.9
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
index f151cdef78c4..2e13df53852c 100644
--- a/audio/mhwaveedit/distinfo
+++ b/audio/mhwaveedit/distinfo
@@ -1,2 +1,2 @@
-MD5 (mhwaveedit-1.2.8.tar.gz) = 34dec235a2bc4cbff96015a15dd352f0
-SIZE (mhwaveedit-1.2.8.tar.gz) = 232581
+MD5 (mhwaveedit-1.2.9.tar.gz) = 94b4caee594a39bb2175dfc36b1287c7
+SIZE (mhwaveedit-1.2.9.tar.gz) = 256750
diff --git a/audio/mhwaveedit/files/patch-src::recorddialog.c b/audio/mhwaveedit/files/patch-src::recorddialog.c
new file mode 100644
index 000000000000..972a959c5453
--- /dev/null
+++ b/audio/mhwaveedit/files/patch-src::recorddialog.c
@@ -0,0 +1,12 @@
+--- src/recorddialog.c.orig Sat Apr 17 12:41:52 2004
++++ src/recorddialog.c Mon Apr 19 19:27:35 2004
+@@ -590,8 +590,7 @@
+ void record_dialog_init(RecordDialog *obj)
+ {
+ GtkWidget *a,*b,*c,*d,*e;
+-GtkAccelGroup* ag;
+-ag = gtk_accel_group_new();
++ GtkAccelGroup* ag = gtk_accel_group_new();
+ GList *l2 = NULL;
+ RecordFormat *rf;
+ guint i;