aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--LEGAL3
-rw-r--r--security/Makefile1
-rw-r--r--security/truecrypt/Makefile84
-rw-r--r--security/truecrypt/distinfo10
-rw-r--r--security/truecrypt/pkg-descr15
-rw-r--r--security/truecrypt/pkg-message14
6 files changed, 127 insertions, 0 deletions
diff --git a/LEGAL b/LEGAL
index 4b09feaba103..894030492f8d 100644
--- a/LEGAL
+++ b/LEGAL
@@ -23,6 +23,9 @@ Such ports are listed below:
Dist Port Why
------------------------------------------------------------------------------
+TrueCrypt* security/truecrypt May not be redistributed.
+ Crypto; export-controlled.
+ Must accept license to download.
ventrilo_srv-* audio/ventrilo-server May not be redistributed.
Crypto; export-controlled.
For personal use only.
diff --git a/security/Makefile b/security/Makefile
index 3c5c053f8709..0cb5d9973c8f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -853,6 +853,7 @@
SUBDIR += tripwire-131
SUBDIR += tripwire12
SUBDIR += trousers
+ SUBDIR += truecrypt
SUBDIR += tthsum
SUBDIR += tuntun
SUBDIR += umit
diff --git a/security/truecrypt/Makefile b/security/truecrypt/Makefile
new file mode 100644
index 000000000000..5afbe16a2d09
--- /dev/null
+++ b/security/truecrypt/Makefile
@@ -0,0 +1,84 @@
+# New ports collection makefile for: truecrypt
+# Date created: 9 May 2011
+# Whom: Ryan Steinmetz
+#
+# $FreeBSD$
+
+PORTNAME= truecrypt
+PORTVERSION= 7.0a
+CATEGORIES= security
+MASTER_SITES= SF/wxwindows/${WX_VER}/:wxwidgets \
+ ftp://ftp.rsasecurity.com/pub/pkcs/pkcs-11/v2-20/:rsa
+DISTFILES= ${TC_SRCFILE}:tc \
+ wxWidgets-${WX_VER}.tar.gz:wxwidgets \
+ pkcs11.h:rsa \
+ pkcs11f.h:rsa \
+ pkcs11t.h:rsa
+EXTRACT_ONLY= ${TC_SRCFILE} wxWidgets-${WX_VER}.tar.gz
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= Free open-source disk encryption software
+
+BUILD_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod \
+ nasm:${PORTSDIR}/devel/nasm
+LIB_DEPENDS= fuse.2:${PORTSDIR}/sysutils/fusefs-libs
+RUN_DEPENDS= ${LOCALBASE}/modules/fuse.ko:${PORTSDIR}/sysutils/fusefs-kmod
+
+WRKSRC= ${WRKDIR}/truecrypt-${PORTVERSION}-source
+
+USE_GMAKE= yes
+USE_ICONV= yes
+RESTRICTED= Downloading requires acceptance of license agreement
+NO_CDROM= Distribution requires acceptance of license agreement
+NO_PACKAGE= Distribution requires acceptance of license agreement
+
+TC_SRCFILE= TrueCrypt_${PORTVERSION}_Source.tar.gz
+WX_VER= 2.8.12
+
+LICENSE_FILE= ${WRKSRC}/License.txt
+
+PLIST_FILES= bin/truecrypt
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= %%DOCSDIR%%/TrueCrypt\ User\ Guide.pdf
+PLIST_FILES+= %%DOCSDIR%%/License.txt
+PLIST_DIRS= %%DOCSDIR%%
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if (!exists(${DISTDIR}/${TC_SRCFILE}))
+DISTFILE_INSTRUCTIONS=\n\
+Due to licensing restrictions, certain files must be fetched manually.\n\n\
+Please visit http://www.truecrypt.org/downloads2 with a web browser and accept the\
+License Agreement.\n\
+Select the Mac OS X / Linux (.tar.gz) version\n\n\
+Place the downloaded file into ${DISTDIR} and rename it to ${TC_SRCFILE}\n\n\
+Then, please restart the build.\n\n
+.endif
+
+pre-fetch:
+.if defined(DISTFILE_INSTRUCTIONS)
+ @${PRINTF} "${DISTFILE_INSTRUCTIONS}"
+ @exit 1
+.endif
+
+do-build:
+ @${MKDIR} ${WRKDIR}/rsa
+ @${CP} ${DISTDIR}/pkcs11.h ${WRKDIR}/rsa
+ @${CP} ${DISTDIR}/pkcs11t.h ${WRKDIR}/rsa
+ @${CP} ${DISTDIR}/pkcs11f.h ${WRKDIR}/rsa
+ cd ${WRKSRC} && ${GMAKE} NOGUI=1 PKCS11_INC=${WRKDIR}/rsa WX_ROOT=${WRKDIR}/wxWidgets-${WX_VER} wxbuild
+ cd ${WRKSRC} && ${GMAKE} NOGUI=1 WXSTATIC=1 PKCS11_INC=${WRKDIR}/rsa
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/Main/truecrypt ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/License.txt ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/Release/Setup\ Files/TrueCrypt\ User\ Guide.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/security/truecrypt/distinfo b/security/truecrypt/distinfo
new file mode 100644
index 000000000000..84339be3c104
--- /dev/null
+++ b/security/truecrypt/distinfo
@@ -0,0 +1,10 @@
+SHA256 (TrueCrypt_7.0a_Source.tar.gz) = 6c845153ee868429e2a531407383e9349754d1579cf66fc838632c44baaba021
+SIZE (TrueCrypt_7.0a_Source.tar.gz) = 1996312
+SHA256 (wxWidgets-2.8.12.tar.gz) = 197c94f7d46269a7fc261a3c8c943f03a9807acf65381944489a538fd8b5dd21
+SIZE (wxWidgets-2.8.12.tar.gz) = 18924737
+SHA256 (pkcs11.h) = 1563d877b6f8868b8eb8687358162bfb7f868104ed694beb35ae1c5cf1a58b9b
+SIZE (pkcs11.h) = 9578
+SHA256 (pkcs11f.h) = 5ae6a4f32ca737e02def3bf314c9842fb89be82bf00b6f4022a97d8d565522b8
+SIZE (pkcs11f.h) = 29258
+SHA256 (pkcs11t.h) = 8ce68616304684f92a7e267bcc8f486441e92a5cbdfcfd97e69ac9a0b436fb7b
+SIZE (pkcs11t.h) = 70934
diff --git a/security/truecrypt/pkg-descr b/security/truecrypt/pkg-descr
new file mode 100644
index 000000000000..2b0617f25c07
--- /dev/null
+++ b/security/truecrypt/pkg-descr
@@ -0,0 +1,15 @@
+Free open-source disk encryption software
+
+Main Features:
+* Creates a virtual encrypted disk within a file and mounts it as
+ a real disk.
+* Encrypts an entire partition or storage device such as USB flash
+ drive or hard drive.
+* Encryption is automatic, real-time (on-the-fly) and transparent.
+* Parallelization and pipelining allow data to be read and written
+ as fast as if the drive was not encrypted.
+* Provides plausible deniability, in case an adversary forces you
+ to reveal the password:
+ Hidden volume (steganography) and hidden operating system.
+
+WWW: http://www.truecrypt.org/
diff --git a/security/truecrypt/pkg-message b/security/truecrypt/pkg-message
new file mode 100644
index 000000000000..31d58ea22c72
--- /dev/null
+++ b/security/truecrypt/pkg-message
@@ -0,0 +1,14 @@
+===========================================================
+*** WARNING ***
+
+TrueCrypt is not offically supported under FreeBSD, however
+it does seem to function fine under certain conditions.
+
+Until TrueCrypt is officially supported under FreeBSD, this
+port should be considered experimental. TrueCrypt's website
+cites that system instability is possible.
+
+Please ensure that the fusefs kmod is loaded prior to use.
+
+WWW: http://www.truecrypt.org/misc/freebsd
+===========================================================