aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/animorph/Makefile2
-rw-r--r--graphics/evolvotron/Makefile2
-rw-r--r--graphics/fracplanet/Makefile2
-rw-r--r--graphics/gimmage/Makefile2
-rw-r--r--graphics/goxel/Makefile2
-rw-r--r--graphics/mupdf/Makefile2
-rw-r--r--graphics/pqiv/Makefile2
-rw-r--r--graphics/py-gphoto2/Makefile2
-rw-r--r--graphics/scantailor/Makefile7
-rw-r--r--graphics/waifu2x-converter-cpp/Makefile2
-rw-r--r--graphics/wayland/Makefile2
-rw-r--r--irc/ezbounce/Makefile2
-rw-r--r--mail/isync/Makefile2
-rw-r--r--mail/openemm2013/Makefile4
-rw-r--r--mail/openemm2015/Makefile4
-rw-r--r--math/drgeo/Makefile2
-rw-r--r--math/libmesh/Makefile2
-rw-r--r--math/libqalculate/Makefile2
-rw-r--r--math/pari/Makefile2
-rw-r--r--math/rexx-regmath/Makefile2
-rw-r--r--math/stp/Makefile5
-rw-r--r--misc/bibletime/Makefile2
-rw-r--r--misc/free42/Makefile1
-rw-r--r--misc/libpostal/Makefile2
-rw-r--r--misc/libsweep-lidar/Makefile2
-rw-r--r--multimedia/gstreamer1-editing-services/Makefile2
-rw-r--r--net-im/prosody/Makefile2
-rw-r--r--net-mgmt/mdata-client/Makefile5
-rw-r--r--net-p2p/torrent-file-editor/Makefile2
-rw-r--r--net-p2p/verlihub-plugins-floodprotect/Makefile2
-rw-r--r--net-p2p/xmrig/Makefile2
-rw-r--r--net/bird2/Makefile2
-rw-r--r--net/delegate/Makefile2
-rw-r--r--net/freeradius3/Makefile4
-rw-r--r--net/grive2/Makefile2
-rw-r--r--net/liferea/Makefile2
-rw-r--r--net/ndproxy/Makefile2
-rw-r--r--net/samba46/Makefile2
-rw-r--r--net/samba48/Makefile2
39 files changed, 84 insertions, 10 deletions
diff --git a/graphics/animorph/Makefile b/graphics/animorph/Makefile
index 35bd39142b13..bb52659ba47e 100644
--- a/graphics/animorph/Makefile
+++ b/graphics/animorph/Makefile
@@ -12,6 +12,8 @@ COMMENT= Morphing engine for MakeHuman
LICENSE= LGPL21
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-std=gnu++03"
+
GNU_CONFIGURE= yes
USES= pkgconfig gmake libtool
USE_LDCONFIG= yes
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index cfc8ba3bc55e..f6a6a70697c3 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -15,6 +15,8 @@ COMMENT= Generative software that evolves images/textures/patterns
LICENSE= GPLv3+ # LICENSE file is GPLv2 though
+BROKEN_powerpc64= fails to link: evolvotron.o: undefined reference to boost::program_options::options_description::options_description
+
LIB_DEPENDS= libboost_thread.so:devel/boost-libs
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/fracplanet/Makefile b/graphics/fracplanet/Makefile
index c21a68542ccf..7f3d2a37cb34 100644
--- a/graphics/fracplanet/Makefile
+++ b/graphics/fracplanet/Makefile
@@ -16,6 +16,8 @@ COMMENT= Interactive tool for creating random fractal planets and terrain
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to link: obj/fracplanet.o:(.text+0x250): undefined reference to boost::program_options::options_description::options_description
+
BUILD_DEPENDS= xsltproc:textproc/libxslt
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
diff --git a/graphics/gimmage/Makefile b/graphics/gimmage/Makefile
index 480a688b8a2d..934014e5c6b6 100644
--- a/graphics/gimmage/Makefile
+++ b/graphics/gimmage/Makefile
@@ -13,6 +13,8 @@ COMMENT= Simple image viewer
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to configure: C++ compiler cannot create executables
+
LIB_DEPENDS= libcurl.so:ftp/curl \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
diff --git a/graphics/goxel/Makefile b/graphics/goxel/Makefile
index fa3af01874b6..583f0026e487 100644
--- a/graphics/goxel/Makefile
+++ b/graphics/goxel/Makefile
@@ -12,6 +12,8 @@ COMMENT= Free and Open Source 3D Voxel Editor
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to build: sh: clang++: not found
+
LIB_DEPENDS= libargp.so:devel/argp-standalone \
libglfw.so:graphics/glfw \
libpng.so:graphics/png
diff --git a/graphics/mupdf/Makefile b/graphics/mupdf/Makefile
index 6e7fffe535a2..ec1696b19c6a 100644
--- a/graphics/mupdf/Makefile
+++ b/graphics/mupdf/Makefile
@@ -15,6 +15,8 @@ COMMENT= Lightweight PDF viewer and toolkit
LICENSE= AGPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: cmsmd5.c:36:51: 'ContextID' undeclared
+
LIB_DEPENDS= libcurl.so:ftp/curl \
libfreetype.so:print/freetype2 \
libharfbuzz.so:print/harfbuzz \
diff --git a/graphics/pqiv/Makefile b/graphics/pqiv/Makefile
index f647fce7019c..1d9ec2564f92 100644
--- a/graphics/pqiv/Makefile
+++ b/graphics/pqiv/Makefile
@@ -10,6 +10,8 @@ COMMENT= Pretty Quick Image Viewer
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: pqiv.c:1183: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
BUILD_DEPENDS= bash:shells/bash
diff --git a/graphics/py-gphoto2/Makefile b/graphics/py-gphoto2/Makefile
index 635a92d1c906..9fd3855b27f5 100644
--- a/graphics/py-gphoto2/Makefile
+++ b/graphics/py-gphoto2/Makefile
@@ -13,6 +13,8 @@ COMMENT= Python bindings for libgphoto2
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-unused-but-set-variable"
+
LIB_DEPENDS= libgphoto2.so:graphics/libgphoto2
USES= pkgconfig python shebangfix
diff --git a/graphics/scantailor/Makefile b/graphics/scantailor/Makefile
index 1cd484bd43c5..5f7606190d6e 100644
--- a/graphics/scantailor/Makefile
+++ b/graphics/scantailor/Makefile
@@ -12,11 +12,12 @@ COMMENT= Interactive post-processing tool for scanned pages
LICENSE= GPLv3
-LIB_DEPENDS= libtiff.so:graphics/tiff \
- libjbig.so:graphics/jbigkit \
- libpng.so:graphics/png \
+BROKEN_powerpc64= fails to compile: core.hpp:69: boost::lambda::<unnamed>::_1 causes a section type conflict
BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs
+LIB_DEPENDS= libtiff.so:graphics/tiff \
+ libjbig.so:graphics/jbigkit \
+ libpng.so:graphics/png
#MAKE_JOBS_UNSAFE= yes
USES= cmake gettext jpeg
diff --git a/graphics/waifu2x-converter-cpp/Makefile b/graphics/waifu2x-converter-cpp/Makefile
index 083d6fa96113..3ed942948aa4 100644
--- a/graphics/waifu2x-converter-cpp/Makefile
+++ b/graphics/waifu2x-converter-cpp/Makefile
@@ -14,6 +14,8 @@ LICENSE_COMB= multi
LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/LICENSE
LICENSE_FILE_MIT= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to link: libw2xc.so: undefined reference to cv::imread
+
BUILD_DEPENDS= ${LOCALBASE}/include/CL/opencl.h:devel/opencl
LIB_DEPENDS= libopencv_highgui.so:graphics/opencv \
libopencv_imgproc.so:graphics/opencv-core
diff --git a/graphics/wayland/Makefile b/graphics/wayland/Makefile
index 81b030775a5a..5c4381aca178 100644
--- a/graphics/wayland/Makefile
+++ b/graphics/wayland/Makefile
@@ -12,6 +12,8 @@ COMMENT= Wayland composite "server"
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: tests/test-runner.c:349: undefined reference to prctl
+
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libffi.so:devel/libffi \
libepoll-shim.so:devel/libepoll-shim
diff --git a/irc/ezbounce/Makefile b/irc/ezbounce/Makefile
index 47eff15464f4..6dd39769c135 100644
--- a/irc/ezbounce/Makefile
+++ b/irc/ezbounce/Makefile
@@ -10,6 +10,8 @@ MASTER_SITES= http://BSDforge.com/projects/source/irc/ezbounce/
MAINTAINER= portmaster@BSDforge.com
COMMENT= Highly configurable IRC Proxy
+BROKEN_powerpc64= fails to configure: checking for boostlib >= 1.33... not found
+
OPTIONS_DEFINE= DOCS SSL COMPRESS
OPTIONS_DEFAULT=SSL COMPRESS
OPTIONS_SUB= yes
diff --git a/mail/isync/Makefile b/mail/isync/Makefile
index e074362834f4..7cc9099ee844 100644
--- a/mail/isync/Makefile
+++ b/mail/isync/Makefile
@@ -11,6 +11,8 @@ COMMENT= Maintain local copies of remote IMAP folders w/synchronized flags
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: util.c:523: #pragma GCC diagnostic not allowed inside functions
+
LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
USES= alias bdb cpe perl5 ssl
diff --git a/mail/openemm2013/Makefile b/mail/openemm2013/Makefile
index 6f2e60399cd0..3422f1a239b9 100644
--- a/mail/openemm2013/Makefile
+++ b/mail/openemm2013/Makefile
@@ -17,6 +17,8 @@ COMMENT= OpenEMM a email marketing enterprise app
LICENSE= CPAL-1.0
LICENSE_FILE= ${WRKSRC}/other/LICENSE.txt
+BROKEN_powerpc64= fails to build: gmake[1]: clang: Command not found
+
LIB_DEPENDS= libslang.so:devel/libslang2 \
libsa.so:net/ossp-sa
BUILD_DEPENDS= ${TOMCATHOME}/bin/bootstrap.jar:www/tomcat8 \
@@ -24,11 +26,11 @@ BUILD_DEPENDS= ${TOMCATHOME}/bin/bootstrap.jar:www/tomcat8 \
RUN_DEPENDS= ${TOMCATHOME}/bin/bootstrap.jar:www/tomcat8 \
py27-MySQLdb>=1.2.3:databases/py-MySQLdb
+USES= dos2unix gmake python:2.7,run
USE_RC_SUBR= openemm2013
USE_JAVA= yes
JAVA_VERSION= 1.7+
-USES= dos2unix gmake python:2.7,run
DOS2UNIX_GLOB= *.c *.cpp *.h *.java *.xml *.properties
CC= clang
CXX= clang++
diff --git a/mail/openemm2015/Makefile b/mail/openemm2015/Makefile
index 665847c05e5f..71a7c916fe01 100644
--- a/mail/openemm2015/Makefile
+++ b/mail/openemm2015/Makefile
@@ -16,6 +16,8 @@ COMMENT= OpenEMM a email marketing enterprise app
LICENSE= CPAL-1.0
LICENSE_FILE= ${WRKSRC}/other/LICENSE.txt
+BROKEN_powerpc64= fails to build: gmake[1]: clang: Command not found
+
LIB_DEPENDS= libslang.so:devel/libslang2 \
libsa.so:net/ossp-sa
BUILD_DEPENDS= ${TOMCATHOME}/bin/bootstrap.jar:www/tomcat8 \
@@ -23,11 +25,11 @@ BUILD_DEPENDS= ${TOMCATHOME}/bin/bootstrap.jar:www/tomcat8 \
RUN_DEPENDS= ${TOMCATHOME}/bin/bootstrap.jar:www/tomcat8 \
py27-MySQLdb>=1.2.3:databases/py-MySQLdb
+USES= dos2unix gmake python:2.7,run
USE_RC_SUBR= openemm2015
USE_JAVA= yes
JAVA_VERSION= 1.7+
-USES= dos2unix gmake python:2.7,run
DOS2UNIX_GLOB= *.c *.cpp *.h *.java *.xml *.properties
CC= clang
CXX= clang++
diff --git a/math/drgeo/Makefile b/math/drgeo/Makefile
index 9eec9611843c..e69bfc360d82 100644
--- a/math/drgeo/Makefile
+++ b/math/drgeo/Makefile
@@ -13,6 +13,8 @@ COMMENT= GTK interactive geometry software
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: ./geo/libgeo.a: multiple definition of drgeoDialogData
+
LIB_DEPENDS= libguile.so:lang/guile
GNU_CONFIGURE= yes
diff --git a/math/libmesh/Makefile b/math/libmesh/Makefile
index 25e220fcbaf8..304dae01a2f8 100644
--- a/math/libmesh/Makefile
+++ b/math/libmesh/Makefile
@@ -13,6 +13,8 @@ COMMENT= Numerical simulation of partial differential equations
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to link: libcontrib_opt.a: relocation truncated to fit: R_PPC64_GOT_TLSLD16 against .LANCHOR1
+
LIB_DEPENDS= libboost_system.so:devel/boost-libs
USES= autoreconf eigen:3 gmake libtool
diff --git a/math/libqalculate/Makefile b/math/libqalculate/Makefile
index 15c47cb102c6..7931cba885d9 100644
--- a/math/libqalculate/Makefile
+++ b/math/libqalculate/Makefile
@@ -13,6 +13,8 @@ COMMENT= Multi-purpose desktop calculator (backend library)
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: umachine.h:347: 'char16_t' does not name a type
+
LIB_DEPENDS= libicuuc.so:devel/icu \
libcurl.so:ftp/curl \
libgmp.so:math/gmp \
diff --git a/math/pari/Makefile b/math/pari/Makefile
index 388522930a58..4d746f16cba9 100644
--- a/math/pari/Makefile
+++ b/math/pari/Makefile
@@ -14,6 +14,8 @@ COMMENT= Mathematics library and advanced calculator package
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to link: intnum.o: relocation truncated to fit: R_PPC64_GOT_TLSGD16 against symbol 'avma' defined in .tbss section in init.o
+
LIB_DEPENDS= libgmp.so:math/gmp
USES= perl5 readline
diff --git a/math/rexx-regmath/Makefile b/math/rexx-regmath/Makefile
index 9647bc75dd42..c38ac434bac5 100644
--- a/math/rexx-regmath/Makefile
+++ b/math/rexx-regmath/Makefile
@@ -14,6 +14,8 @@ COMMENT= Two mathematics libraries for Rexx
LICENSE= MPL10
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-incompatible-pointer-types"
+
BUILD_DEPENDS= ${LOCALBASE}/include/rexxsaa.h:lang/rexx-regina
USES= zip
diff --git a/math/stp/Makefile b/math/stp/Makefile
index d32029329b4e..3f3a37c286f8 100644
--- a/math/stp/Makefile
+++ b/math/stp/Makefile
@@ -12,6 +12,9 @@ COMMENT= Decision Procedure for Bitvectors and Arrays
LICENSE= MIT
+BROKEN_aarch64= fails to compile: undefined reference to sbrk
+BROKEN_powerpc64= fails to compile: main.cpp.o: undefined reference to boost::program_options::error_with_option_name::get_canonical_option_name()
+
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
@@ -19,6 +22,4 @@ USES= bison:build cmake:noninja perl5 tar:xz
USE_PERL5= build
CMAKE_ARGS= -DFL_LIBRARY=/usr/lib/libfl.a
-BROKEN_aarch64= Fails to compile: undefined reference to sbrk
-
.include <bsd.port.mk>
diff --git a/misc/bibletime/Makefile b/misc/bibletime/Makefile
index 8d711816bf9f..e6157badcbab 100644
--- a/misc/bibletime/Makefile
+++ b/misc/bibletime/Makefile
@@ -11,6 +11,8 @@ COMMENT= Open source Bible study tool
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: btosismorphsegmentation.cpp.o: undefined reference to sword::SWOptionFilter::SWOptionFilter
+
LIB_DEPENDS= libclucene-core.so:textproc/clucene \
libsword.so:misc/sword
diff --git a/misc/free42/Makefile b/misc/free42/Makefile
index 26c31c2f4fd9..66153e55199d 100644
--- a/misc/free42/Makefile
+++ b/misc/free42/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_aarch64= fails to link: c++: error: no such file or directory: 'gcc111libbid.a'
BROKEN_armv6= fails to link: c++: error: no such file or directory: 'gcc111libbid.a'
BROKEN_mips64= fails to link: c++: error: no such file or directory: 'gcc111libbid.a'
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-c++11-narrowing"
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
diff --git a/misc/libpostal/Makefile b/misc/libpostal/Makefile
index 6372ef2fc2a4..42308ebf5356 100644
--- a/misc/libpostal/Makefile
+++ b/misc/libpostal/Makefile
@@ -11,6 +11,8 @@ COMMENT= Library for parsing/normalizing street addresses around the world
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-c++11-narrowing"
+
RUN_DEPENDS= curl:ftp/curl
USES= autoreconf libtool localbase
diff --git a/misc/libsweep-lidar/Makefile b/misc/libsweep-lidar/Makefile
index 07baad1b9bde..bfb9d675468d 100644
--- a/misc/libsweep-lidar/Makefile
+++ b/misc/libsweep-lidar/Makefile
@@ -11,6 +11,8 @@ COMMENT= Low-level Scanse Sweep LiDAR library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Weverything"
+
USES= cmake:outsource
USE_GITHUB= yes
GH_ACCOUNT= scanse
diff --git a/multimedia/gstreamer1-editing-services/Makefile b/multimedia/gstreamer1-editing-services/Makefile
index 82ac2b27f8d3..a37cf0895448 100644
--- a/multimedia/gstreamer1-editing-services/Makefile
+++ b/multimedia/gstreamer1-editing-services/Makefile
@@ -10,6 +10,8 @@ DISTNAME= gstreamer-editing-services-${PORTVERSION}
MAINTAINER= multimedia@FreeBSD.org
COMMENT= GStreamer editing services
+BROKEN_powerpc64= fails to compile: ges-extractable.h:24: error: redefinition of typedef 'GESExtractable'
+
PORTSCOUT= limitw:1,even
USES= gmake gnome libtool pathfix python:2.7 pkgconfig tar:xz
diff --git a/net-im/prosody/Makefile b/net-im/prosody/Makefile
index 4dc092cfecb6..332896512538 100644
--- a/net-im/prosody/Makefile
+++ b/net-im/prosody/Makefile
@@ -13,6 +13,8 @@ COMMENT= Simple extensible XMPP server written in Lua
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: table.c:14: 'for' loop initial declaration used outside C99 mode
+
RUN_DEPENDS= ${LUA_MODLIBDIR}/socket/core.so:net/luasocket-51 \
${LUA_MODLIBDIR}/ssl.so:security/luasec-51 \
${LUA_MODLIBDIR}/lxp.so:textproc/luaexpat-51 \
diff --git a/net-mgmt/mdata-client/Makefile b/net-mgmt/mdata-client/Makefile
index 67f59b23ada5..91700553fdbf 100644
--- a/net-mgmt/mdata-client/Makefile
+++ b/net-mgmt/mdata-client/Makefile
@@ -10,9 +10,10 @@ COMMENT= Metadata tools for use within guests of the SmartOS
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USE_GITHUB= yes
-GH_ACCOUNT= joyent
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-typedef-redefinition"
USES= gmake
+USE_GITHUB= yes
+GH_ACCOUNT= joyent
.include <bsd.port.mk>
diff --git a/net-p2p/torrent-file-editor/Makefile b/net-p2p/torrent-file-editor/Makefile
index 6a945b2feb63..b0703a3ebff7 100644
--- a/net-p2p/torrent-file-editor/Makefile
+++ b/net-p2p/torrent-file-editor/Makefile
@@ -12,6 +12,8 @@ COMMENT= Qt-based GUI tool for creating and editing .torrent files
LICENSE= GPLv3
+BROKEN_powerpc64= fails to compile: -Werror=cpp: No option -Wcpp
+
USES= cmake desktop-file-utils
_QT4_DEPS= linguisttools_build moc_build qmake_build rcc_build \
diff --git a/net-p2p/verlihub-plugins-floodprotect/Makefile b/net-p2p/verlihub-plugins-floodprotect/Makefile
index 51b4c0309efe..5b55bc475f17 100644
--- a/net-p2p/verlihub-plugins-floodprotect/Makefile
+++ b/net-p2p/verlihub-plugins-floodprotect/Makefile
@@ -10,6 +10,8 @@ DISTNAME= ${PLUGIN_NAME}
MAINTAINER= me@skylord.ru
+BROKEN_powerpc64= fails to compile: thasharray.h:338:29: cast from 'std::nullptr_t' to 'short int' loses precision
+
PLUGIN_NAME= floodprot
PLUGIN_DESC= Floodprotect
diff --git a/net-p2p/xmrig/Makefile b/net-p2p/xmrig/Makefile
index 900668382a07..bff5809b8041 100644
--- a/net-p2p/xmrig/Makefile
+++ b/net-p2p/xmrig/Makefile
@@ -12,6 +12,8 @@ COMMENT= High performance Monero (XMR) CPU miner
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to configure: Target "xmrig" requires the language dialect "CXX11", but CMake does not know the compile flags to use to enable it.
+
OPTIONS_DEFINE= STATIC MICROHTTPD
MICROHTTPD_DESC=Build with libmicrohttpd support
OPTIONS_DEFAULT=MICROHTTPD
diff --git a/net/bird2/Makefile b/net/bird2/Makefile
index 0a62062d0d1c..78d9aaeb67d9 100644
--- a/net/bird2/Makefile
+++ b/net/bird2/Makefile
@@ -13,6 +13,8 @@ COMMENT= Dynamic IP routing daemon
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: ./lib/ip.h:337: 'for' loop initial declaration used outside C99 mode
+
LIB_DEPENDS= libssh.so:security/libssh
CONFLICTS= bird-[0-9]*
diff --git a/net/delegate/Makefile b/net/delegate/Makefile
index 48f98ff3da4a..8b0126c27d6d 100644
--- a/net/delegate/Makefile
+++ b/net/delegate/Makefile
@@ -10,6 +10,8 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= danilo@FreeBSD.org
COMMENT= General purpose TCP/IP proxy system
+BROKEN_powerpc64= fails to build: gmake[1]: *** [Makefile:116: mkmake.exe] Error 1
+
USES= gmake
SUB_FILES= pkg-message
diff --git a/net/freeradius3/Makefile b/net/freeradius3/Makefile
index 5803a0cfe86a..2728062298ad 100644
--- a/net/freeradius3/Makefile
+++ b/net/freeradius3/Makefile
@@ -17,6 +17,8 @@ COMMENT= Free RADIUS server implementation
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-date-time"
+
LIB_DEPENDS= libgdbm.so:databases/gdbm \
libtalloc.so:devel/talloc
@@ -26,9 +28,9 @@ KRB5_CONFIG?= /usr/bin/krb5-config --libs
CONFLICTS_INSTALL= gnu-radius-[0-9].* openradius-[0-9].* radiusd-cistron-[0-9].* \
freeradius-mysql-[0-9].* freeradius-[^3].*
+USES= gmake readline shebangfix ssl tar:bzip2
USE_RC_SUBR= radiusd
-USES= gmake readline shebangfix ssl tar:bzip2
SHEBANG_FILES= src/modules/rlm_counter/rad_counter scripts/sql/radsqlrelay
GNU_CONFIGURE= yes
# Prevent /root/.rnd leftover
diff --git a/net/grive2/Makefile b/net/grive2/Makefile
index a2723507380f..48ae38cc458c 100644
--- a/net/grive2/Makefile
+++ b/net/grive2/Makefile
@@ -12,6 +12,8 @@ COMMENT= Open source client for Google Drive
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+BROKEN_powerpc64= fails to compile: JsonValTest.cc.o: undefined reference to boost::unit_test::ut_detail::normalize_test_case_name
+
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index 7c4b60abb3e2..f752ece191b4 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -11,6 +11,8 @@ COMMENT= Simple RSS/RDF feed reader
LICENSE= GPLv2
+BROKEN_powerpc64= fails to compile: WebKitWebEditor.h:40: redefinition of typedef 'WebKitWebEditor'
+
BUILD_DEPENDS= gsettings-desktop-schemas>=0:devel/gsettings-desktop-schemas
LIB_DEPENDS= libsoup-2.4.so:devel/libsoup \
libwebkit2gtk-4.0.so:www/webkit2-gtk3 \
diff --git a/net/ndproxy/Makefile b/net/ndproxy/Makefile
index 545022c5f79d..36258931b4e4 100644
--- a/net/ndproxy/Makefile
+++ b/net/ndproxy/Makefile
@@ -11,6 +11,8 @@ COMMENT= Implementation of IPv6 Neighbor Discovery proxy
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: ndproxy.c:51: function declaration isn't a prototype
+
SUB_FILES= pkg-message
USES= kmod
diff --git a/net/samba46/Makefile b/net/samba46/Makefile
index f35525cfeb19..1bbd72acc296 100644
--- a/net/samba46/Makefile
+++ b/net/samba46/Makefile
@@ -13,6 +13,8 @@ COMMENT?= Free SMB/CIFS and AD/DC server and client for Unix
LICENSE= GPLv3
+BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-format-truncation"
+
IGNORE_NONTHREAD_PYTHON= needs port lang/python${PYTHON_SUFFIX} to be build with THREADS support
CONFLICTS_INSTALL?= samba4-4.0.* samba4[1-57-9]-4.* p5-Parse-Pidl-4.*
diff --git a/net/samba48/Makefile b/net/samba48/Makefile
index 96c50ffdba74..6dd03f582b86 100644
--- a/net/samba48/Makefile
+++ b/net/samba48/Makefile
@@ -13,6 +13,8 @@ COMMENT= Free SMB/CIFS and AD/DC server and client for Unix
LICENSE= GPLv3
+BROKEN_powerpc64= fails to compile: auth.idl:107: Unable to determine origin of type struct cli_credentials
+
IGNORE_NONTHREAD_PYTHON= needs port lang/python${PYTHON_SUFFIX} to be build with THREADS support
CONFLICTS_INSTALL?= samba4-4.0.* samba4[1-79]-4.* p5-Parse-Pidl-4.*