aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pecl-mysqlnd_ms/Makefile24
-rw-r--r--databases/pecl-mysqlnd_ms/distinfo2
-rw-r--r--databases/pecl-mysqlnd_ms/pkg-descr9
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 497ab32fbeaf..40c74b83de75 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -513,6 +513,7 @@
SUBDIR += pecl-memcache
SUBDIR += pecl-memcached
SUBDIR += pecl-mongo
+ SUBDIR += pecl-mysqlnd_ms
SUBDIR += pecl-rrd
SUBDIR += pecl-sqlite
SUBDIR += pecl-tokyo_tyrant
diff --git a/databases/pecl-mysqlnd_ms/Makefile b/databases/pecl-mysqlnd_ms/Makefile
new file mode 100644
index 000000000000..f771a37b1eee
--- /dev/null
+++ b/databases/pecl-mysqlnd_ms/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: pecl-mysqlnd_ms
+# Date created: 13 Oct 2011
+# Whom: johnpupu <johnpupu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mysqlnd_ms
+PORTVERSION= 1.1.1
+CATEGORIES= databases
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= johnpupu@gmail.com
+COMMENT= A replication and load balancing plugin for mysqlnd
+
+USE_PHP= json
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+USE_PHPIZE= yes
+
+.include <bsd.port.mk>
diff --git a/databases/pecl-mysqlnd_ms/distinfo b/databases/pecl-mysqlnd_ms/distinfo
new file mode 100644
index 000000000000..f2abc93adb39
--- /dev/null
+++ b/databases/pecl-mysqlnd_ms/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/mysqlnd_ms-1.1.1.tgz) = d199eef485b574e6bbf0c0b65a35c511897e51a620f75e7c0974b8758e160dec
+SIZE (PECL/mysqlnd_ms-1.1.1.tgz) = 282136
diff --git a/databases/pecl-mysqlnd_ms/pkg-descr b/databases/pecl-mysqlnd_ms/pkg-descr
new file mode 100644
index 000000000000..ce8ec4de0d36
--- /dev/null
+++ b/databases/pecl-mysqlnd_ms/pkg-descr
@@ -0,0 +1,9 @@
+The replication and load balancing plugin is a plugin for the mysqlnd library.
+It can be used with PHP MySQL extensions (ext/mysql, ext/mysqli, PDO_MySQL) if
+they are compiled to use mysqlnd. The plugin inspects queries to do read-write
+splitting. Read-only queries are send to configured MySQL replication slave
+servers all other queries are redirected to the MySQL replication master server.
+Very little, if any, application changes required, dependent on the usage
+scenario required.
+
+WWW: http://pecl.php.net/package/mysqlnd_ms