aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/firebird25-server/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/databases/firebird25-server/Makefile b/databases/firebird25-server/Makefile
index edf8d3b20595..46f270e0fb2b 100644
--- a/databases/firebird25-server/Makefile
+++ b/databases/firebird25-server/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firebird
PORTVERSION= 2.5.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES?= databases
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION:S/.0//}-Release/
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}-server
@@ -24,12 +24,11 @@ LICENSE_PERMS_IPL= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libicuuc.so:${PORTSDIR}/devel/icu
-USES= gmake libedit pkgconfig tar:bzip2
+USES= gmake pkgconfig tar:bzip2
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ARGS= --with-system-editline \
- --with-system-icu \
+CONFIGURE_ARGS= --with-system-icu \
--prefix=${LOCALSTATEDIR} \
--exec-prefix=${PREFIX} \
--with-fbconf=${PREFIX}/${CONFDIR} \
@@ -44,8 +43,7 @@ CONFIGURE_ARGS= --with-system-editline \
--with-fbudf=${LIBEXECDIR}/UDF
CONFIGURE_ENV+= PTHREAD_LIBS="-lpthread" \
ac_cv_header_atomic_ops_h="no" \
- ac_cv_lib_atomic_ops_main="no" \
- ac_cv_lib_edit_readline="yes"
+ ac_cv_lib_atomic_ops_main="no"
LOCALSTATEDIR= /var/db/firebird
CONFDIR= etc/firebird
@@ -76,7 +74,7 @@ IGNORE= your system does not support sysvipc
# Server part stuff
LIB_DEPENDS+= libfbembed.so:${PORTSDIR}/databases/firebird25-client
-CONFIGURE_ARGS+=--enable-superserver
+CONFIGURE_ARGS+=--enable-superserver --without-editline
ALL_TARGET= firebird_embedded firebird_server
@@ -92,6 +90,11 @@ UDF_SQL= src/extlib/ib_udf2.sql src/extlib/fbudf/fbudf.sql
PKGINSTALL?= ${PKGDIR}/pkg-install-server
.else
# Client part stuff
+LIB_DEPENDS+= libedit.so.0:${PORTSDIR}/devel/libedit
+
+CONFIGURE_ARGS+= --with-system-editline
+CONFIGURE_ENV+= ac_cv_lib_edit_readline="yes"
+
ALL_TARGET= firebird_basic libfbembed libfbclient embed_isql embed_gpre \
embed_gdef embed_qli extlib