aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/bsdstats/Makefile9
-rw-r--r--sysutils/bsdstats/files/pkg-message.in27
-rw-r--r--sysutils/bsdstats/pkg-descr15
-rw-r--r--sysutils/bsdstats/pkg-install45
4 files changed, 41 insertions, 55 deletions
diff --git a/sysutils/bsdstats/Makefile b/sysutils/bsdstats/Makefile
index 962bda05a3c2..c2ea9c4069e2 100644
--- a/sysutils/bsdstats/Makefile
+++ b/sysutils/bsdstats/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bsdstats
PORTVERSION= 5.5
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= sysutils
DISTFILES=
@@ -22,13 +22,8 @@ do-install:
${MKDIR} ${PREFIX}/etc/periodic/monthly
${INSTALL_SCRIPT} ${WRKDIR}/300.statistics ${PREFIX}/etc/periodic/monthly
post-install:
- @${CAT} ${PKGMESSAGE}
.if defined(BATCH) || defined(PACKAGE_BUILDING)
- @${ECHO_MSG} " To activate monthly statistics reporting in /etc/periodic.conf,"
- @${ECHO_MSG} " execute the following as root user:"
- @${ECHO_MSG}
- @${ECHO_MSG} "PKG_PREFIX=\"${PREFIX}\" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL"
- @${ECHO_MSG}
+ @${CAT} ${PKGMESSAGE}
.else
@PKG_PREFIX="${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
diff --git a/sysutils/bsdstats/files/pkg-message.in b/sysutils/bsdstats/files/pkg-message.in
index a2a3d5f12bb3..4629e89ff170 100644
--- a/sysutils/bsdstats/files/pkg-message.in
+++ b/sysutils/bsdstats/files/pkg-message.in
@@ -1,30 +1,15 @@
-
-This script, meant to be run monthly, submits statistics anonymously
-to a central checkin server (http://bsdstats.org), in an attempt to
-generate reasonably accurate demographics of both *BSD usage, as well
-as devices in use.
-
-Steps have been taken to make eliminate security concerns brought up
-in earlier releases of this, including, but not limited to, not storing
-anything in the database that has been deemed as 'sensitive' (ie. IP of
-the reporting server, and hostname).
-
********************
-To enable monthly reporting, edit or create /etc/periodic.conf and add this line:
+To enable monthly reporting, add these lines to /etc/periodic.conf:
monthly_statistics_enable="YES"
-
-To enable boottime reporting, edit or create /etc/rc.conf and add this line:
- bsdstats_enable="YES"
-
-To enable device reporting, add this line:
monthly_statistics_report_devices="YES"
-
-To enable ports reporting, add this line:
monthly_statistics_report_ports="YES"
-To run it manually the first time, just run it as:
+To enable reporting on bootup, add this line to /etc/rc.conf:
+ bsdstats_enable="YES"
+
+To run it manually the first time:
%%PREFIX%%/etc/periodic/monthly/300.statistics -nodelay
To view current statistics, go to:
- http://www.bsdstats.org
+ http://www.bsdstats.org/
********************
diff --git a/sysutils/bsdstats/pkg-descr b/sysutils/bsdstats/pkg-descr
index 5c05d0ca325e..d00474c83321 100644
--- a/sysutils/bsdstats/pkg-descr
+++ b/sysutils/bsdstats/pkg-descr
@@ -1,8 +1,15 @@
-The purpose of this port is to attempt to produce reasonably accurate
-statistics on FreeBSD deployment, to be used for both marketing, and
-advocacy purposes by the project.
+BSDstats is an attempt to produce reasonably accurate statistics on
+deployments of BSD operating systems. This is useful for marketing,
+project advocacy, hardware vendors and purchasers, device driver
+maintainers, and port maintainers.
The major problem that we are trying to address is vendors who do not
-feel that FreeBSD presents enough of a market to bother supporting.
+feel that BSD operating systems present enough of a market to bother
+supporting.
+
+Meant to be run monthly or during bootup, this script submits
+statistics anonymously to a central server (http://bsdstats.org).
+Potentially sensitive details like IP addresses and hostnames are not
+stored by or relayed through the BSDstats server.
WWW: http://www.bsdstats.org/
diff --git a/sysutils/bsdstats/pkg-install b/sysutils/bsdstats/pkg-install
index dd228acf9ddf..f6b3f4010ef7 100644
--- a/sysutils/bsdstats/pkg-install
+++ b/sysutils/bsdstats/pkg-install
@@ -3,30 +3,30 @@
# pkg-install : based off ${PORTSDIR}/mail/courier/files/pkg-install.in
#
-# The default answer to "Would you like to activate monthly reporting in
-# /etc/periodic.conf?" is "no", which you can override by setting the
-# BSDSTATS_MONTHLY_ENABLE environment variable to "yes".
+# The default answer to "Would you like to enable monthly reporting in
+# /etc/periodic.conf?" is "yes", which you can override by setting the
+# BSDSTATS_MONTHLY_ENABLE environment variable to "no".
#
# The default answer to "Would you like to send a list of installed hardware
-# as well?" is "no", which you can override by setting the
-# BSDSTATS_MONTHLY_DEVICES environment variable to "yes".
+# as well?" is "yes", which you can override by setting the
+# BSDSTATS_MONTHLY_DEVICES environment variable to "no".
#
# The default answer to "Would you like to send a list of installed ports as
-# well?" is "no", which you can override by setting the BSDSTATS_MONTHLY_PORTS
-# environment variable to "yes".
+# well?" is "yes", which you can override by setting the BSDSTATS_MONTHLY_PORTS
+# environment variable to "no".
#
# The default answer to "Would you like to run it now?" is "yes", which you can
# override by setting the BSDSTATS_MONTHLY_NOW environment variable to "no".
#
-# The default answer to "Would you like to activate reporting on reboot in
-# /etc/rc.conf?" is "no", which you can override by setting the
-# BSDSTATS_REBOOT_REPORTING environment variable to "yes".
+# The default answer to "Would you like to enable reporting on bootup in
+# /etc/rc.conf?" is "yes", which you can override by setting the
+# BSDSTATS_REBOOT_REPORTING environment variable to "no".
-BSDSTATS_MONTHLY_ENABLE=${BSDSTATS_MONTHLY_ENABLE:=no}
-BSDSTATS_MONTHLY_DEVICES=${BSDSTATS_MONTHLY_DEVICES:=no}
-BSDSTATS_MONTHLY_PORTS=${BSDSTATS_MONTHLY_PORTS:=no}
+BSDSTATS_MONTHLY_ENABLE=${BSDSTATS_MONTHLY_ENABLE:=yes}
+BSDSTATS_MONTHLY_DEVICES=${BSDSTATS_MONTHLY_DEVICES:=yes}
+BSDSTATS_MONTHLY_PORTS=${BSDSTATS_MONTHLY_PORTS:=yes}
BSDSTATS_MONTHLY_NOW=${BSDSTATS_MONTHLY_NOW:=yes}
-BSDSTATS_REBOOT_REPORTING=${BSDSTATS_REBOOT_REPORTING:=no}
+BSDSTATS_REBOOT_REPORTING=${BSDSTATS_REBOOT_REPORTING:=yes}
ask() {
local question default answer
@@ -58,8 +58,8 @@ yesno() {
}
if [ "$2" = "POST-INSTALL" ]; then
- if [ -f "/etc/periodic.conf" -a -z "`grep monthly_statistics /etc/periodic.conf`" ] || [ ! -f "/etc/periodic.conf" ]; then
- if yesno "Would you like to activate monthly reporting in /etc/periodic.conf" ${BSDSTATS_MONTHLY_ENABLE}; then
+ if [ ! -f "/etc/periodic.conf" ] || [ -z "`grep monthly_statistics /etc/periodic.conf`" ]; then
+ if yesno "Would you like to enable monthly reporting in /etc/periodic.conf" ${BSDSTATS_MONTHLY_ENABLE}; then
echo "monthly_statistics_enable=\"YES\"" >> /etc/periodic.conf
if yesno "Would you like to send a list of installed hardware as well" ${BSDSTATS_MONTHLY_DEVICES}; then
echo "monthly_statistics_report_devices=\"YES\"" >> /etc/periodic.conf
@@ -72,15 +72,14 @@ if [ "$2" = "POST-INSTALL" ]; then
fi
fi
fi
- if [ -f "/etc/rc.conf" -a -z "`grep bsdstats_enable /etc/rc.conf`" ] || [ ! -f "/etc/rc.conf" ]; then
+ if [ ! -f "/etc/rc.conf" ] || [ -z "`grep bsdstats_enable /etc/rc.conf`" ]; then
echo ""
- echo "If running as a desktop, or on a laptop, it is recommended that you"
- echo "enable bsdstats within /etc/rc.conf, so that it will run on reboot."
+ echo "If you're installing BSDstats on a system that won't always be on, such as a"
+ echo "desktop or a laptop, it is recommended that you enable it in /etc/rc.conf so"
+ echo "that it will run on bootup. This will ensure that, even if your computer is"
+ echo "off when \"monthly\" runs, your computer will be counted properly."
echo ""
- echo "This will ensure that even if your computer is off when monthly runs,"
- echo "your computer will be properly counted."
- echo ""
- if yesno "Would you like to activate reporting on reboot in /etc/rc.conf" ${BSDSTATS_REBOOT_REPORTING}; then
+ if yesno "Would you like to enable reporting on bootup in /etc/rc.conf" ${BSDSTATS_REBOOT_REPORTING}; then
echo "bsdstats_enable=\"YES\"" >> /etc/rc.conf
fi
fi