aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/xaralx-devel/Makefile2
-rw-r--r--graphics/xaralx/Makefile12
2 files changed, 13 insertions, 1 deletions
diff --git a/graphics/xaralx-devel/Makefile b/graphics/xaralx-devel/Makefile
index 2fd4d14c7861..0b9771b03767 100644
--- a/graphics/xaralx-devel/Makefile
+++ b/graphics/xaralx-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTVERSION= 0.5r1261
-PORTREVISION= 0
+PORTREVISION= 1
PKGNAMESUFFIX= -devel
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.bz2
diff --git a/graphics/xaralx/Makefile b/graphics/xaralx/Makefile
index c1a23c896d2a..e0fe3440ee2b 100644
--- a/graphics/xaralx/Makefile
+++ b/graphics/xaralx/Makefile
@@ -79,6 +79,18 @@ BROKEN= does not configure due to the lack of CDraw libraries for ${ARCH}
post-patch:
${REINPLACE_CMD} -E -e 's|-I[^[:space:]]*/wxOil[[:space:]]||g' \
${WRKSRC}/Makefile.am
+ ${REINPLACE_CMD} -E \
+ -e 's/^Name=Xara LX$$/Name=Xara LX ${PORTVERSION}/' \
+ ${WRKSRC}/xaralx.desktop
+.else
+post-patch:
+ ${REINPLACE_CMD} -E \
+ -e 's/^Name=Xara LX$$/Name=Xara LX ${PORTVERSION}/' \
+ -e 's/^Icon=xaralx.png$$/Icon=xaralx${PKGNAMESUFFIX}.png/' \
+ -e 's/^FilePattern=xaralx;$$/FilePattern=xaralx${PKGNAMESUFFIX}/' \
+ -e 's/^Exec=xaralx %F$$/Exec=xaralx${PKGNAMESUFFIX} %F/' \
+ -e 's/^TryExec=xaralx$$/TryExec=xaralx${PKGNAMESUFFIX}/' \
+ ${WRKSRC}/xaralx.desktop
.endif
pre-configure: