aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/mupen64plus-audio-sdl/Makefile1
-rw-r--r--emulators/mupen64plus-core/Makefile10
-rw-r--r--emulators/mupen64plus-core/Makefile.common50
-rw-r--r--emulators/mupen64plus-core/pkg-descr2
-rw-r--r--emulators/mupen64plus-input-sdl/Makefile1
-rw-r--r--emulators/mupen64plus-plugins/Makefile1
-rw-r--r--emulators/mupen64plus-rsp-hle/Makefile1
-rw-r--r--emulators/mupen64plus-rsp-z64/Makefile1
-rw-r--r--emulators/mupen64plus-ui-console/Makefile1
-rw-r--r--emulators/mupen64plus-video-arachnoid/Makefile1
-rw-r--r--emulators/mupen64plus-video-glide64/Makefile1
-rw-r--r--emulators/mupen64plus-video-glide64mk2/Makefile2
-rw-r--r--emulators/mupen64plus-video-rice/Makefile1
-rw-r--r--emulators/mupen64plus/Makefile1
14 files changed, 26 insertions, 48 deletions
diff --git a/emulators/mupen64plus-audio-sdl/Makefile b/emulators/mupen64plus-audio-sdl/Makefile
index aba24505b280..6ff9827bf0ba 100644
--- a/emulators/mupen64plus-audio-sdl/Makefile
+++ b/emulators/mupen64plus-audio-sdl/Makefile
@@ -11,5 +11,4 @@ MASTERDIR= ${.CURDIR}/../mupen64plus-core
OPTIONS_DEFINE= #
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-core/Makefile b/emulators/mupen64plus-core/Makefile
index d96b64503afb..577682741fe5 100644
--- a/emulators/mupen64plus-core/Makefile
+++ b/emulators/mupen64plus-core/Makefile
@@ -13,7 +13,7 @@ PKGNAMESUFFIX?= -core
DIST_SUBDIR= ${PORTNAME}
MAINTAINER?= ports@FreeBSD.org
-COMMENT?= A fork of Mupen64 Nintendo 64 emulator
+COMMENT?= Fork of Mupen64 Nintendo 64 emulator
#PROJECTHOST= bsdistfiles
USES= gmake pkgconfig
@@ -27,9 +27,5 @@ OPTFLAGS= #
MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}" OPTFLAGS="${OPTFLAGS}"
OPTIONSFILE= ${PORT_DBDIR}/${PORTNAME}${PKGNAMESUFFIX}/options
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.include "${MASTERDIR}/Makefile.common"
-
-.include <bsd.port.post.mk>
+.include "${.CURDIR}/../mupen64plus-core/Makefile.common"
+.include <bsd.port.mk>
diff --git a/emulators/mupen64plus-core/Makefile.common b/emulators/mupen64plus-core/Makefile.common
index 5219140a912e..c4a199639560 100644
--- a/emulators/mupen64plus-core/Makefile.common
+++ b/emulators/mupen64plus-core/Makefile.common
@@ -16,10 +16,6 @@ LIB_DEPENDS+= libfreetype.so:${PORTSDIR}/print/freetype2 \
PLIST= ${WRKDIR}/pkg-plist
.endif
-.if ${PKGNAMESUFFIX} == "-ui-console"
-MAN6= mupen64plus.6
-.endif
-
.if ${PKGNAMESUFFIX} == "-video-rice"
LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
.endif
@@ -62,13 +58,17 @@ pre-install:
@${ECHO_CMD} "%%DATADIR%%/InputAutoCfg.ini" >> ${PLIST}
. endif
+. if ${PKGNAMESUFFIX} == "-ui-console"
+ @${ECHO_CMD} "man/man6/mupen64plus.6.gz" >> ${PLIST}
+. endif
+
. if ${PKGNAMESUFFIX} != "-ui-console"
@${ECHO_CMD} "lib/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}.so" >> ${PLIST}
@${ECHO_CMD} "@dirrmtry lib/${PORTNAME}" >> ${PLIST}
- @${ECHO_CMD} "@dirrmtry %%DATADIR%%" >> ${PLIST}
. else
@${ECHO_CMD} "bin/${PORTNAME}" >> ${PLIST}
. endif
+ @${ECHO_CMD} "@dirrmtry %%DATADIR%%" >> ${PLIST}
.else
post-patch:
@cd ${BUILD_WRKSRC} && ${REINPLACE_CMD} -e 's|gcc|${CC}|g' -e \
@@ -76,54 +76,48 @@ post-patch:
.endif
do-install:
+ @${MKDIR} ${STAGEDIR}${DATADIR}
.if ${PKGNAMESUFFIX} == "-core"
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/libmupen64plus.so.2.0.0 \
- ${PREFIX}/lib/libmupen64plus.so.2.0.0
+ ${STAGEDIR}${PREFIX}/lib/libmupen64plus.so.2.0.0
- @${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/* \
- ${DATADIR}
+ ${STAGEDIR}${DATADIR}
- @${MKDIR} ${PREFIX}/include/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/include/${PORTNAME}
${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/src/api/m64p_*.h \
- ${PREFIX}/include/${PORTNAME}
+ ${STAGEDIR}${PREFIX}/include/${PORTNAME}
-. if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/RELEASE \
- ${DOCSDIR}/RELEASE
-. endif
- ${LN} -sf ${PREFIX}/lib/libmupen64plus.so.2.0.0 ${PREFIX}/lib/libmupen64plus.so.2
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/RELEASE \
+ ${STAGEDIR}${DOCSDIR}/RELEASE
+ ${LN} -sf ${PREFIX}/lib/libmupen64plus.so.2.0.0 ${STAGEDIR}${PREFIX}/lib/libmupen64plus.so.2
.else
. if ${PKGNAMESUFFIX} == "-ui-console"
- ${INSTALL_MAN} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/doc/${MAN6} ${PREFIX}/man/man6/
+ ${INSTALL_MAN} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/doc/mupen64plus.6 ${STAGEDIR}${PREFIX}/man/man6/
. endif
. if ${PKGNAMESUFFIX} == "-video-rice"
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/RiceVideoLinux.ini ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/RiceVideoLinux.ini ${STAGEDIR}${DATADIR}
. endif
. if ${PKGNAMESUFFIX} == "-video-glide64"
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/data/Glide64.ini ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/data/Glide64.ini ${STAGEDIR}${DATADIR}
. endif
. if ${PKGNAMESUFFIX} == "-video-glide64mk2"
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/Glide64mk2.ini ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/Glide64mk2.ini ${STAGEDIR}${DATADIR}
. endif
. if ${PKGNAMESUFFIX} == "-input-sdl"
- @${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/InputAutoCfg.ini ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/source/${PORTNAME}${PKGNAMESUFFIX}/data/InputAutoCfg.ini ${STAGEDIR}${DATADIR}
. endif
. if ${PKGNAMESUFFIX} != "-ui-console"
- @${MKDIR} ${PREFIX}/lib/${PORTNAME}
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}.so ${PREFIX}/lib/${PORTNAME}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}.so ${STAGEDIR}${PREFIX}/lib/${PORTNAME}
. else
- ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
. endif
.endif
diff --git a/emulators/mupen64plus-core/pkg-descr b/emulators/mupen64plus-core/pkg-descr
index ecb4945ba5cf..5a7ff3875ef4 100644
--- a/emulators/mupen64plus-core/pkg-descr
+++ b/emulators/mupen64plus-core/pkg-descr
@@ -5,4 +5,4 @@ amd64 systems, and necessary plugins for audio, graphical rendering (RDP),
signal co-processor (RSP), and input. There are 3 OpenGL video plugins
included: glN64, RiceVideoLinux, and Glide64.
-WWW: http://code.google.com/p/mupen64plus/
+WWW: http://code.google.com/p/mupen64plus/
diff --git a/emulators/mupen64plus-input-sdl/Makefile b/emulators/mupen64plus-input-sdl/Makefile
index 961cb61aab0e..eaaed1624360 100644
--- a/emulators/mupen64plus-input-sdl/Makefile
+++ b/emulators/mupen64plus-input-sdl/Makefile
@@ -9,5 +9,4 @@ MASTERDIR= ${.CURDIR}/../mupen64plus-core
OPTION_DEFINE= #
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-plugins/Makefile b/emulators/mupen64plus-plugins/Makefile
index e57b307d062b..adc03826161e 100644
--- a/emulators/mupen64plus-plugins/Makefile
+++ b/emulators/mupen64plus-plugins/Makefile
@@ -20,7 +20,6 @@ RSP_Z64_DESC= z64 RSP plugin
OPTIONS_DEFAULT= VIDEO_ARACHNOID VIDEO_GLIDE64 VIDEO_Z64 RSP_Z64
-NO_STAGE= yes
.include <bsd.port.pre.mk>
# Graphics plugins
diff --git a/emulators/mupen64plus-rsp-hle/Makefile b/emulators/mupen64plus-rsp-hle/Makefile
index 03b1d9259ae5..2bd280e7330a 100644
--- a/emulators/mupen64plus-rsp-hle/Makefile
+++ b/emulators/mupen64plus-rsp-hle/Makefile
@@ -9,5 +9,4 @@ MASTERDIR= ${.CURDIR}/../mupen64plus-core
OPTIONS_DEFINE= #
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-rsp-z64/Makefile b/emulators/mupen64plus-rsp-z64/Makefile
index ced01d1480d9..9fd57a344d9a 100644
--- a/emulators/mupen64plus-rsp-z64/Makefile
+++ b/emulators/mupen64plus-rsp-z64/Makefile
@@ -22,5 +22,4 @@ EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-ui-console/Makefile b/emulators/mupen64plus-ui-console/Makefile
index 16d022368d62..510aea8b43cb 100644
--- a/emulators/mupen64plus-ui-console/Makefile
+++ b/emulators/mupen64plus-ui-console/Makefile
@@ -9,5 +9,4 @@ MASTERDIR= ${.CURDIR}/../mupen64plus-core
OPTIONS_DEFINE= #
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-video-arachnoid/Makefile b/emulators/mupen64plus-video-arachnoid/Makefile
index 4d8234d4d94d..77bd9b9acce5 100644
--- a/emulators/mupen64plus-video-arachnoid/Makefile
+++ b/emulators/mupen64plus-video-arachnoid/Makefile
@@ -22,5 +22,4 @@ EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-video-glide64/Makefile b/emulators/mupen64plus-video-glide64/Makefile
index 1db749c2195d..b407a817c9aa 100644
--- a/emulators/mupen64plus-video-glide64/Makefile
+++ b/emulators/mupen64plus-video-glide64/Makefile
@@ -23,5 +23,4 @@ EXTRACT_AFTER_ARGS= #
BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX}/projects/unix
WRKSRC= ${WRKDIR}
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-video-glide64mk2/Makefile b/emulators/mupen64plus-video-glide64mk2/Makefile
index 0e22d69cb67b..571d31e3b3a9 100644
--- a/emulators/mupen64plus-video-glide64mk2/Makefile
+++ b/emulators/mupen64plus-video-glide64mk2/Makefile
@@ -18,6 +18,4 @@ OPTIONS_DEFINE= #
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/${PORTNAME}
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
-
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-video-rice/Makefile b/emulators/mupen64plus-video-rice/Makefile
index 10a6083b7026..3c8480bc61ce 100644
--- a/emulators/mupen64plus-video-rice/Makefile
+++ b/emulators/mupen64plus-video-rice/Makefile
@@ -11,5 +11,4 @@ MASTERDIR= ${.CURDIR}/../mupen64plus-core
OPTIONS_DEFINE= #
-NO_STAGE= yes
.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus/Makefile b/emulators/mupen64plus/Makefile
index 7c5609eb56a6..0f6840f0da58 100644
--- a/emulators/mupen64plus/Makefile
+++ b/emulators/mupen64plus/Makefile
@@ -34,7 +34,6 @@ SUB_FILES= pkg-message
do-install: # empty
-NO_STAGE= yes
post-install:
@${CAT} ${PKGMESSAGE}