aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-WWW-Google-SiteMap/Makefile30
-rw-r--r--textproc/p5-WWW-Google-SiteMap/distinfo3
-rw-r--r--textproc/p5-WWW-Google-SiteMap/pkg-descr8
-rw-r--r--textproc/p5-WWW-Google-SiteMap/pkg-plist12
5 files changed, 54 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index ff773debe1ef..7226f31ecad1 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -486,6 +486,7 @@
SUBDIR += p5-URI-Find
SUBDIR += p5-Unicode-Normalize
SUBDIR += p5-WDDX
+ SUBDIR += p5-WWW-Google-SiteMap
SUBDIR += p5-WordNet-QueryData
SUBDIR += p5-WordNet-Similarity
SUBDIR += p5-XML-Atom
diff --git a/textproc/p5-WWW-Google-SiteMap/Makefile b/textproc/p5-WWW-Google-SiteMap/Makefile
new file mode 100644
index 000000000000..7526d27d19de
--- /dev/null
+++ b/textproc/p5-WWW-Google-SiteMap/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-WWW-Google-SiteMap
+# Date created: 2006-04-15
+# Whom: nork@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-Google-SiteMap
+PORTVERSION= 1.08
+CATEGORIES= textproc www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= WWW
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= Perl extension for managing Google SiteMaps
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig \
+ ${SITE_PERL}/URI/Escape.pm:${PORTSDIR}/net/p5-URI
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::Google::SiteMap.3 \
+ WWW::Google::SiteMap::Index.3 \
+ WWW::Google::SiteMap::Ping.3 \
+ WWW::Google::SiteMap::Robot.3 \
+ WWW::Google::SiteMap::URL.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-WWW-Google-SiteMap/distinfo b/textproc/p5-WWW-Google-SiteMap/distinfo
new file mode 100644
index 000000000000..eb70e4be6499
--- /dev/null
+++ b/textproc/p5-WWW-Google-SiteMap/distinfo
@@ -0,0 +1,3 @@
+MD5 (WWW-Google-SiteMap-1.08.tar.gz) = a2b3211169369df64a15717f53034f88
+SHA256 (WWW-Google-SiteMap-1.08.tar.gz) = 6f03d498dd5bba345ebd1cb4b0ddd05891dcfb724d6c29bf46ffd631e4328592
+SIZE (WWW-Google-SiteMap-1.08.tar.gz) = 30507
diff --git a/textproc/p5-WWW-Google-SiteMap/pkg-descr b/textproc/p5-WWW-Google-SiteMap/pkg-descr
new file mode 100644
index 000000000000..88ba9fc410a8
--- /dev/null
+++ b/textproc/p5-WWW-Google-SiteMap/pkg-descr
@@ -0,0 +1,8 @@
+The Sitemap Protocol allows you to inform search engine
+crawlers about URLs on your Web sites that are available
+for crawling. A Sitemap consists of a list of URLs and
+may also contain additional information about those URLs,
+such as when they were last modified, how frequently they
+change, etc.
+
+WWW: http://search.cpan.org/dist/WWW-Google-SiteMap/
diff --git a/textproc/p5-WWW-Google-SiteMap/pkg-plist b/textproc/p5-WWW-Google-SiteMap/pkg-plist
new file mode 100644
index 000000000000..6de98c7b5e91
--- /dev/null
+++ b/textproc/p5-WWW-Google-SiteMap/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/WWW/Google/SiteMap.pm
+%%SITE_PERL%%/WWW/Google/SiteMap/Index.pm
+%%SITE_PERL%%/WWW/Google/SiteMap/Ping.pm
+%%SITE_PERL%%/WWW/Google/SiteMap/Robot.pm
+%%SITE_PERL%%/WWW/Google/SiteMap/URL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/SiteMap/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google/SiteMap
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/Google
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrm %%SITE_PERL%%/WWW/Google/SiteMap
+@dirrm %%SITE_PERL%%/WWW/Google
+@dirrmtry %%SITE_PERL%%/WWW