aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--benchmarks/nuttcp/Makefile7
-rw-r--r--benchmarks/slowloris/Makefile2
-rw-r--r--chinese/qterm/Makefile4
-rw-r--r--java/classpath/Makefile5
-rw-r--r--java/icedtea-web/Makefile4
-rw-r--r--mail/assp/Makefile3
-rw-r--r--mail/bogofilter/Makefile3
-rw-r--r--mail/elmo-devel/Makefile4
-rw-r--r--mail/p5-Sendmail-Milter/Makefile3
-rw-r--r--mail/postfix/Makefile3
-rw-r--r--mail/postfix28/Makefile3
-rw-r--r--mail/sqlgrey/Makefile3
-rw-r--r--mail/zmailer/Makefile2
-rw-r--r--print/a2ps/Makefile2
-rw-r--r--print/foomatic-filters/Makefile2
-rw-r--r--print/lilypond/Makefile4
-rw-r--r--print/lyx/Makefile3
-rw-r--r--print/pdflib/Makefile4
-rw-r--r--print/tgif2tex/Makefile4
19 files changed, 36 insertions, 29 deletions
diff --git a/benchmarks/nuttcp/Makefile b/benchmarks/nuttcp/Makefile
index 0221bf9c7c36..0f819cd84511 100644
--- a/benchmarks/nuttcp/Makefile
+++ b/benchmarks/nuttcp/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= andrewclarkii@gmail.com
COMMENT= TCP/UDP network testing tool
USE_BZIP2= yes
-WANT_PERL= yes
MAKEFILE= /dev/null
ALL_TARGET= ${PORTNAME}
MAN8= ${PORTNAME}.8
@@ -27,15 +26,17 @@ OPTIONS_DEFAULT= NUTTSCP
NUTTSCP_DESC= Install script for copying files over nuttcp
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MNUTTSCP}
-USE_PERL5= yes
+USES+= perl5
PLIST_SUB+= NUTTSCP=""
.else
PLIST_SUB+= NUTTSCP="@comment "
.endif
+.include <bsd.port.pre.mk>
+
post-extract: .SILENT
${CP} ${DISTDIR}/${DIST_SUBDIR}/${NUTTSCPDISTFILE} ${WRKDIR}/nuttscp
diff --git a/benchmarks/slowloris/Makefile b/benchmarks/slowloris/Makefile
index 475005fd8f2c..7d10dbd4ad84 100644
--- a/benchmarks/slowloris/Makefile
+++ b/benchmarks/slowloris/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ftp://ftp.renatasystems.org/pub/FreeBSD/ports/distfiles/
MAINTAINER= alexey@renatasystems.org
COMMENT= The low bandwidth, yet greedy and poisonous HTTP client
-USE_PERL5= yes
+USES= perl5
NO_BUILD= yes
RUN_DEPENDS= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL \
diff --git a/chinese/qterm/Makefile b/chinese/qterm/Makefile
index 3650176d4fd9..5c7ef3833708 100644
--- a/chinese/qterm/Makefile
+++ b/chinese/qterm/Makefile
@@ -10,8 +10,8 @@ MAINTAINER= kaiwang27@gmail.com
COMMENT= BBS client for BSD/Linux
USE_BZIP2= yes
-USES= cmake
-USE_PERL5_BUILD= yes
+USES= cmake perl5
+USE_PERL5= build
USE_QT4= codecs-cn_run codecs-tw_run gui help-tools_build \
linguist_build moc_build network qt3support_build \
qmake_build rcc_build uic_build xml
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index f0fd24687da0..44d6dd3180e4 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -17,10 +17,9 @@ COMMENT= A GNU project to create a free Java class library
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= pkgconfig iconv
-USE_GMAKE= yes
+USES= gmake pkgconfig iconv perl5
USE_LDCONFIG= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_XORG= x11 ice xtst xaw xproto xext
WANT_GNOME= yes
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 4687b81bf698..27a4bab30742 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -21,9 +21,9 @@ USE_JAVA= yes
JAVA_OS= native
JAVA_VENDOR= openjdk
JAVA_VERSION= 1.6+
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_XORG= x11
-USES= gmake pkgconfig shebangfix
+USES= gmake pkgconfig shebangfix perl5
SHEBANG_FILES= javac.in jrunscript.in
WANT_GNOME= yes
diff --git a/mail/assp/Makefile b/mail/assp/Makefile
index 3460aa2658f4..744487cf2d3e 100644
--- a/mail/assp/Makefile
+++ b/mail/assp/Makefile
@@ -11,9 +11,10 @@ DISTNAME= ${PORTNAME:U}_${PORTVERSION}_Install
MAINTAINER= rnejdl@ringofsaturn.com
COMMENT= Anti-Spam SMTP Proxy
+USES= perl5
USE_ZIP= yes
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
MAN8= assp.8 assplog.8
diff --git a/mail/bogofilter/Makefile b/mail/bogofilter/Makefile
index 32c5841a7b4e..9456a630ab88 100644
--- a/mail/bogofilter/Makefile
+++ b/mail/bogofilter/Makefile
@@ -22,8 +22,9 @@ UNICODE_DESC= Normalize tokens to Unicode (UTF-8) (recommended)
CONFLICTS_INSTALL?= bogofilter-sqlite-[0-9]* bogofilter-qdbm-[0-9]* bogofilter-tc-[0-9]* [a-z][a-z]-bogofilter-[0-9]*
+USES= perl5
+USE_PERL5= run
USE_BZIP2= yes
-USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
.include <bsd.port.options.mk>
diff --git a/mail/elmo-devel/Makefile b/mail/elmo-devel/Makefile
index 623c101050b6..d2a5e56f7c0f 100644
--- a/mail/elmo-devel/Makefile
+++ b/mail/elmo-devel/Makefile
@@ -14,9 +14,9 @@ COMMENT= Receive, filter, read, compose, and send mail at the text console
CONFLICTS= elmo-[0-9]*
GNU_CONFIGURE= yes
-USES= iconv
+USES= iconv perl5
USE_OPENSSL= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/mail/p5-Sendmail-Milter/Makefile b/mail/p5-Sendmail-Milter/Makefile
index 15f2e3c15e0d..d51d727386a2 100644
--- a/mail/p5-Sendmail-Milter/Makefile
+++ b/mail/p5-Sendmail-Milter/Makefile
@@ -14,7 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= marc@pilgerer.org
COMMENT= Module to write mail filters in Perl using sendmail's mail filter API
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Sendmail::Milter.3
diff --git a/mail/postfix/Makefile b/mail/postfix/Makefile
index 4675c3485b4e..12de70c96379 100644
--- a/mail/postfix/Makefile
+++ b/mail/postfix/Makefile
@@ -28,8 +28,9 @@ CONFLICTS= courier-0.* postfix-1.* postfix-2.[0-9].* postfix-base-2.[0-9].* \
USERS= postfix
GROUPS= mail maildrop postfix
+USES= perl5
USE_SUBMAKE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
OPTIONS_DEFINE= PCRE SASL2 TLS BDB MYSQL PGSQL SQLITE OPENLDAP LDAP_SASL \
diff --git a/mail/postfix28/Makefile b/mail/postfix28/Makefile
index 13a485fc750d..b44126e55895 100644
--- a/mail/postfix28/Makefile
+++ b/mail/postfix28/Makefile
@@ -31,8 +31,9 @@ NO_LATEST_LINK= yes
USERS= postfix
GROUPS= mail maildrop postfix
+USES= perl5
+USE_PERL5= build
USE_SUBMAKE= yes
-USE_PERL5_BUILD=yes
SCRIPTS_ENV+= POSTFIX_DEFAULT_MTA="${POSTFIX_DEFAULT_MTA}"
OPTIONS_DEFINE= PCRE SASL2 TLS BDB MYSQL PGSQL SQLITE OPENLDAP \
diff --git a/mail/sqlgrey/Makefile b/mail/sqlgrey/Makefile
index e0e3d1cd7f7e..ee411f9874cc 100644
--- a/mail/sqlgrey/Makefile
+++ b/mail/sqlgrey/Makefile
@@ -13,7 +13,8 @@ RUN_DEPENDS= p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
p5-IO-Multiplex>=0:${PORTSDIR}/devel/p5-IO-Multiplex \
p5-Pod-Parser>=0:${PORTSDIR}/textproc/p5-Pod-Parser
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
USE_RC_SUBR= sqlgrey
NO_BUILD= yes
diff --git a/mail/zmailer/Makefile b/mail/zmailer/Makefile
index cbb8a968f7d1..259e1a501a53 100644
--- a/mail/zmailer/Makefile
+++ b/mail/zmailer/Makefile
@@ -15,8 +15,8 @@ CONFLICTS= courier-0.* postfix-1.* postfix-2.* sendmail-8.* sendmail-*-8.* smail
OPTIONS_DEFINE= SSL
OPTIONS_DEFAULT=SSL
+USES= perl5
GNU_CONFIGURE= yes
-USE_PERL5= yes
MAKE_JOBS_UNSAFE=
.include <bsd.port.options.mk>
diff --git a/print/a2ps/Makefile b/print/a2ps/Makefile
index 2607e471fe1c..69f2f74808b6 100644
--- a/print/a2ps/Makefile
+++ b/print/a2ps/Makefile
@@ -16,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= paper:${PORTSDIR}/print/libpaper
-USE_PERL5= yes
+USES= perl5
USE_CSTD= gnu89
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index 3a3bc3b89e38..61d522e86495 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -13,8 +13,8 @@ COMMENT= Foomatic wrapper scripts
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+USES= perl5
USE_AUTOTOOLS= autoheader
-USE_PERL5= yes
USE_GHOSTSCRIPT=yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= ac_cv_path_A2PS=${LOCALBASE}/bin/a2ps \
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index 65b7862955c0..90d7ddd7cb03 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -39,11 +39,11 @@ INFO= lilypond-notation \
music-glossary \
internals
-USES= bison:build gettext gmake pkgconfig
+USES= bison:build gettext gmake pkgconfig perl5
USE_GHOSTSCRIPT=9
USE_TEX= latex
USE_PYTHON= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
USE_GNOME= pango
USE_GCC= any
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index ebeac82c0563..5435a5ed6c56 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -23,12 +23,11 @@ CONFLICTS= lyx-1.[0-9]*
MAJOR_VERSION= 2.0
MINOR_VERSION= 6
-USES= gmake iconv pkgconfig
+USES= gmake iconv pkgconfig perl5
USE_XZ= yes
USE_QT4= corelib gui moc_build uic_build rcc_build
USE_GNOME= desktopfileutils
USE_PYTHON= -2.7
-USE_PERL5= yes
GNU_CONFIGURE= yes
CPPFLAGS+= ${PTHREAD_CFLAGS}
LDFLAGS+= ${PTHREAD_LIBS}
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index 2d468186ae8e..9ebbbed6225c 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -21,8 +21,8 @@ OPTIONS_DEFINE= PERL JAVA
PERL_DESC= Build perl bindings
JAVA_DESC= Build Java bindings
+USES= gmake
USE_LDCONFIG= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-py=no --with-ruby=no --with-tcl=no
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+=--enable-64bit
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
PLIST_SUB= PERL=""
CONFIGURE_ARGS+=--with-perl=${PERL}
.else
diff --git a/print/tgif2tex/Makefile b/print/tgif2tex/Makefile
index 547253e34e9a..d822534bc88c 100644
--- a/print/tgif2tex/Makefile
+++ b/print/tgif2tex/Makefile
@@ -12,7 +12,6 @@ COMMENT= Converting texts in figure by tgif to LaTeX commands
LICENSE= GPLv2
-USE_PERL5_RUN= yes
PLIST_FILES= bin/tgif2tex
PORTDOCS= how-to-use.dvi how-to-use.ps how-to-use.tex \
example.obj example.tex \
@@ -26,6 +25,9 @@ PORTDOCS= how-to-use.dvi how-to-use.ps how-to-use.tex \
OPTIONS_DEFINE= DOCS
+USES= perl5
+USE_PERL5= run
+
.include <bsd.port.options.mk>
do-build: