aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/kimagemapeditor/Makefile4
-rw-r--r--math/fung-calc/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/graphics/kimagemapeditor/Makefile b/graphics/kimagemapeditor/Makefile
index 29232fa8a8a6..1eff2b4338a0 100644
--- a/graphics/kimagemapeditor/Makefile
+++ b/graphics/kimagemapeditor/Makefile
@@ -16,10 +16,14 @@ USE_BZIP2= yes
USE_KDELIBS_VER= 3
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-pedantic ||g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/math/fung-calc/Makefile b/math/fung-calc/Makefile
index 2f474736dc37..09cf5345385a 100644
--- a/math/fung-calc/Makefile
+++ b/math/fung-calc/Makefile
@@ -17,10 +17,14 @@ USE_KDELIBS_VER= 3
USE_MESA= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET=
CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+pre-configure:
+ ${REINPLACE_CMD} -e 's|-pedantic ||g' ${WRKSRC}/configure
+
.include <bsd.port.mk>