aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/keychain/Makefile30
-rw-r--r--security/keychain/distinfo1
-rw-r--r--security/keychain/files/patch-keychain29
-rw-r--r--security/keychain/pkg-comment1
-rw-r--r--security/keychain/pkg-descr9
-rw-r--r--security/keychain/pkg-plist1
7 files changed, 72 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1cf198e92e09..a95f1c2c30a1 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -65,6 +65,7 @@
SUBDIR += isakmpd
SUBDIR += its4
SUBDIR += john
+ SUBDIR += keychain
SUBDIR += keynote
SUBDIR += keyprint
SUBDIR += kmap
diff --git a/security/keychain/Makefile b/security/keychain/Makefile
new file mode 100644
index 000000000000..3ba217084fe5
--- /dev/null
+++ b/security/keychain/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: keychain
+# Date created: 10 September 2001
+# Whom: Johann Visagie <wjv@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= keychain
+PORTVERSION= 1.2
+CATEGORIES= security
+MASTER_SITES= http://www.ibiblio.org/gentoo/distfiles/
+
+MAINTAINER= wjv@FreeBSD.org
+
+RUN_DEPENDS= pidof:${PORTSDIR}/sysutils/psmisc
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 400016
+RUN_DEPENDS= ssh-agent:${PORTSDIR}/security/openssh
+.endif
+
+do-install:
+ @ ${MKDIR} ${PREFIX}/bin
+ @ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.include <bsd.port.post.mk>
diff --git a/security/keychain/distinfo b/security/keychain/distinfo
new file mode 100644
index 000000000000..7eae24e2c984
--- /dev/null
+++ b/security/keychain/distinfo
@@ -0,0 +1 @@
+MD5 (keychain-1.2.tar.bz2) = 506755c48f886d3de6a0498125473680
diff --git a/security/keychain/files/patch-keychain b/security/keychain/files/patch-keychain
new file mode 100644
index 000000000000..dfba9cc120f0
--- /dev/null
+++ b/security/keychain/files/patch-keychain
@@ -0,0 +1,29 @@
+--- keychain.orig Mon Sep 10 06:42:47 2001
++++ keychain Mon Sep 10 08:54:24 2001
+@@ -59,7 +59,7 @@
+
+ EOHELP
+ echo -e " ${CYAN}keychain ~/.ssh/id_rsa ~/.ssh/id_dsa"
+-echo -e " source ~/.ssh-agent > /dev/null${OFF}"
++echo -e " . ~/.ssh-agent > /dev/null${OFF}"
+ echo -e " # the > /dev/null eliminates the redundant agent PID output"
+ echo
+ cat <<EOHELP
+@@ -109,7 +109,7 @@
+ chmod 0600 ~/.ssh-agent
+ SSH_AGENT_PID="NULL"
+ else
+- source ~/.ssh-agent > /dev/null
++ . ~/.ssh-agent > /dev/null
+ fi
+
+ match="no"
+@@ -130,7 +130,7 @@
+ chmod 0600 ~/.ssh-agent
+ echo -e " ${GREEN}*${OFF} starting new ssh-agent"
+ nohup ssh-agent > ~/.ssh-agent
+- source ~/.ssh-agent > /dev/null
++ . ~/.ssh-agent > /dev/null
+ fi
+
+ if [ -n "`echo $* | grep '\-\-clear'`" ]
diff --git a/security/keychain/pkg-comment b/security/keychain/pkg-comment
new file mode 100644
index 000000000000..cc163180c5f7
--- /dev/null
+++ b/security/keychain/pkg-comment
@@ -0,0 +1 @@
+A user-friendly front-end to ssh-agent(1)
diff --git a/security/keychain/pkg-descr b/security/keychain/pkg-descr
new file mode 100644
index 000000000000..9c52d3e643c3
--- /dev/null
+++ b/security/keychain/pkg-descr
@@ -0,0 +1,9 @@
+Keychain is a shell script which acts as user-friendly front-end to
+ssh-agent(1), allowing you to have one long-running ssh-agent process per
+system rather than per login session.
+
+Please study the documentation on the keychain website carefully since
+incorrect usage of this script may have certain security implementations.
+
+Author: Daniel Robbins <drobbins@gentoo.org>
+WWW: http://www.gentoo.org/projects/keychain.html
diff --git a/security/keychain/pkg-plist b/security/keychain/pkg-plist
new file mode 100644
index 000000000000..a03342d6e8b7
--- /dev/null
+++ b/security/keychain/pkg-plist
@@ -0,0 +1 @@
+bin/keychain