aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dns/p5-Net-DNS-Async/Makefile2
-rw-r--r--finance/gnucash/Makefile6
-rw-r--r--graphics/inkscape/Makefile2
-rw-r--r--lang/vala/Makefile4
-rw-r--r--mail/postfix-postfwd/Makefile8
-rw-r--r--net/ekiga3/Makefile2
-rw-r--r--security/p5-Filter-Crypto/Makefile2
-rw-r--r--sysutils/system-tools-backends/Makefile4
-rw-r--r--textproc/intltool/Makefile4
-rw-r--r--www/p5-WWW-OpenSearch/Makefile2
10 files changed, 18 insertions, 18 deletions
diff --git a/dns/p5-Net-DNS-Async/Makefile b/dns/p5-Net-DNS-Async/Makefile
index 39d39545fdf9..cb7047de7a1a 100644
--- a/dns/p5-Net-DNS-Async/Makefile
+++ b/dns/p5-Net-DNS-Async/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sahil@FreeBSD.org
COMMENT= Asynchronous DNS helper for high volume applications
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS
+BUILD_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/finance/gnucash/Makefile b/finance/gnucash/Makefile
index 724c7a71d6cd..f68269648da9 100644
--- a/finance/gnucash/Makefile
+++ b/finance/gnucash/Makefile
@@ -24,9 +24,9 @@ LIB_DEPENDS= gnome-keyring.0:${PORTSDIR}/security/libgnome-keyring \
goffice-0.8.8:${PORTSDIR}/devel/goffice
RUN_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile \
${LOCALBASE}/share/guile/1.8/slibcat:${PORTSDIR}/lang/slib-guile \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/Finance/Quote.pm:${PORTSDIR}/finance/p5-Finance-Quote
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
+ p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-Finance-Quote>=0:${PORTSDIR}/finance/p5-Finance-Quote
OPTIONS_DEFINE= AQBANKING OFX DATABASE LOCALE_TAX WEBKIT PYTHON
diff --git a/graphics/inkscape/Makefile b/graphics/inkscape/Makefile
index 0c604b28d3a6..b5e55f8c3cb2 100644
--- a/graphics/inkscape/Makefile
+++ b/graphics/inkscape/Makefile
@@ -25,7 +25,7 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
wpg-0.2:${PORTSDIR}/graphics/libwpg \
png15:${PORTSDIR}/graphics/png \
Magick++.5:${PORTSDIR}/graphics/ImageMagick
-RUN_DEPENDS= ${SITE_PERL}/XML/XQL.pm:${PORTSDIR}/textproc/p5-XML-XQL
+RUN_DEPENDS= p5-XML-XQL>=0:${PORTSDIR}/textproc/p5-XML-XQL
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/lang/vala/Makefile b/lang/vala/Makefile
index f899439a5fbb..d9f819fb55bf 100644
--- a/lang/vala/Makefile
+++ b/lang/vala/Makefile
@@ -34,8 +34,8 @@ PLIST_SUB= VERSION=0.12
.if defined(VALA_SLAVE)
LIB_DEPENDS+= vala-0.12.0:${PORTSDIR}/lang/vala
CONFIGURE_ARGS+=--enable-vapigen
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML
+BUILD_DEPENDS+= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS+= p5-XML-LibXML>=0:${PORTSDIR}/textproc/p5-XML-LibXML
MAN1= vala-gen-introspect.1 vapigen.1
.else
CONFIGURE_ARGS+=--disable-vapigen
diff --git a/mail/postfix-postfwd/Makefile b/mail/postfix-postfwd/Makefile
index 8dd844074a2f..23edc22dc0be 100644
--- a/mail/postfix-postfwd/Makefile
+++ b/mail/postfix-postfwd/Makefile
@@ -17,10 +17,10 @@ COMMENT= A postfix firewall policy daemon
LICENSE= BSD
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
- ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
- ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
- ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Net-Server>=0:${PORTSDIR}/net/p5-Net-Server \
+ p5-Storable>=0:${PORTSDIR}/devel/p5-Storable \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
PORTDOCS= *
PORTEXAMPLES= request.sample postfwd.plugins.sample
diff --git a/net/ekiga3/Makefile b/net/ekiga3/Makefile
index b4ba8d382106..7b201f5230b3 100644
--- a/net/ekiga3/Makefile
+++ b/net/ekiga3/Makefile
@@ -18,7 +18,7 @@ COMMENT= VoIP and video conferencing application
LIB_DEPENDS= sigc-2:${PORTSDIR}/devel/libsigc++20 \
opal-3.6.[6-9]:${PORTSDIR}/net/opal3
BUILD_DEPENDS= intltoolize:${PORTSDIR}/textproc/intltool \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
${LOCALBASE}/bin/scrollkeeper-config:${PORTSDIR}/textproc/rarian
CONFLICTS= ekiga-2.*
diff --git a/security/p5-Filter-Crypto/Makefile b/security/p5-Filter-Crypto/Makefile
index 6385ebb04186..c21622671549 100644
--- a/security/p5-Filter-Crypto/Makefile
+++ b/security/p5-Filter-Crypto/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sahil@FreeBSD.org
COMMENT= Create runnable Perl files encrypted with OpenSSL libcrypto
-BUILD_DEPENDS= ${SITE_PERL}/PAR/Filter.pm:${PORTSDIR}/devel/p5-PAR-Packer
+BUILD_DEPENDS= p5-PAR-Packer>=0:${PORTSDIR}/devel/p5-PAR-Packer
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/sysutils/system-tools-backends/Makefile b/sysutils/system-tools-backends/Makefile
index 1f88119f465e..64ffda743e4d 100644
--- a/sysutils/system-tools-backends/Makefile
+++ b/sysutils/system-tools-backends/Makefile
@@ -16,10 +16,10 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Backend system admin scripts for gnome-system-tools
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DBus.pm:${PORTSDIR}/devel/p5-Net-DBus
+BUILD_DEPENDS= p5-Net-DBus>=0:${PORTSDIR}/devel/p5-Net-DBus
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
polkit-gobject-1.0:${PORTSDIR}/sysutils/polkit
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Net/DBus.pm:${PORTSDIR}/devel/p5-Net-DBus
+RUN_DEPENDS= p5-Net-DBus>=0:${PORTSDIR}/devel/p5-Net-DBus
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/textproc/intltool/Makefile b/textproc/intltool/Makefile
index afeef5808270..359828e335fa 100644
--- a/textproc/intltool/Makefile
+++ b/textproc/intltool/Makefile
@@ -14,8 +14,8 @@ DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Tools to internationalize various kinds of data files
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser
+BUILD_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
+RUN_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
USE_GMAKE= yes
USE_ICONV= yes
diff --git a/www/p5-WWW-OpenSearch/Makefile b/www/p5-WWW-OpenSearch/Makefile
index d9497928e55b..58702a3d42b6 100644
--- a/www/p5-WWW-OpenSearch/Makefile
+++ b/www/p5-WWW-OpenSearch/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= sahil@FreeBSD.org
COMMENT= Search A9 OpenSearch compatible engines
-RUN_DEPENDS= ${SITE_PERL}/URI/Template.pm:${PORTSDIR}/net/p5-URI-Template \
+RUN_DEPENDS= p5-URI-Template>=0:${PORTSDIR}/net/p5-URI-Template \
p5-URI>=0:${PORTSDIR}/net/p5-URI \
p5-Data-Page>=2.00:${PORTSDIR}/databases/p5-Data-Page \
p5-XML-Feed>=0.08:${PORTSDIR}/textproc/p5-XML-Feed \