aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/Makefile1
-rw-r--r--games/gish-demo/Makefile36
-rw-r--r--games/gish-demo/distinfo3
-rw-r--r--games/gish-demo/files/rungish.sh.in12
-rw-r--r--games/gish-demo/pkg-descr13
-rw-r--r--games/gish-demo/pkg-plist296
6 files changed, 361 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 92ee856a8687..4ae60b333891 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -240,6 +240,7 @@
SUBDIR += ggz-sdl-games
SUBDIR += ggz-txt-client
SUBDIR += gillo
+ SUBDIR += gish-demo
SUBDIR += gl-117
SUBDIR += glasteroids
SUBDIR += glaxium
diff --git a/games/gish-demo/Makefile b/games/gish-demo/Makefile
new file mode 100644
index 000000000000..b459bfd02726
--- /dev/null
+++ b/games/gish-demo/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: gish-demo
+# Date created: 04 September 2006
+# Whom: Jona Joachim <walkingshadow@grummel.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gish-demo
+PORTVERSION= 1.2
+CATEGORIES= games linux
+MASTER_SITES= http://s159260531.onlinehome.us/demos/
+DISTNAME= gishdemo
+
+MAINTAINER= walkingshadow@grummel.net
+COMMENT= A platform game with a gelatinous 12-pound ball of tar named Gish (Demo version)
+
+RUN_DEPENDS= ${LINUXBASE}/usr/lib/libvorbis.so.0:${PORTSDIR}/audio/linux-libvorbis \
+ ${LINUXBASE}/usr/lib/libopenal.so.0:${PORTSDIR}/audio/linux-openal \
+ ${LINUXBASE}/usr/lib/libalut.so.0:${PORTSDIR}/audio/linux-freealut \
+ ${LINUXBASE}/usr/X11R6/lib/libGL.so.1.2:${PORTSDIR}/graphics/linux_dri
+
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= is an i386 Linux binary
+USE_LINUX= yes
+NO_BUILD= yes
+DATADIR= ${PREFIX}/lib/${PORTNAME}
+SUB_FILES= rungish.sh
+SUB_LIST= LINUXBASE=${LINUXBASE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/* ${DATADIR}
+ ${BRANDELF} -t Linux ${DATADIR}/gish
+ ${INSTALL_SCRIPT} ${WRKDIR}/rungish.sh ${PREFIX}/bin/gish
+
+.include <bsd.port.mk>
diff --git a/games/gish-demo/distinfo b/games/gish-demo/distinfo
new file mode 100644
index 000000000000..cfde8e5ea76e
--- /dev/null
+++ b/games/gish-demo/distinfo
@@ -0,0 +1,3 @@
+MD5 (gishdemo.tar.gz) = 4b8dc9c5fb61fcf11151e7a79c3961d3
+SHA256 (gishdemo.tar.gz) = f3c1db89733457b51e6e569a6d5542c03c33f9b3b36f1719d734d1cbaf3dcdc7
+SIZE (gishdemo.tar.gz) = 13564186
diff --git a/games/gish-demo/files/rungish.sh.in b/games/gish-demo/files/rungish.sh.in
new file mode 100644
index 000000000000..7b5702378bab
--- /dev/null
+++ b/games/gish-demo/files/rungish.sh.in
@@ -0,0 +1,12 @@
+#!/bin/sh
+
+LD_PRELOAD_ALUT=%%LINUXBASE%%/usr/lib/libalut.so.0
+
+if [ -n "$LD_PRELOAD" ]; then
+ export LD_PRELOAD="$LD_PRELOAD_ALUT:$LD_PRELOAD"
+else
+ export LD_PRELOAD="$LD_PRELOAD_ALUT"
+fi
+
+cd %%DATADIR%% || exit 1
+exec ./gish "$@"
diff --git a/games/gish-demo/pkg-descr b/games/gish-demo/pkg-descr
new file mode 100644
index 000000000000..ae5f14002a96
--- /dev/null
+++ b/games/gish-demo/pkg-descr
@@ -0,0 +1,13 @@
+"Gish isn't your average hero, in fact he's not your average
+anything... see Gish is a ball of tar. A Sunday stroll with his
+lady friend Brea goes awry when a shadowy figure emerges from an
+open man hole and pulls Brea into the ground below. Following
+Brea's calls for help Gish suddenly finds himself in the
+subterranean sewers of Dross, a long forgotten city filled with
+twisting corridors, evil traps and some of the most demented
+creatures imaginable."
+
+This is the demo version of the game. Visit the website to buy
+the full version.
+
+WWW: http://www.chroniclogic.com/index.htm?gish.htm
diff --git a/games/gish-demo/pkg-plist b/games/gish-demo/pkg-plist
new file mode 100644
index 000000000000..240cdec545d9
--- /dev/null
+++ b/games/gish-demo/pkg-plist
@@ -0,0 +1,296 @@
+bin/gish
+%%DATADIR%%/animation/bibatk01.tga
+%%DATADIR%%/animation/bibatk02.tga
+%%DATADIR%%/animation/bibatk03.tga
+%%DATADIR%%/animation/bibatk04.tga
+%%DATADIR%%/animation/bibatk05.tga
+%%DATADIR%%/animation/bibatk06.tga
+%%DATADIR%%/animation/bibatk07.tga
+%%DATADIR%%/animation/bibatk08.tga
+%%DATADIR%%/animation/bibatk09.tga
+%%DATADIR%%/animation/bibsta01.tga
+%%DATADIR%%/animation/bibsta02.tga
+%%DATADIR%%/animation/bibsta03.tga
+%%DATADIR%%/animation/bibsta04.tga
+%%DATADIR%%/animation/bibsta05.tga
+%%DATADIR%%/animation/bibsta06.tga
+%%DATADIR%%/animation/bibwlk01.tga
+%%DATADIR%%/animation/bibwlk02.tga
+%%DATADIR%%/animation/bibwlk03.tga
+%%DATADIR%%/animation/bibwlk04.tga
+%%DATADIR%%/animation/bibwlk05.tga
+%%DATADIR%%/animation/bibwlk06.tga
+%%DATADIR%%/animation/bibwlk07.tga
+%%DATADIR%%/animation/bibwlk08.tga
+%%DATADIR%%/animation/bibwlk09.tga
+%%DATADIR%%/animation/frkatk01.tga
+%%DATADIR%%/animation/frkatk02.tga
+%%DATADIR%%/animation/frkatk03.tga
+%%DATADIR%%/animation/frkatk04.tga
+%%DATADIR%%/animation/frkatk05.tga
+%%DATADIR%%/animation/frkatk06.tga
+%%DATADIR%%/animation/frkatk07.tga
+%%DATADIR%%/animation/frkatk08.tga
+%%DATADIR%%/animation/frkatk09.tga
+%%DATADIR%%/animation/frkdie01.tga
+%%DATADIR%%/animation/frkdie02.tga
+%%DATADIR%%/animation/frkdie03.tga
+%%DATADIR%%/animation/frkdie04.tga
+%%DATADIR%%/animation/frkdie05.tga
+%%DATADIR%%/animation/frkdie06.tga
+%%DATADIR%%/animation/frkdie07.tga
+%%DATADIR%%/animation/frkdie08.tga
+%%DATADIR%%/animation/frkdie09.tga
+%%DATADIR%%/animation/frkhed01.tga
+%%DATADIR%%/animation/frkhed02.tga
+%%DATADIR%%/animation/frkhed03.tga
+%%DATADIR%%/animation/frkhed04.tga
+%%DATADIR%%/animation/frkhed05.tga
+%%DATADIR%%/animation/frkhed06.tga
+%%DATADIR%%/animation/frksta01.tga
+%%DATADIR%%/animation/frksta02.tga
+%%DATADIR%%/animation/frksta03.tga
+%%DATADIR%%/animation/frksta04.tga
+%%DATADIR%%/animation/frksta05.tga
+%%DATADIR%%/animation/frksta06.tga
+%%DATADIR%%/animation/frkwlk01.tga
+%%DATADIR%%/animation/frkwlk02.tga
+%%DATADIR%%/animation/frkwlk03.tga
+%%DATADIR%%/animation/frkwlk04.tga
+%%DATADIR%%/animation/frkwlk05.tga
+%%DATADIR%%/animation/frkwlk06.tga
+%%DATADIR%%/animation/frkwlk07.tga
+%%DATADIR%%/animation/frkwlk08.tga
+%%DATADIR%%/animation/frkwlk09.tga
+%%DATADIR%%/animation/frkwlk10.tga
+%%DATADIR%%/animation/nibatk01.tga
+%%DATADIR%%/animation/nibatk02.tga
+%%DATADIR%%/animation/nibatk03.tga
+%%DATADIR%%/animation/nibatk04.tga
+%%DATADIR%%/animation/nibatk05.tga
+%%DATADIR%%/animation/nibatk06.tga
+%%DATADIR%%/animation/nibatk07.tga
+%%DATADIR%%/animation/nibatk08.tga
+%%DATADIR%%/animation/nibatk09.tga
+%%DATADIR%%/animation/nibdie01.tga
+%%DATADIR%%/animation/nibdie02.tga
+%%DATADIR%%/animation/nibdie03.tga
+%%DATADIR%%/animation/nibdie04.tga
+%%DATADIR%%/animation/nibdie05.tga
+%%DATADIR%%/animation/nibdie06.tga
+%%DATADIR%%/animation/nibdie07.tga
+%%DATADIR%%/animation/nibdie08.tga
+%%DATADIR%%/animation/nibdie09.tga
+%%DATADIR%%/animation/nibsta01.tga
+%%DATADIR%%/animation/nibsta02.tga
+%%DATADIR%%/animation/nibsta03.tga
+%%DATADIR%%/animation/nibsta04.tga
+%%DATADIR%%/animation/nibsta05.tga
+%%DATADIR%%/animation/nibsta06.tga
+%%DATADIR%%/animation/nibwlk01.tga
+%%DATADIR%%/animation/nibwlk02.tga
+%%DATADIR%%/animation/nibwlk03.tga
+%%DATADIR%%/animation/nibwlk04.tga
+%%DATADIR%%/animation/nibwlk05.tga
+%%DATADIR%%/animation/nibwlk06.tga
+%%DATADIR%%/animation/nibwlk07.tga
+%%DATADIR%%/animation/nibwlk08.tga
+%%DATADIR%%/animation/nibwlk09.tga
+%%DATADIR%%/gish
+%%DATADIR%%/gish.bmp
+%%DATADIR%%/gishmanual.html
+%%DATADIR%%/leveldemo/bathhouse.lvl
+%%DATADIR%%/leveldemo/cave2.lvl
+%%DATADIR%%/leveldemo/co06.lvl
+%%DATADIR%%/leveldemo/co10.lvl
+%%DATADIR%%/leveldemo/egypt1.lvl
+%%DATADIR%%/leveldemo/playroom.lvl
+%%DATADIR%%/leveldemo/sewer1.lvl
+%%DATADIR%%/leveldemo/sewer7.lvl
+%%DATADIR%%/manual3.swf
+%%DATADIR%%/music/intro.ogg
+%%DATADIR%%/music/sewer.ogg
+%%DATADIR%%/replay/demo01.gre
+%%DATADIR%%/replay/demo02.gre
+%%DATADIR%%/replay/demo03.gre
+%%DATADIR%%/replay/demo04.gre
+%%DATADIR%%/sound/amber.wav
+%%DATADIR%%/sound/blockbreak.wav
+%%DATADIR%%/sound/bobattack.wav
+%%DATADIR%%/sound/chainbreak.wav
+%%DATADIR%%/sound/fleshhit.wav
+%%DATADIR%%/sound/gishhit.wav
+%%DATADIR%%/sound/gishhurt.wav
+%%DATADIR%%/sound/lava.wav
+%%DATADIR%%/sound/necksnap.wav
+%%DATADIR%%/sound/nibattack.wav
+%%DATADIR%%/sound/points.wav
+%%DATADIR%%/sound/rockfriction.wav
+%%DATADIR%%/sound/rockhit.wav
+%%DATADIR%%/sound/ropebreak.wav
+%%DATADIR%%/sound/secrets1.wav
+%%DATADIR%%/sound/secrets2.wav
+%%DATADIR%%/sound/splash.wav
+%%DATADIR%%/sound/squish.wav
+%%DATADIR%%/sound/switch.wav
+%%DATADIR%%/sound/tarball.wav
+%%DATADIR%%/sound/visattack.wav
+%%DATADIR%%/texture/0.tga
+%%DATADIR%%/texture/1.tga
+%%DATADIR%%/texture/10.tga
+%%DATADIR%%/texture/11.tga
+%%DATADIR%%/texture/12.tga
+%%DATADIR%%/texture/2.tga
+%%DATADIR%%/texture/3.tga
+%%DATADIR%%/texture/4.tga
+%%DATADIR%%/texture/5.tga
+%%DATADIR%%/texture/6.tga
+%%DATADIR%%/texture/7.tga
+%%DATADIR%%/texture/8.tga
+%%DATADIR%%/texture/9.tga
+%%DATADIR%%/texture/amber.tga
+%%DATADIR%%/texture/amber1.tga
+%%DATADIR%%/texture/amber2.tga
+%%DATADIR%%/texture/amber3.tga
+%%DATADIR%%/texture/bastalk.tga
+%%DATADIR%%/texture/blank.tga
+%%DATADIR%%/texture/blood.tga
+%%DATADIR%%/texture/border.tga
+%%DATADIR%%/texture/breatalk.tga
+%%DATADIR%%/texture/bubble.tga
+%%DATADIR%%/texture/buynow.tga
+%%DATADIR%%/texture/cage1.tga
+%%DATADIR%%/texture/cage2.tga
+%%DATADIR%%/texture/cage3.tga
+%%DATADIR%%/texture/cage4.tga
+%%DATADIR%%/texture/cave.tga
+%%DATADIR%%/texture/chain.tga
+%%DATADIR%%/texture/chronic.tga
+%%DATADIR%%/texture/complete.tga
+%%DATADIR%%/texture/demolevel.tga
+%%DATADIR%%/texture/dust.tga
+%%DATADIR%%/texture/egypt.tga
+%%DATADIR%%/texture/eyes.tga
+%%DATADIR%%/texture/face.tga
+%%DATADIR%%/texture/faceb1.tga
+%%DATADIR%%/texture/faceb2.tga
+%%DATADIR%%/texture/faceh1.tga
+%%DATADIR%%/texture/faceh2.tga
+%%DATADIR%%/texture/faceh3.tga
+%%DATADIR%%/texture/faceh4.tga
+%%DATADIR%%/texture/facem1.tga
+%%DATADIR%%/texture/facem2.tga
+%%DATADIR%%/texture/facem3.tga
+%%DATADIR%%/texture/facem4.tga
+%%DATADIR%%/texture/fight.tga
+%%DATADIR%%/texture/font00.tga
+%%DATADIR%%/texture/font01.tga
+%%DATADIR%%/texture/font02.tga
+%%DATADIR%%/texture/font03.tga
+%%DATADIR%%/texture/gameover.tga
+%%DATADIR%%/texture/gface.tga
+%%DATADIR%%/texture/gfaceb1.tga
+%%DATADIR%%/texture/gfaceb2.tga
+%%DATADIR%%/texture/gfaceh01.tga
+%%DATADIR%%/texture/gfaceh02.tga
+%%DATADIR%%/texture/gfaceh03.tga
+%%DATADIR%%/texture/gfacem1.tga
+%%DATADIR%%/texture/gfacem2.tga
+%%DATADIR%%/texture/gfacem3.tga
+%%DATADIR%%/texture/gfacem4.tga
+%%DATADIR%%/texture/gishhud.tga
+%%DATADIR%%/texture/gishhurt.tga
+%%DATADIR%%/texture/gishtalk.tga
+%%DATADIR%%/texture/gishtitle.tga
+%%DATADIR%%/texture/gishwin.tga
+%%DATADIR%%/texture/gishy.tga
+%%DATADIR%%/texture/grayhurt.tga
+%%DATADIR%%/texture/graywin.tga
+%%DATADIR%%/texture/greyhud.tga
+%%DATADIR%%/texture/key.tga
+%%DATADIR%%/texture/level.tga
+%%DATADIR%%/texture/loading03.tga
+%%DATADIR%%/texture/lvlcomplete.tga
+%%DATADIR%%/texture/mouse00.tga
+%%DATADIR%%/texture/mouse01.tga
+%%DATADIR%%/texture/oneup.tga
+%%DATADIR%%/texture/piston1.tga
+%%DATADIR%%/texture/piston2.tga
+%%DATADIR%%/texture/poop.tga
+%%DATADIR%%/texture/ready.tga
+%%DATADIR%%/texture/rope.tga
+%%DATADIR%%/texture/sewer.tga
+%%DATADIR%%/texture/storymode.tga
+%%DATADIR%%/texture/sumo.tga
+%%DATADIR%%/texture/tar.tga
+%%DATADIR%%/texture/tar2.tga
+%%DATADIR%%/texture/tarball.tga
+%%DATADIR%%/texture/tarballs.tga
+%%DATADIR%%/texture/text000.tga
+%%DATADIR%%/texture/text001.tga
+%%DATADIR%%/texture/text002.tga
+%%DATADIR%%/texture/text003.tga
+%%DATADIR%%/texture/text004.tga
+%%DATADIR%%/texture/text005.tga
+%%DATADIR%%/texture/text006.tga
+%%DATADIR%%/texture/text007.tga
+%%DATADIR%%/texture/text008.tga
+%%DATADIR%%/texture/text009.tga
+%%DATADIR%%/texture/text010.tga
+%%DATADIR%%/texture/text011.tga
+%%DATADIR%%/texture/text012.tga
+%%DATADIR%%/texture/text013.tga
+%%DATADIR%%/texture/text014.tga
+%%DATADIR%%/texture/text015.tga
+%%DATADIR%%/texture/text016.tga
+%%DATADIR%%/texture/text017.tga
+%%DATADIR%%/texture/text018.tga
+%%DATADIR%%/texture/text019.tga
+%%DATADIR%%/texture/text020.tga
+%%DATADIR%%/texture/text021.tga
+%%DATADIR%%/texture/text022.tga
+%%DATADIR%%/texture/text023.tga
+%%DATADIR%%/texture/text024.tga
+%%DATADIR%%/texture/text025.tga
+%%DATADIR%%/texture/text026.tga
+%%DATADIR%%/texture/text027.tga
+%%DATADIR%%/texture/text028.tga
+%%DATADIR%%/texture/text029.tga
+%%DATADIR%%/texture/text030.tga
+%%DATADIR%%/texture/text031.tga
+%%DATADIR%%/texture/text032.tga
+%%DATADIR%%/texture/text033.tga
+%%DATADIR%%/texture/text034.tga
+%%DATADIR%%/texture/text035.tga
+%%DATADIR%%/texture/text036.tga
+%%DATADIR%%/texture/text037.tga
+%%DATADIR%%/texture/text038.tga
+%%DATADIR%%/texture/text039.tga
+%%DATADIR%%/texture/text040.tga
+%%DATADIR%%/texture/text041.tga
+%%DATADIR%%/texture/text042.tga
+%%DATADIR%%/texture/text043.tga
+%%DATADIR%%/texture/text046.tga
+%%DATADIR%%/texture/text047.tga
+%%DATADIR%%/texture/text048.tga
+%%DATADIR%%/texture/text049.tga
+%%DATADIR%%/texture/text052.tga
+%%DATADIR%%/texture/text053.tga
+%%DATADIR%%/texture/text054.tga
+%%DATADIR%%/texture/text055.tga
+%%DATADIR%%/texture/text056.tga
+%%DATADIR%%/texture/text058.tga
+%%DATADIR%%/texture/text059.tga
+%%DATADIR%%/texture/text060.tga
+%%DATADIR%%/texture/text061.tga
+%%DATADIR%%/texture/text062.tga
+%%DATADIR%%/texture/text063.tga
+%%DATADIR%%/texture/turbo.tga
+%%DATADIR%%/texture/vsmode.tga
+@dirrm %%DATADIR%%/texture
+@dirrm %%DATADIR%%/sound
+@dirrm %%DATADIR%%/replay
+@dirrm %%DATADIR%%/music
+@dirrm %%DATADIR%%/leveldemo
+@dirrm %%DATADIR%%/animation
+@dirrm %%DATADIR%%