aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/etoile-bookmarkkit/Makefile33
-rw-r--r--www/etoile-bookmarkkit/distinfo3
-rw-r--r--www/etoile-bookmarkkit/pkg-descr10
-rw-r--r--www/etoile-bookmarkkit/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index e5a9a7f3ac2d..ee01c8a10064 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -123,6 +123,7 @@
SUBDIR += epiphany
SUBDIR += epiphany-extensions
SUBDIR += erwn
+ SUBDIR += etoile-bookmarkkit
SUBDIR += etoile-grr
SUBDIR += etoile-rsskit
SUBDIR += eventum
diff --git a/www/etoile-bookmarkkit/Makefile b/www/etoile-bookmarkkit/Makefile
new file mode 100644
index 000000000000..e906002969c7
--- /dev/null
+++ b/www/etoile-bookmarkkit/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: etoile-bookmarkkit
+# Date created: 18 Nov 2006
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= bookmarkkit
+PORTVERSION= 0.1.${SNAPSHOT}
+CATEGORIES= www
+MASTER_SITES= http://florida.ethz.ch/ports/distfiles/
+PKGNAMEPREFIX= etoile-
+DISTNAME= etoile_0+${SNAPSHOT}+dfsg.orig
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= Etoile Project BookmarkKit framework
+
+SNAPSHOT= 20060917
+WRKSRC= ${WRKDIR}/etoile-0+${SNAPSHOT}+dfsg/Etoile/
+USE_GMAKE= yes
+USE_GNUSTEP= yes
+USE_GNUSTEP_PREFIX= yes
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+MAKEFILE= GNUmakefile
+NO_FILTER_SHLIBS= yes
+USE_GNUSTEP_SYSTEM_LIBS+= TrackerKit:${TRACKERKIT_PORT}
+USE_GNUSTEP_MAKE_DIRS+= Frameworks/BookmarkKit
+
+TRACKERKIT_PORT?= deskutils/etoile-trackerkit
+
+.include <bsd.port.mk>
diff --git a/www/etoile-bookmarkkit/distinfo b/www/etoile-bookmarkkit/distinfo
new file mode 100644
index 000000000000..2d5c7ccf5d13
--- /dev/null
+++ b/www/etoile-bookmarkkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (etoile_0+20060917+dfsg.orig.tar.gz) = bc96dcaba7ac66abb1320d5cfc98f05e
+SHA256 (etoile_0+20060917+dfsg.orig.tar.gz) = de7cb026ccebdbb72d115ca800a13910cd51c9df27f5578ad7059b13f88eb334
+SIZE (etoile_0+20060917+dfsg.orig.tar.gz) = 10478850
diff --git a/www/etoile-bookmarkkit/pkg-descr b/www/etoile-bookmarkkit/pkg-descr
new file mode 100644
index 000000000000..5e9d6ce7b98e
--- /dev/null
+++ b/www/etoile-bookmarkkit/pkg-descr
@@ -0,0 +1,10 @@
+Etoile intends to be an innovative GNUstep based user environnement built
+from the ground up on highly modular and light components with project and
+document orientation in mind, in order to allow users to create their own
+workflow by reshaping or recombining provided Services (aka Applications),
+Components etc. Flexibility and modularity on both User Interface and code
+level should allow us to scale from PDA to computer environment.
+
+This package installs the BookmarkKit framework.
+
+WWW: http://www.etoile-project.org/
diff --git a/www/etoile-bookmarkkit/pkg-plist b/www/etoile-bookmarkkit/pkg-plist
new file mode 100644
index 000000000000..cdb62bdd3eab
--- /dev/null
+++ b/www/etoile-bookmarkkit/pkg-plist
@@ -0,0 +1,8 @@
+System/Library/Headers/BookmarkKit/BKBookmark.h
+System/Library/Headers/BookmarkKit/BKBookmarkQuery.h
+System/Library/Headers/BookmarkKit/BKBookmarkSearchResult.h
+System/Library/Headers/BookmarkKit/BKBookmarkStore.h
+System/Library/Libraries/libBookmarkKit.so
+System/Library/Libraries/libBookmarkKit.so.%%MAJORLIBVERSION%%
+System/Library/Libraries/libBookmarkKit.so.%%MAJORLIBVERSION%%.1
+@dirrm System/Library/Headers/BookmarkKit