aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/py-ipy/Makefile28
-rw-r--r--net-mgmt/py-ipy/distinfo1
-rw-r--r--net-mgmt/py-ipy/pkg-comment1
-rw-r--r--net-mgmt/py-ipy/pkg-descr6
-rw-r--r--net-mgmt/py-ipy/pkg-plist2
-rw-r--r--net/Makefile1
-rw-r--r--net/py-ipy/Makefile28
-rw-r--r--net/py-ipy/distinfo1
-rw-r--r--net/py-ipy/pkg-comment1
-rw-r--r--net/py-ipy/pkg-descr6
-rw-r--r--net/py-ipy/pkg-plist2
11 files changed, 77 insertions, 0 deletions
diff --git a/net-mgmt/py-ipy/Makefile b/net-mgmt/py-ipy/Makefile
new file mode 100644
index 000000000000..5c79207323e9
--- /dev/null
+++ b/net-mgmt/py-ipy/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: py-ipy
+# Date created: Jan 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipy
+PORTVERSION= 0.41
+CATEGORIES= net python
+MASTER_SITES= http://c0re.jp/c0de/IPy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= IPy-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-ipy/distinfo b/net-mgmt/py-ipy/distinfo
new file mode 100644
index 000000000000..68057dcc92fb
--- /dev/null
+++ b/net-mgmt/py-ipy/distinfo
@@ -0,0 +1 @@
+MD5 (IPy-0.41.tar.gz) = 883aca022bfe7a4a5867995bed267072
diff --git a/net-mgmt/py-ipy/pkg-comment b/net-mgmt/py-ipy/pkg-comment
new file mode 100644
index 000000000000..deef71323e4d
--- /dev/null
+++ b/net-mgmt/py-ipy/pkg-comment
@@ -0,0 +1 @@
+A Python module for handling IPv4 and IPv6 Addresses and Networks
diff --git a/net-mgmt/py-ipy/pkg-descr b/net-mgmt/py-ipy/pkg-descr
new file mode 100644
index 000000000000..60bb2d34e892
--- /dev/null
+++ b/net-mgmt/py-ipy/pkg-descr
@@ -0,0 +1,6 @@
+IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks in
+a fashion similar to perl's Net::IP and friends. The IP class allows a
+comfortable parsing and handling for most notations in use for IPv4 and IPv6
+Addresses and Networks.
+
+WWW: http://c0re.jp/c0de/IPy/
diff --git a/net-mgmt/py-ipy/pkg-plist b/net-mgmt/py-ipy/pkg-plist
new file mode 100644
index 000000000000..b526b8ef8600
--- /dev/null
+++ b/net-mgmt/py-ipy/pkg-plist
@@ -0,0 +1,2 @@
+lib/%%PYTHON_VERSION%%/site-packages/IPy.py
+lib/%%PYTHON_VERSION%%/site-packages/IPy.pyc
diff --git a/net/Makefile b/net/Makefile
index 4843d692096c..53c37b5d9776 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -361,6 +361,7 @@
SUBDIR += punkbuster-data
SUBDIR += pvm
SUBDIR += pvm++
+ SUBDIR += py-ipy
SUBDIR += py-jabber
SUBDIR += py-pcap
SUBDIR += py-smb
diff --git a/net/py-ipy/Makefile b/net/py-ipy/Makefile
new file mode 100644
index 000000000000..5c79207323e9
--- /dev/null
+++ b/net/py-ipy/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# Ports collection makefile for: py-ipy
+# Date created: Jan 30, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipy
+PORTVERSION= 0.41
+CATEGORIES= net python
+MASTER_SITES= http://c0re.jp/c0de/IPy/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= IPy-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/net/py-ipy/distinfo b/net/py-ipy/distinfo
new file mode 100644
index 000000000000..68057dcc92fb
--- /dev/null
+++ b/net/py-ipy/distinfo
@@ -0,0 +1 @@
+MD5 (IPy-0.41.tar.gz) = 883aca022bfe7a4a5867995bed267072
diff --git a/net/py-ipy/pkg-comment b/net/py-ipy/pkg-comment
new file mode 100644
index 000000000000..deef71323e4d
--- /dev/null
+++ b/net/py-ipy/pkg-comment
@@ -0,0 +1 @@
+A Python module for handling IPv4 and IPv6 Addresses and Networks
diff --git a/net/py-ipy/pkg-descr b/net/py-ipy/pkg-descr
new file mode 100644
index 000000000000..60bb2d34e892
--- /dev/null
+++ b/net/py-ipy/pkg-descr
@@ -0,0 +1,6 @@
+IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks in
+a fashion similar to perl's Net::IP and friends. The IP class allows a
+comfortable parsing and handling for most notations in use for IPv4 and IPv6
+Addresses and Networks.
+
+WWW: http://c0re.jp/c0de/IPy/
diff --git a/net/py-ipy/pkg-plist b/net/py-ipy/pkg-plist
new file mode 100644
index 000000000000..b526b8ef8600
--- /dev/null
+++ b/net/py-ipy/pkg-plist
@@ -0,0 +1,2 @@
+lib/%%PYTHON_VERSION%%/site-packages/IPy.py
+lib/%%PYTHON_VERSION%%/site-packages/IPy.pyc