aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/structuresynth/Makefile6
-rw-r--r--graphics/tiled/Makefile8
-rw-r--r--x11-themes/qt4-style-float/Makefile6
-rw-r--r--x11-themes/qt4-style-phase/Makefile6
-rw-r--r--x11-themes/qt4-style-quantumstyle/Makefile6
5 files changed, 11 insertions, 21 deletions
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
index b62d063d3c7f..1e48daf8e1ac 100644
--- a/graphics/structuresynth/Makefile
+++ b/graphics/structuresynth/Makefile
@@ -11,9 +11,10 @@ DISTNAME= StructureSynth-Source-v${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Rule-based 3D structure generator
+USES= qmake
USE_GL= glu
USE_ZIP= yes
-USE_QT4= qmake_build corelib gui opengl moc_build rcc_build xml script
+USE_QT4= corelib gui opengl moc_build rcc_build xml script
WRKSRC= ${WRKDIR}/structure-synth
USE_DOS2UNIX= *.cpp *.h
@@ -26,11 +27,10 @@ post-patch:
/miscDir/ s|"Misc"|"${DATADIR}/Misc"|' \
${WRKSRC}/StructureSynth/GUI/MainWindow.cpp
-do-configure:
+pre-configure:
@cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} -project \
-after "CONFIG+=opengl" -after "QT+=xml opengl script" \
-after "LIBS+=-lGLU"
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/structure-synth ${STAGEDIR}${PREFIX}/bin/
diff --git a/graphics/tiled/Makefile b/graphics/tiled/Makefile
index eec24c508f6f..59e145f010da 100644
--- a/graphics/tiled/Makefile
+++ b/graphics/tiled/Makefile
@@ -10,10 +10,10 @@ DISTNAME= tiled-qt-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= General purpose tile map editor
+USES= qmake
USE_QT4= corelib gui opengl \
- linguist_build qmake_build moc_build uic_build rcc_build
+ linguist_build moc_build uic_build rcc_build
USE_LDCONFIG= yes
-DESTDIRNAME= INSTALL_ROOT
PORTDOCS= *
@@ -30,10 +30,6 @@ post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' ${WRKSRC}/docs/tiled.desktop
@${FIND} ${WRKSRC} -name "*.pro" -exec ${REINPLACE_CMD} -e 's|share/man|man|' {} \;
-do-configure:
- cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} ${QMAKEFLAGS} PREFIX="${PREFIX}" tiled.pro
-
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}/
diff --git a/x11-themes/qt4-style-float/Makefile b/x11-themes/qt4-style-float/Makefile
index b512de869fde..a024b67b7d86 100644
--- a/x11-themes/qt4-style-float/Makefile
+++ b/x11-themes/qt4-style-float/Makefile
@@ -15,17 +15,15 @@ COMMENT= Style for Qt 4 and KDE
LICENSE= GPLv2
+USES= qmake
USE_BZIP2= yes
-USE_QT4= corelib gui qmake_build moc_build rcc_build
+USE_QT4= corelib gui moc_build rcc_build
WRKSRC= ${WRKDIR}/floatstyle-${PORTVERSION}
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/libfloatstyle.so
PLIST_DIRSTRY= ${QT_PLUGINDIR_REL}/styles
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${QT_PLUGINDIR_REL}/styles/
${INSTALL_PROGRAM} ${WRKSRC}/libfloatstyle.so ${STAGEDIR}${PREFIX}/${QT_PLUGINDIR_REL}/styles/
diff --git a/x11-themes/qt4-style-phase/Makefile b/x11-themes/qt4-style-phase/Makefile
index 8df420481a2e..de220d58fd38 100644
--- a/x11-themes/qt4-style-phase/Makefile
+++ b/x11-themes/qt4-style-phase/Makefile
@@ -15,17 +15,15 @@ COMMENT= Widget style for Qt 4 and KDE 4
LICENSE= MIT
+USES= qmake
USE_BZIP2= yes
-USE_QT4= corelib gui qmake_build moc_build
+USE_QT4= corelib gui moc_build
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/libphasestyle.so
PLIST_DIRSTRY= ${QT_PLUGINDIR_REL}/styles
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${QT_PLUGINDIR_REL}/styles/
${INSTALL_PROGRAM} ${WRKSRC}/libphasestyle.so ${STAGEDIR}${PREFIX}/${QT_PLUGINDIR_REL}/styles/
diff --git a/x11-themes/qt4-style-quantumstyle/Makefile b/x11-themes/qt4-style-quantumstyle/Makefile
index 71bcb60920a5..7a6b363ee9a9 100644
--- a/x11-themes/qt4-style-quantumstyle/Makefile
+++ b/x11-themes/qt4-style-quantumstyle/Makefile
@@ -16,16 +16,14 @@ COMMENT= SVG themeable style for Qt 4 and KDE
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USE_QT4= corelib gui svg qmake_build rcc_build uic_build moc_build
+USES= qmake
+USE_QT4= corelib gui svg rcc_build uic_build moc_build
WRKSRC= ${WRKDIR}/QuantumStyle
PLIST_FILES= ${QT_PLUGINDIR_REL}/styles/libquantumstyle.so
PLIST_DIRSTRY= ${QT_PLUGINDIR_REL}/styles
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE} ${QMAKEFLAGS}
-
do-install:
${MKDIR} ${STAGEDIR}${PREFIX}/${QT_PLUGINDIR_REL}/styles/
${INSTALL_PROGRAM} ${WRKSRC}/style/libquantumstyle.so ${STAGEDIR}${PREFIX}/${QT_PLUGINDIR_REL}/styles/