aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/emacs-devel/Makefile4
-rw-r--r--ftp/bsdftpd-ssl/Makefile4
-rw-r--r--ftp/ftpd-tls/Makefile4
-rw-r--r--mail/biffer/Makefile8
-rw-r--r--misc/c-hey/Makefile8
-rw-r--r--net-im/centericq/Makefile4
-rw-r--r--net-im/centerim/Makefile4
-rw-r--r--net/clusterit/Makefile8
-rw-r--r--net/fspclient/Makefile8
-rw-r--r--net/fspd/Makefile4
-rw-r--r--security/chkrootkit/Makefile8
-rw-r--r--x11-wm/e17-module-uptime/Makefile8
-rw-r--r--x11/aterm/Makefile8
-rw-r--r--x11/e17-module-uptime/Makefile8
-rw-r--r--x11/emu/Makefile8
15 files changed, 87 insertions, 9 deletions
diff --git a/editors/emacs-devel/Makefile b/editors/emacs-devel/Makefile
index f961fd322c0c..aeccfe395f20 100644
--- a/editors/emacs-devel/Makefile
+++ b/editors/emacs-devel/Makefile
@@ -84,6 +84,10 @@ OPTIONS= SOURCES "Install source code" ON
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined(WITH_SOURCES)
PLIST_SUB+= SOURCES=""
.else
diff --git a/ftp/bsdftpd-ssl/Makefile b/ftp/bsdftpd-ssl/Makefile
index 3013cabd48d0..01d798a1d811 100644
--- a/ftp/bsdftpd-ssl/Makefile
+++ b/ftp/bsdftpd-ssl/Makefile
@@ -18,6 +18,10 @@ USE_OPENSSL= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
# Client only part
.if defined(CLIENT_ONLY)
PKGNAMESUFFIX= -client
diff --git a/ftp/ftpd-tls/Makefile b/ftp/ftpd-tls/Makefile
index 2765aa55c839..dec789f64008 100644
--- a/ftp/ftpd-tls/Makefile
+++ b/ftp/ftpd-tls/Makefile
@@ -26,6 +26,10 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-patch:
.for i in README.TLS ftpd.8.TLS pathnames.h tlsutil.c
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
diff --git a/mail/biffer/Makefile b/mail/biffer/Makefile
index 4d4519791852..16ee2fccb9ce 100644
--- a/mail/biffer/Makefile
+++ b/mail/biffer/Makefile
@@ -21,6 +21,12 @@ MAKE_JOBS_UNSAFE= yes
MAN1= biffopt.1
MAN8= biffer.8 biffer_comsat.8
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's,/usr/local,${PREFIX},g' ${WRKSRC}/biffer_comsat/Makefile
@@ -35,4 +41,4 @@ post-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} \
POST-INSTALL
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/misc/c-hey/Makefile b/misc/c-hey/Makefile
index aef4797fcd29..262fdf9f1af9 100644
--- a/misc/c-hey/Makefile
+++ b/misc/c-hey/Makefile
@@ -18,4 +18,10 @@ MAN1= c-hey.1
MLINKS= c-hey.1 hey.1
PLIST_FILES= bin/c-hey bin/hey
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index 8b53194fe047..6743b703cf04 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -44,6 +44,10 @@ PORTDOCS= FAQ README
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if ${ARCH} == "amd64"
# Don't use optimization since it sefgaults in some cases otherwise.
CFLAGS:= ${CFLAGS:C/-O[0123456789]*/-O0/}
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index 4b41b91c0101..04c2faa61889 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -46,6 +46,10 @@ PORTDOCS= FAQ README
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
diff --git a/net/clusterit/Makefile b/net/clusterit/Makefile
index cb19d5b85855..3c22b9b4bfea 100644
--- a/net/clusterit/Makefile
+++ b/net/clusterit/Makefile
@@ -18,6 +18,12 @@ GNU_CONFIGURE= yes
MAN1= barrier.1 barrierd.1 clustersed.1 dsh.1 dshbak.1 \
dtop.1 jsh.1 jsd.1 pcp.1 pdf.1 prm.1 rseq.1 run.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined (WITHOUT_X11)
PLIST_SUB+= X11='@comment '
.else
@@ -31,4 +37,4 @@ post-patch:
${REINPLACE_CMD} -E 's,^(SUBDIRS) = .*,\1 = barrier dsh jsd pcp dtop tools,' ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/fspclient/Makefile b/net/fspclient/Makefile
index e39fa26e5bf5..e49cacc184bc 100644
--- a/net/fspclient/Makefile
+++ b/net/fspclient/Makefile
@@ -21,4 +21,10 @@ MAN1= fsp.1
MANCOMPRESSED= yes
PLIST_FILES= bin/fsp
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/fspd/Makefile b/net/fspd/Makefile
index 0fb89e11d8af..ca91d84c7979 100644
--- a/net/fspd/Makefile
+++ b/net/fspd/Makefile
@@ -43,6 +43,10 @@ OPTIONS= NOCLIENTS "Omit client commands" off \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if defined(WITH_INFINITE)
SCONS_ARGS+= disable-timeout=yes
.endif
diff --git a/security/chkrootkit/Makefile b/security/chkrootkit/Makefile
index a517b0eef84f..ebacc1ed68c2 100644
--- a/security/chkrootkit/Makefile
+++ b/security/chkrootkit/Makefile
@@ -40,6 +40,12 @@ PLIST_FILES= ${ALL_TARGET:C,^,sbin/,}
BINMODE= 0700
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-patch:
@${REINPLACE_CMD} -E "s/^(CC|CFLAGS)[^a-zA-Z]*=/\1 ?=/" \
${WRKSRC}/Makefile
@@ -57,4 +63,4 @@ do-install:
${INSTALL_DATA} ${PORTDOCS:C,^,${WRKSRC}/,} ${DOCSDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-wm/e17-module-uptime/Makefile b/x11-wm/e17-module-uptime/Makefile
index b98d0395315b..21059067e9fa 100644
--- a/x11-wm/e17-module-uptime/Makefile
+++ b/x11-wm/e17-module-uptime/Makefile
@@ -25,6 +25,12 @@ USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_EFL= edje
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -33,4 +39,4 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/aterm/Makefile b/x11/aterm/Makefile
index 01d82b9d7560..58c32d4061e0 100644
--- a/x11/aterm/Makefile
+++ b/x11/aterm/Makefile
@@ -23,6 +23,12 @@ CONFIGURE_ARGS+= --enable-transparency \
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if !defined(WITHOUT_BACKGROUND_IMAGE)
LIB_DEPENDS+= AfterImage.0:${PORTSDIR}/graphics/libafterimage
CONFIGURE_ARGS+= --enable-background-image
@@ -71,4 +77,4 @@ MAN1= aterm.1
post-install:
@${CHMOD} 4711 ${PREFIX}/bin/aterm
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/e17-module-uptime/Makefile b/x11/e17-module-uptime/Makefile
index b98d0395315b..21059067e9fa 100644
--- a/x11/e17-module-uptime/Makefile
+++ b/x11/e17-module-uptime/Makefile
@@ -25,6 +25,12 @@ USE_GMAKE= yes
USE_GNOME= gnometarget pkgconfig
USE_EFL= edje
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -33,4 +39,4 @@ CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11/emu/Makefile b/x11/emu/Makefile
index 0a6e29ae0ea1..ba6dc3fcd647 100644
--- a/x11/emu/Makefile
+++ b/x11/emu/Makefile
@@ -24,6 +24,12 @@ USE_DISPLAY= yes
WRKSRC= ${WRKDIR}/emu
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
.if (!defined(DISPLAY) || ${DISPLAY} == "") && !defined(PACKAGE_BUILDING)
IGNORE= requires an active X session (and DISPLAY variable) to run xrdb. Please compile this while running X
.endif
@@ -33,4 +39,4 @@ MAN1= emu.1
pre-configure:
cd ${WRKSRC}/client ; ${LN} -s ../doc/emu.man .
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>