aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/Makefile1
-rw-r--r--databases/py-pytc/Makefile24
-rw-r--r--databases/py-pytc/distinfo3
-rw-r--r--databases/py-pytc/files/patch-setyp.py11
-rw-r--r--databases/py-pytc/pkg-descr3
5 files changed, 42 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index e37814ab2968..6fe3a34c0981 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -520,6 +520,7 @@
SUBDIR += py-pysqlite21
SUBDIR += py-pysqlite22
SUBDIR += py-pysqlite23
+ SUBDIR += py-pytc
SUBDIR += py-qt4-sql
SUBDIR += py-rrdpipe
SUBDIR += py-rrdtool_lgpl
diff --git a/databases/py-pytc/Makefile b/databases/py-pytc/Makefile
new file mode 100644
index 000000000000..2b75e963bd6a
--- /dev/null
+++ b/databases/py-pytc/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: py-pytc
+# Date created: 2009-02-18
+# Whom: Li-Wen Hsu <lwhsu@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pytc
+PORTVERSION= 0.7
+CATEGORIES= databases python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Tokyo Cabinet Python bindings
+
+LIB_DEPENDS= tokyocabinet:${PORTSDIR}/databases/tokyocabinet
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/pytc.so
+
+.include <bsd.port.mk>
diff --git a/databases/py-pytc/distinfo b/databases/py-pytc/distinfo
new file mode 100644
index 000000000000..54652a763948
--- /dev/null
+++ b/databases/py-pytc/distinfo
@@ -0,0 +1,3 @@
+MD5 (pytc-0.7.tar.gz) = a7346ee22dbe772fbdcd989282335bd8
+SHA256 (pytc-0.7.tar.gz) = 32a05a735666283ca607672ebede24896c5ae5217fcad3cb2a3f4959383df776
+SIZE (pytc-0.7.tar.gz) = 10591
diff --git a/databases/py-pytc/files/patch-setyp.py b/databases/py-pytc/files/patch-setyp.py
new file mode 100644
index 000000000000..fa7df2591cec
--- /dev/null
+++ b/databases/py-pytc/files/patch-setyp.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2009-02-18 08:58:48.199458174 +0800
++++ setup.py 2009-02-18 08:58:56.569760265 +0800
+@@ -5,7 +5,7 @@
+ if sys.version_info < (2, 3):
+ raise Error, "Python 2.3 or later is required"
+
+-include_dirs = []
++include_dirs = ['/usr/local/include']
+ library_dirs = ['/usr/local/lib']
+
+ if sys.platform == 'darwin':
diff --git a/databases/py-pytc/pkg-descr b/databases/py-pytc/pkg-descr
new file mode 100644
index 000000000000..cc011c993c0d
--- /dev/null
+++ b/databases/py-pytc/pkg-descr
@@ -0,0 +1,3 @@
+Tokyo Cabinet Python bindings
+
+WWW: http://coderepos.org/share/wiki/PyTC