aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/sge60/Makefile6
-rw-r--r--sysutils/sge60/files/qsh-disabled.sh3
2 files changed, 8 insertions, 1 deletions
diff --git a/sysutils/sge60/Makefile b/sysutils/sge60/Makefile
index 0e06067af324..38194ec17d1f 100644
--- a/sysutils/sge60/Makefile
+++ b/sysutils/sge60/Makefile
@@ -27,7 +27,8 @@ FETCH_CMD= wget -c
OPTIONS= BDB "Use DB based spooler" on \
JAVA "Support Java DRMAA API" on \
- X11 "Qmon X11 GUI" on
+ X11 "Qmon X11 GUI" on \
+ QSH "Enable qsh (requires xterm on exec hosts)" on
CONFLICTS= sge-6.[1-9]* sge-5* sgeee-[0-9]* sge-0.*
@@ -174,6 +175,9 @@ do-build:
@${MKDIR} ${TMP_SGE_ROOT}
@cd ${WRKSRC} && ${SETENV} SGE_ROOT=${TMP_SGE_ROOT} \
./scripts/distinst -local -libs ${SGE_ARCH} -- ${INST_PROGS}
+.if defined(WITHOUT_QSH)
+ ${INSTALL_SCRIPT} ${FILESDIR}/qsh-disabled.sh ${TMP_SGE_ROOT}/bin/${SGE_ARCH}/qsh
+.endif
.if !defined(WITH_X11)
@${RM} ${TMP_SGE_ROOT}/catman/cat/cat1/qmon.1
@${RM} -r ${TMP_SGE_ROOT}/3rd_party/qmon
diff --git a/sysutils/sge60/files/qsh-disabled.sh b/sysutils/sge60/files/qsh-disabled.sh
new file mode 100644
index 000000000000..1398eec061dc
--- /dev/null
+++ b/sysutils/sge60/files/qsh-disabled.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+echo "qsh is not supported on this system" 1>&2
+exit 1