aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c11
-rw-r--r--net-im/pidgin/Makefile2
2 files changed, 12 insertions, 1 deletions
diff --git a/net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c b/net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c
new file mode 100644
index 000000000000..3d37956cc567
--- /dev/null
+++ b/net-im/libpurple/files/patch-pidgin_plugins_cap_cap.c
@@ -0,0 +1,11 @@
+--- pidgin/plugins/cap/cap.c.orig 2013-03-24 20:34:29.882262000 +0000
++++ pidgin/plugins/cap/cap.c 2013-03-24 20:34:39.576121000 +0000
+@@ -43,7 +43,7 @@ static double generate_prediction_for(Pu
+ int threshold = purple_prefs_get_int("/plugins/gtk/cap/threshold");
+ int min_minute = (current_minute - threshold) % 1440;
+ int max_minute = (current_minute + threshold) % 1440;
+- char *sql, sta_id = NULL;
++ char *sql, *sta_id = NULL;
+ sqlite3_stmt *stmt = NULL;
+ const char *tail = NULL;
+ int rc;
diff --git a/net-im/pidgin/Makefile b/net-im/pidgin/Makefile
index e51dc0834c09..a1bc1f20e830 100644
--- a/net-im/pidgin/Makefile
+++ b/net-im/pidgin/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= pidgin
-PORTREVISION= 0
+PORTREVISION= 1
MAINTAINER= marcus@FreeBSD.org
COMMENT= Pidgin multi-protocol messaging client (GTK+ UI)