aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED4
-rw-r--r--net/Makefile4
-rw-r--r--net/ipw-firmware-kmod/Makefile73
-rw-r--r--net/ipw-firmware-kmod/distinfo2
-rw-r--r--net/ipw-firmware-kmod/pkg-descr6
-rw-r--r--net/ipw-firmware-kmod/pkg-plist4
-rw-r--r--net/ipw-firmware/Makefile174
-rw-r--r--net/ipw-firmware/distinfo4
-rw-r--r--net/ipw-firmware/files/ipw.sh.in66
-rw-r--r--net/ipw-firmware/files/pkg-message.in40
-rw-r--r--net/ipw-firmware/pkg-descr6
-rw-r--r--net/ipw-firmware/pkg-plist11
-rw-r--r--net/ipw-firmware/pkg-req222
-rw-r--r--net/iwi-firmware-kmod/Makefile30
-rw-r--r--net/iwi-firmware-kmod/distinfo2
-rw-r--r--net/iwi-firmware-kmod/pkg-descr6
-rw-r--r--net/iwi-firmware-kmod/pkg-plist4
-rw-r--r--net/iwi-firmware/Makefile36
-rw-r--r--net/iwi-firmware/distinfo4
-rw-r--r--net/iwi-firmware/files/iwi.sh.in59
-rw-r--r--net/iwi-firmware/files/pkg-message.in40
-rw-r--r--net/iwi-firmware/pkg-descr6
-rw-r--r--net/iwi-firmware/pkg-plist15
23 files changed, 4 insertions, 814 deletions
diff --git a/MOVED b/MOVED
index b31bb32447d8..14c52a5a3a43 100644
--- a/MOVED
+++ b/MOVED
@@ -3234,3 +3234,7 @@ devel/hs-hmake||2012-02-13|Removed: Broken, unmaintained upstream.
net/yate-devel||2012-02-17|Removed, please use net/yate
databases/p5-postgresql-plperl|databases/postgresql84-plperl|2012-02-19|Split into versioned ports
devel/p5-Version-Requirements||2012-03-01|Removed: deprecated, use CPAN::Meta::Requirements (devel/p5-CPAN-Meta >= 2.113640) instead
+net/ipw-firmware||2012-03-02|Removed: is already included in base system
+net/ipw-firmware-kmod||2012-03-02|Removed: is already included in base system
+net/iwi-firmware||2012-03-02|Removed: is already included in base system
+net/iwi-firmware-kmod||2012-03-02|Removed: is already included in base system
diff --git a/net/Makefile b/net/Makefile
index cabf51750207..3c274301c59d 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -249,8 +249,6 @@
SUBDIR += ipsorc
SUBDIR += ipsumdump
SUBDIR += ipsvd
- SUBDIR += ipw-firmware
- SUBDIR += ipw-firmware-kmod
SUBDIR += irrd
SUBDIR += isc-dhcp41-client
SUBDIR += isc-dhcp41-relay
@@ -260,8 +258,6 @@
SUBDIR += isc-dhcp42-server
SUBDIR += iscsi-target
SUBDIR += istgt
- SUBDIR += iwi-firmware
- SUBDIR += iwi-firmware-kmod
SUBDIR += jags
SUBDIR += jakarta-commons-net
SUBDIR += java-beepcore
diff --git a/net/ipw-firmware-kmod/Makefile b/net/ipw-firmware-kmod/Makefile
deleted file mode 100644
index 60aa1127a1b7..000000000000
--- a/net/ipw-firmware-kmod/Makefile
+++ /dev/null
@@ -1,73 +0,0 @@
-# New ports collection makefile for: ipw-firmware-kmod
-# Date created: Mar 16 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME?= ipw-firmware
-PORTVERSION= ${FWVERSION}
-PORTREVISION?= 3
-CATEGORIES= net kld
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= flz/ipw
-PKGNAMESUFFIX= -kmod
-FWNAME?= ipw2100-fw-${FWVERSION}
-FWVERSION?= 1.3
-DISTFILES= ${FWNAME}.tgz
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT?= Intel PRO/Wireless 2100 Firmware Kernel Module
-
-DRIVERNAME?= ipw
-FIRMWARES?= ${FWNAME:C/fw-//}-i.fw:${DRIVERNAME}_ibss \
- ${FWNAME:C/fw-//}-p.fw:${DRIVERNAME}_monitor \
- ${FWNAME:C/fw-//}.fw:${DRIVERNAME}_bss
-
-WRKSRC= ${WRKDIR}
-KMODDIR= /boot/modules
-KMODVERSION= ${FWVERSION:C/^(...)$/\1.0/:S/.//g}
-PLIST_SUB= DRIVERNAME="${DRIVERNAME}" \
- KMODDIR="${KMODDIR}"
-CFLAGS+= -D_KERNEL
-
-NO_PACKAGE= "this is a modified version of a restricted firmware"
-
-MIN6OSVERSION?= 999999
-MAX6OSVERSION= 999999
-MIN7OSVERSION?= 700015
-MAX7OSVERSION= 700032
-
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} >= ${MAX7OSVERSION} || \
- ( ${OSVERSION} < 700000 && ${OSVERSION} >= ${MAX6OSVERSION} ) )
-IGNORE= is already included in base system
-.endif
-
-.if !( ${OSVERSION} > ${MIN7OSVERSION} || \
- ( ${OSVERSION} < 700000 && ${OSVERSION} >= ${MIN6OSVERSION} ) )
-IGNORE= needs fresh ${DRIVERNAME}(4), install net/${DRIVERNAME}-firmware instead
-.endif
-
-post-patch:
-.for i in ${FIRMWARES}
- @${MKDIR} ${WRKSRC}/${i:C/.*://}
- @${MV} ${WRKSRC}/${i:C/:.*//} ${WRKSRC}/${i:C/.*://}/${i:C/.*://:S/$/.fw/}
- @${ECHO_CMD} "KMOD= ${i:C/.*://}" > ${WRKSRC}/${i:C/.*://}/Makefile
- @${ECHO_CMD} "FIRMWS= ${i:C/.*://:S/$/.fw/}:${i:C/.*://}:${KMODVERSION}" >> \
- ${WRKSRC}/${i:C/.*://}/Makefile
- @${ECHO_CMD} ".include <bsd.kmod.mk>" >> ${WRKSRC}/${i:C/.*://}/Makefile
-.endfor
-
-do-build:
-.for i in ${FIRMWARES}
- @cd ${WRKSRC}/${i:C/.*://}; ${SETENV} KMODDIR="${KMODDIR}" make all
-.endfor
-
-do-install:
-.for i in ${FIRMWARES}
- @cd ${WRKSRC}/${i:C/.*://}; ${SETENV} KMODDIR="${KMODDIR}" make install
-.endfor
-
-.include <bsd.port.post.mk>
diff --git a/net/ipw-firmware-kmod/distinfo b/net/ipw-firmware-kmod/distinfo
deleted file mode 100644
index 5807020f3804..000000000000
--- a/net/ipw-firmware-kmod/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ipw2100-fw-1.3.tgz) = e1107c455e48d324a616b47a622593bc8413dcce72026f72731c0b03dae3a7a2
-SIZE (ipw2100-fw-1.3.tgz) = 248471
diff --git a/net/ipw-firmware-kmod/pkg-descr b/net/ipw-firmware-kmod/pkg-descr
deleted file mode 100644
index 43e4f4d2fb7f..000000000000
--- a/net/ipw-firmware-kmod/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This project was created by Intel to enable support for the Intel
-PRO/Wireless 2100 Network Connection mini PCI adapter. This project
-(IPW2100) is intended to be a community effort as much as is possible
-given some working constraints (mainly, no HW documentation is available).
-
-WWW: http://ipw2100.sourceforge.net/
diff --git a/net/ipw-firmware-kmod/pkg-plist b/net/ipw-firmware-kmod/pkg-plist
deleted file mode 100644
index c84efe6c3b98..000000000000
--- a/net/ipw-firmware-kmod/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@cwd %%KMODDIR%%
-%%DRIVERNAME%%_bss.ko
-%%DRIVERNAME%%_ibss.ko
-%%DRIVERNAME%%_monitor.ko
diff --git a/net/ipw-firmware/Makefile b/net/ipw-firmware/Makefile
deleted file mode 100644
index 15838660d68c..000000000000
--- a/net/ipw-firmware/Makefile
+++ /dev/null
@@ -1,174 +0,0 @@
-# New ports collection makefile for: ipw-firmware
-# Date created: May 11 2005
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME?= ipw-firmware
-RELNAME?= ipw2100
-PORTVERSION?= 1.3
-PORTREVISION?= 10
-CATEGORIES= net sysutils kld
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= flz/ipw
-DISTFILES= ${RELNAME}-fw-${PORTVERSION}.tgz
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT?= Intel PRO/Wireless 2100 Driver Firmware
-
-DRIVERNAME?= ipw
-DRIVERVERSION?= 1.6.4
-DRIVERDISTNAME= ${DRIVERNAME}-freebsd-${DRIVERVERSION}
-DISTFILES+= ${DRIVERDISTNAME}.tgz
-FIRMWARES?= ${RELNAME}-${PORTVERSION}-i.fw:${DRIVERNAME}-i.fw \
- ${RELNAME}-${PORTVERSION}-p.fw:${DRIVERNAME}-p.fw \
- ${RELNAME}-${PORTVERSION}.fw:${DRIVERNAME}.fw
-
-.include <bsd.port.pre.mk>
-
-# Dummy OSVERSION for ipw.
-MIN7OSVERSION?= 999999
-MAX6OSVERSION?= 700000
-
-# Try to guess sensible defaults.
-.if ${OSVERSION} > ${MIN7OSVERSION}
-OPTIONS+= CONTROL "Install ${DRIVERNAME}control(8) utility" off
-.else
-OPTIONS+= CONTROL "Install ${DRIVERNAME}control(8) utility" on
-.endif
-
-.if ${OSVERSION} > 600023
-OPTIONS+= MODULE "Install ${DRIVERNAME}(4) kernel module (very old snapshot)" off
-.else
-OPTIONS+= MODULE "Install ${DRIVERNAME}(4) kernel module (very old snapshot)" on
-.endif
-
-# Override PREFIX to install ${DRIVERNAME}control(8) somewhere we hope it'll
-# be available soon enough.
-PREFIX= /usr
-
-WRKSRC= ${WRKDIR}
-KERNDIR= /boot/kernel
-KMODDIR= /boot/modules
-FWDIR= /boot/firmware
-SUB_FILES= pkg-message
-SUB_LIST= DRIVERNAME="${DRIVERNAME}" \
- RELNAME="${RELNAME}" \
- KMODDIR="${KMODDIR}" \
- FWDIR="${FWDIR}"
-PLIST_SUB:= ${SUB_LIST}
-MAKE_ENV= BINDIR="${PREFIX}/sbin" \
- MANDIR="${PREFIX}/share/man/man" \
- KMODDIR="${KMODDIR}"
-
-MANCOMPRESSED= yes
-
-.if !defined(PACKAGE_BUILDING)
-IS_INTERACTIVE= yes
-.endif
-
-# That's a bit arbitrary since I have no idea if ${DRIVERNAME}(4) can be
-# compiled on FreeBSD previous to 5.3-RELEASE. This is just too old, people
-# should move on. I may change this if I get successful reports though.
-# Comment this IGNORE line if you want to test it anyway.
-.if ${OSVERSION} < 503000
-IGNORE= needs at least FreeBSD 5.3-RELEASE
-.endif
-
-.if ( ${OSVERSION} >= 700014 || ( ${OSVERSION} < 700000 && ${OSVERSION} >= ${MAX6OSVERSION} ) )
-IGNORE= is now obsolete, install net/${DRIVERNAME}-firmware-kmod instead
-.endif
-
-
-.if ${OSVERSION} > ${MIN7OSVERSION}
-SUB_LIST+= DONT_NEED_CONTROL="@comment "
-MTREE_DIRRM= "@comment "
-. if !defined(WITHOUT_CONTROL)
-IGNORE= is configured with ${DRIVERNAME}control(8) which you don't need, use 'make rmconfig' and uncheck CONTROL
-. endif
-.else
-SUB_LIST+= DONT_NEED_CONTROL=""
-MTREE_DIRRM= ""
-MAN8+= ${DRIVERNAME}control.8
-USE_RCORDER= ${DRIVERNAME}.sh
-.endif
-
-# Hack because ipw(4) and iwi(4) behavior are not in sync: as of 20/01/2006,
-# iwi(4) loads firmware from /boot/firmware, but ipw(4) does not). Hopefully,
-# sam or mlaier will commit generic firmware loading support and new firmware
-# ports will be created once ipw(4) and iwi(4) have been patched to use it.
-.if ${DRIVERNAME} == "ipw" && ${OSVERSION} > 700006
-MTREE_DIRRM= "@comment "
-.endif
-
-PLIST_SUB+= MTREE_DIRRM=${MTREE_DIRRM}
-
-.if defined(WITH_MODULE)
-. if ${OSVERSION} > 600023
-IGNORE= is configured with ${DRIVERNAME}(4) support which you don't need, use 'make rmconfig' and uncheck MODULE
-. else
-PLIST_SUB+= WITH_MODULE=""
-MAN4+= ${DRIVERNAME}.4
-. endif
-.else
-PLIST_SUB+= WITH_MODULE="@comment MODULE "
-.endif
-
-.if !defined(WITHOUT_CONTROL)
-PLIST_SUB+= WITH_CONTROL=""
-.else
-PLIST_SUB+= WITH_CONTROL="@comment CONTROL "
-.endif
-
-# "Might" because people still can include ${DRIVERNAME}(4) support in kernel by extracting
-# its source in src/ and tweaking src/sys/conf/files.
-.if ${OSVERSION} <= 600023 && !exists(${KERNDIR}/if_${DRIVERNAME}.ko) && !defined(WITH_MODULE)
-SUB_LIST+= MIGHT_NEED_MODULE=""
-.else
-SUB_LIST+= MIGHT_NEED_MODULE="@comment "
-.endif
-
-do-build:
-.if defined(WITH_MODULE)
-. for i in share sys
- cd ${WRKSRC}/${DRIVERDISTNAME}/src/${i}; make all
-. endfor
-.endif
-.if !defined(WITHOUT_CONTROL)
- cd ${WRKSRC}/${DRIVERDISTNAME}/src/usr.sbin/${DRIVERNAME}control/; make all
-.endif
-
-do-install:
-.if !defined(PACKAGE_BUILDING)
-# Let pointyhat build the package, anyway the user will have to agree with license
-# terms to install the port/package.
- ${SH} ${PKGREQ} ${PORTNAME} INSTALL
-.endif
-.if defined(WITH_MODULE)
-. for i in share sys
- cd ${WRKSRC}/${DRIVERDISTNAME}/src/${i}; make install ${MAKE_ENV}
-. endfor
-.endif
-.if !defined(WITHOUT_CONTROL)
- cd ${WRKSRC}/${DRIVERDISTNAME}/src/usr.sbin/${DRIVERNAME}control/; make install ${MAKE_ENV}
-.endif
- ${MKDIR} ${FWDIR}
- ${INSTALL_DATA} ${WRKSRC}/LICENSE ${FWDIR}/LICENSE.${DRIVERNAME}
-.for i in ${FIRMWARES}
- ${INSTALL_KLD} ${WRKSRC}/${i:C/:.*//} ${FWDIR}/${i:C/.*://}
-.endfor
-
-post-install:
- @${CAT} ${PKGMESSAGE}
-.if defined(WITH_MODULE)
- @${ECHO_CMD} "You asked for ${DRIVERNAME}(4) module to be installed but"
- @${ECHO_CMD} "be aware that this is a *very* *old* snapshot of the code"
- @${ECHO_CMD} "and that it probably won't work correctly."
- @${ECHO_CMD} "This option will probably go away in a near future."
- @${ECHO_CMD} "SLIPPERY WHEN WET ! BEWARE OF THE DOGS !"
- @${ECHO_CMD} "You have been warned."
-.endif
-
-
-.include <bsd.port.post.mk>
diff --git a/net/ipw-firmware/distinfo b/net/ipw-firmware/distinfo
deleted file mode 100644
index f6769a547387..000000000000
--- a/net/ipw-firmware/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (ipw2100-fw-1.3.tgz) = e1107c455e48d324a616b47a622593bc8413dcce72026f72731c0b03dae3a7a2
-SIZE (ipw2100-fw-1.3.tgz) = 248471
-SHA256 (ipw-freebsd-1.6.4.tgz) = 1db681b0af563b12242d12d28f81a8745f856e24ab337de792293514956cfdf6
-SIZE (ipw-freebsd-1.6.4.tgz) = 23051
diff --git a/net/ipw-firmware/files/ipw.sh.in b/net/ipw-firmware/files/ipw.sh.in
deleted file mode 100644
index 7954a2e8f8a4..000000000000
--- a/net/ipw-firmware/files/ipw.sh.in
+++ /dev/null
@@ -1,66 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: %%DRIVERNAME%%
-# REQUIRE: mountcritlocal
-# BEFORE: ipfilter
-# KEYWORD: shutdown
-
-# Add the following line to /etc/rc.conf to enable `%%DRIVERNAME%%':
-#
-# %%DRIVERNAME%%_enable="YES"
-#
-
-. /etc/rc.subr
-
-name="%%DRIVERNAME%%"
-rcvar=%%DRIVERNAME%%_enable
-
-start_cmd="%%DRIVERNAME%%_start_cmd"
-stop_cmd="%%DRIVERNAME%%_stop_cmd"
-
-load_rc_config "$name"
-: ${%%DRIVERNAME%%_enable="NO"}
-: ${%%DRIVERNAME%%_interfaces="%%DRIVERNAME%%0"}
-
-command="%%PREFIX%%/sbin/%%DRIVERNAME%%control"
-
-%%DRIVERNAME%%_start_cmd()
-{
- echo -n "Starting %%DRIVERNAME%%"
- for i in ${%%DRIVERNAME%%_interfaces}; do
- eval _mode=\$%%DRIVERNAME%%_mode_${i}
- case ${_mode} in
- ""|bss)
- eval _%%DRIVERNAME%%_file_${i}="%%DRIVERNAME%%.fw"
- ;;
- ibss)
- eval _%%DRIVERNAME%%_file_${i}="%%DRIVERNAME%%-i.fw"
- ;;
- monitor)
- eval _%%DRIVERNAME%%_file_${i}="%%DRIVERNAME%%-p.fw"
- ;;
- *)
- echo "${_mode} - Possible values for %%DRIVERNAME%%_mode_${i} are bss|ibss|monitor."
- exit 1
- ;;
- esac
-
- eval _file=\$_%%DRIVERNAME%%_file_${i}
- echo -n " [${i}:${_mode:=bss}]"
- ${command} -i ${i} -f %%FWDIR%%/${_file}
- done
- echo "."
-}
-
-%%DRIVERNAME%%_stop_cmd()
-{
- echo "Stopping %%DRIVERNAME%%."
- for i in ${%%DRIVERNAME%%_interfaces}; do
- ${command} -i ${i} -k
- done
-}
-
-run_rc_command "$1"
diff --git a/net/ipw-firmware/files/pkg-message.in b/net/ipw-firmware/files/pkg-message.in
deleted file mode 100644
index e7fc2cefa596..000000000000
--- a/net/ipw-firmware/files/pkg-message.in
+++ /dev/null
@@ -1,40 +0,0 @@
-------------------------------------------------------------------
-This port has installed following files in %%FWDIR%%:
-
- - LICENSE.%%DRIVERNAME%% : License terms,
- - %%DRIVERNAME%%-i.fw : IBSS mode (aka ad-hoc mode) firmware,
- - %%DRIVERNAME%%-p.fw : Monitor mode firmware,
- - %%DRIVERNAME%%.fw : BSS mode (aka infrastructure mode) firmware.
-
-Ensure you've read license terms carefully before you use this
-firmware.
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%%You must choose the correct image depending on how you want to
-%%DONT_NEED_CONTROL%%use your adapter.
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%%For instance, to download firmware for BSS mode:
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%% # %%DRIVERNAME%%control -i %%DRIVERNAME%%0 \
-%%DONT_NEED_CONTROL%% -f %%FWDIR%%/%%DRIVERNAME%%.fw
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%%The port has installed a startup script (%%DRIVERNAME%%.sh). Add these lines
-%%DONT_NEED_CONTROL%%to /etc/rc.conf to use it :
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%% - %%DRIVERNAME%%_enable (bool) : defaults to "NO", set it to "YES" to
-%%DONT_NEED_CONTROL%% use the startup script.
-%%DONT_NEED_CONTROL%% - %%DRIVERNAME%%_interfaces (str) : defaults to "%%DRIVERNAME%%0", override it to
-%%DONT_NEED_CONTROL%% change to interface names list (optional).
-%%DONT_NEED_CONTROL%% - %%DRIVERNAME%%_mode_<iface> (str) : defaults to "bss", possible values
-%%DONT_NEED_CONTROL%% are bss, ibss and monitor (optional).
-%%MIGHT_NEED_MODULE%%
-%%MIGHT_NEED_MODULE%%Note:
-%%MIGHT_NEED_MODULE%%
-%%MIGHT_NEED_MODULE%%This port requires %%DRIVERNAME%%(4) driver which has not been MFC'ed to
-%%MIGHT_NEED_MODULE%%RELENG_5. Point your web browser at [1] and install it by hand
-%%MIGHT_NEED_MODULE%%if not already done or rebuild the port with WITH_MODULE=yes.
-%%MIGHT_NEED_MODULE%%
-%%MIGHT_NEED_MODULE%%[1] http://damien.bergamini.free.fr/ipw/
-
-Note: You need to have a kernel compiled with "device %%DRIVERNAME%%" or "if_%%DRIVERNAME%%_load="YES"
-in /boot/loader.conf to be able to use this firmware.
-------------------------------------------------------------------
diff --git a/net/ipw-firmware/pkg-descr b/net/ipw-firmware/pkg-descr
deleted file mode 100644
index 43e4f4d2fb7f..000000000000
--- a/net/ipw-firmware/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This project was created by Intel to enable support for the Intel
-PRO/Wireless 2100 Network Connection mini PCI adapter. This project
-(IPW2100) is intended to be a community effort as much as is possible
-given some working constraints (mainly, no HW documentation is available).
-
-WWW: http://ipw2100.sourceforge.net/
diff --git a/net/ipw-firmware/pkg-plist b/net/ipw-firmware/pkg-plist
deleted file mode 100644
index fb9b8b95b78c..000000000000
--- a/net/ipw-firmware/pkg-plist
+++ /dev/null
@@ -1,11 +0,0 @@
-@cwd /
-%%WITH_CONTROL%%usr/sbin/%%DRIVERNAME%%control
-%%MTREE_DIRRM%%@exec mkdir -p %%FWDIR%%
-@cwd %%FWDIR%%
-LICENSE.%%DRIVERNAME%%
-%%DRIVERNAME%%-i.fw
-%%DRIVERNAME%%-p.fw
-%%DRIVERNAME%%.fw
-%%MTREE_DIRRM%%@unexec rmdir %%FWDIR%% 2>/dev/null || true
-%%WITH_MODULE%%@cwd /
-%%WITH_MODULE%%%%KMODDIR%%/if_%%DRIVERNAME%%.ko
diff --git a/net/ipw-firmware/pkg-req b/net/ipw-firmware/pkg-req
deleted file mode 100644
index e3696b37222f..000000000000
--- a/net/ipw-firmware/pkg-req
+++ /dev/null
@@ -1,222 +0,0 @@
-#! /bin/sh
-
-case "$2" in
-INSTALL)
- cat << EOF | more
- TERMS AND CONDITIONS
- IMPORTANT - PLEASE READ BEFORE INSTALLING OR USING THIS INTEL(C) SOFTWARE
-
-Do not use or load this firmware (the "Software") until you have carefully read
-the following terms and conditions. By loading or using the Software, you agree
-to the terms of this Agreement. If you do not wish to so agree, do not install
-or use the Software.
-
-LICENSEES:
-
-Please note:
-
-* If you are an End-User, only Exhibit A, the SOFTWARE LICENSE AGREEMENT,
- applies.
-* If you are an Original Equipment Manufacturer (OEM), Independent Hardware
- Vendor (IHV), or Independent Software Vendor (ISV), this complete Agreement
- applies
-
---------------------------------------------------------------------------------
-
-For OEMs, IHVs, and ISVs:
-
-LICENSE. This Software is licensed for use only in conjunction with Intel
-component products. Use of the Software in conjunction with non-Intel component
-products is not licensed hereunder. Subject to the terms of this Agreement,
-Intel grants to you a nonexclusive, nontransferable, worldwide, fully paid-up
-license under Intel's copyrights to: (i) copy the Software internally for your
-own development and maintenance purposes; (ii) copy and distribute the Software
-to your end-users, but only under a license agreement with terms at least as
-restrictive as those contained in Intel's Final, Single User License Agreement,
-attached as Exhibit A; and (iii) modify, copy and distribute the end-user
-documentation which may accompany the Software, but only in association with
-the Software.
-
-If you are not the final manufacturer or vendor of a computer system or software
-program incorporating the Software, then you may transfer a copy of the
-Software, including any related documentation (modified or unmodified) to your
-recipient for use in accordance with the terms of this Agreement, provided such
-recipient agrees to be fully bound by the terms hereof. You shall not otherwise
-assign, sublicense, lease, or in any other way transfer or disclose Software to
-any third party. You may not, nor may you assist any other person or entity to
-modify, translate, convert to another programming language, decompile, reverse
-engineer, or disassemble any portion of the Software or otherwise attempt to
-derive source code from any object code modules of the Software or any internal
-data files generated by the Software. Your rights to redistribute the Software
-shall be contingent upon your installation of this Agreement in its entirety in
-the same directory as the Software.
-
-CONFIDENTIALITY. If you wish to have a third party consultant or subcontractor
-("Contractor") perform work on your behalf which involves access to or use of
-Software, you shall obtain a written confidentiality agreement from the
-Contractor which contains provisions with respect to access to or use of the
-Software no less restrictive than those set forth in this Agreement and
-excluding any distribution rights, and use for any other purpose. Except as
-expressly provided herein, you shall not disclose the terms or existence of
-this Agreement or use Intel's name in any publications, advertisements, or
-other announcements without Intel's prior written consent. You do not have any
-rights to use any Intel trademarks or logos.
-
-OWNERSHIP OF SOFTWARE AND COPYRIGHTS. Software and accompanying materials, if
-any, are owned by Intel or its suppliers and licensors and may be protected by
-copyright, trademark, patent and trade secret law and international treaties.
-Any rights, express or implied, in the intellectual property embodied in the
-foregoing, other than those specified in this Agreement, are reserved by Intel
-and its suppliers and licensors or otherwise as set forth in any applicable
-open source license agreement. You will keep the Software free of liens,
-attachments, and other encumbrances. You agree not to remove any proprietary
-notices and/or any labels from the Software and accompanying materials without
-prior written approval by Intel
-
-LIMITATION OF LIABILITY. IN NO EVENT SHALL INTEL OR ITS SUPPLIERS AND LICENSORS
-BE LIABLE FOR ANY DAMAGES WHATSOEVER FROM ANY CAUSE OF ACTION OF ANY KIND
-(INCLUDING, WITHOUT LIMITATION, LOST PROFITS, BUSINESS INTERRUPTION, OR LOST
-INFORMATION) ARISING OUT OF THE USE, MODIFICATION, OR INABILITY TO USE THE
-INTEL SOFTWARE, OR OTHERWISE, NOR FOR PUNITIVE, INCIDENTAL, CONSEQUENTIAL, OR
-SPECIAL DAMAGES OF ANY KIND, EVEN IF INTEL OR ITS SUPPLIERS AND LICENSORS HAS
-BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. SOME JURISDICTIONS PROHIBIT
-EXCLUSION OR LIMITATION OF LIABILITY FOR IMPLIED WARRANTIES, CONSEQUENTIAL OR
-INCIDENTAL DAMAGES, SO CERTAIN LIMITATIONS MAY NOT APPLY. YOU MAY ALSO HAVE
-OTHER LEGAL RIGHTS THAT VARY BETWEEN JURISDICTIONS.
-
-EXCLUSION OF WARRANTIES. THE SOFTWARE IS PROVIDED "AS IS" AND POSSIBLY WITH
-FAULTS. UNLESS EXPRESSLY AGREED OTHERWISE, INTEL AND ITS SUPPLIERS AND
-LICENSORS DISCLAIM ANY AND ALL WARRANTIES AND GUARANTEES, EXPRESS, IMPLIED OR
-OTHERWISE, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-NONINFRINGEMENT, OR FITNESS FOR A PARTICULAR PURPOSE. Intel does not warrant
-or assume responsibility for the accuracy or completeness of any information,
-text, graphics, links or other items contained within the Software. You assume
-all liability, financial or otherwise, associated with Your use or disposition
-of the Software.
-
-APPLICABLE LAW. Claims arising under this Agreement shall be governed by the
-laws of State of California], excluding its principles of conflict of laws and
-the United Nations Convention on Contracts for the Sale of Goods.
-
-WAIVER AND AMENDMENT. No modification, amendment or waiver of any provision of
-this Agreement shall be effective unless in writing and signed by an officer of
-Intel. No failure or delay in exercising any right, power, or remedy under
-this Agreement shall operate as a waiver of any such right, power or remedy.
-Without limiting the foregoing, terms and conditions on any purchase orders or
-similar materials submitted by you to Intel, and any terms contained in Intel’s
-standard acknowledgment form that are in conflict with these terms, shall be of
-no force or effect.
-
-SEVERABILITY. If any provision of this Agreement is held by a court of
-competent jurisdiction to be contrary to law, such provision shall be changed
-and interpreted so as to best accomplish the objectives of the original
-provision to the fullest extent allowed by law and the remaining provisions of
-this Agreement shall remain in full force and effect.
-
-EXPORT RESTRICTIONS. Each party acknowledges that the Software is subject to
-applicable import and export regulations of the United States and of the
-countries in which each party transacts business, specifically including U.S.
-Export Administration Act and Export Administration Regulations. Each party
-shall comply with such laws and regulations, as well as all other laws and
-regulations applicable to the Software. Without limiting the generality of the
-foregoing, each party agrees that it will not export, re-export, transfer or
-divert any of the Software or the direct programs thereof to any restricted
-place or party in accordance with U.S. export regulations. Note that Software
-containing encryption may be subject to additional restrictions.
-
-GOVERNMENT RESTRICTED RIGHTS. The Software is provided with "RESTRICTED RIGHTS."
-Use, duplication, or disclosure by the Government is subject to restrictions as
-set forth in FAR52.227-14 and DFAR252.227-7013 et seq. or their successors. Use
-of the Software by the Government constitutes acknowledgment of Intel's
-proprietary rights therein. Contractor or Manufacturer is Intel Corporation,
-2200 Mission College Blvd., Santa Clara, CA 95052.
-
-TERMINATION OF THE AGREEMENT. Intel may terminate this Agreement if you violate
-its terms. Upon termination, you will immediately destroy the Software or
-return all copies of the Software to Intel.
-
---------------------------------------------------------------------------------
-
-EXHIBIT "A"
-
-SOFTWARE LICENSE AGREEMENT (Final, Single User)
-
-IMPORTANT - READ BEFORE COPYING, INSTALLING OR USING.
-
-Do not use or load this firmware image (the "Software") until you have carefully
-read the following terms and conditions. By loading or using the Software, you
-agree to the terms of this Agreement. If you do not wish to so agree, do not
-install or use the Software.
-
-LICENSE. You may copy and use the Software, subject to these conditions:
-1. This Software is licensed for use only in conjunction with Intel component
- products. Use of the Software in conjunction with non-Intel component
- products is not licensed hereunder.
-2. You may not copy, modify, rent, sell, distribute or transfer any part of the
- Software except as provided in this Agreement, and you agree to prevent
- unauthorized copying of the Software.
-3. You may not reverse engineer, decompile, or disassemble the Software.
-4. You may not sublicense the Software.
-5. The Software may contain the software or other property of third party
- suppliers.
-
-OWNERSHIP OF SOFTWARE AND COPYRIGHTS. Title to all copies of the Software
-remains with Intel or its suppliers. The Software is copyrighted and protected
-by the laws of the United States and other countries, and international treaty
-provisions. You may not remove any copyright notices from the Software. Intel
-may make changes to the Software, or items referenced therein, at any time
-without notice, but is not obligated to support or update the Software. Except
-as otherwise expressly provided, Intel grants no express or implied right under
-Intel patents, copyrights, trademarks, or other intellectual property rights.
-You may transfer the Software only if a copy of this license accompanies the
-Software and the recipient agrees to be fully bound by these terms.
-
-EXCLUSION OF OTHER WARRANTIES EXCEPT AS PROVIDED ABOVE, THE SOFTWARE IS PROVIDED
-"AS IS" WITHOUT ANY EXPRESS OR IMPLIED WARRANTY OF ANY KIND INCLUDING
-WARRANTIES OF MERCHANTABILITY, NONINFRINGEMENT, OR FITNESS FOR A PARTICULAR
-PURPOSE. Intel does not warrant or assume responsibility for the accuracy or
-completeness of any information, text, graphics, links or other items contained
-within the Software.
-
-LIMITATION OF LIABILITY. IN NO EVENT SHALL INTEL OR ITS SUPPLIERS BE LIABLE FOR
-ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, LOST PROFITS, BUSINESS
-INTERRUPTION, OR LOST INFORMATION) ARISING OUT OF THE USE OF OR INABILITY TO
-USE THE SOFTWARE, EVEN IF INTEL HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH
-DAMAGES. SOME JURISDICTIONS PROHIBIT EXCLUSION OR LIMITATION OF LIABILITY FOR
-IMPLIED WARRANTIES OR CONSEQUENTIAL OR INCIDENTAL DAMAGES, SO THE ABOVE
-LIMITATION MAY NOT APPLY TO YOU. YOU MAY ALSO HAVE OTHER LEGAL RIGHTS THAT VARY
-BETWEEN JURISDICTIONS.
-
-TERMINATION OF THIS AGREEMENT. Intel may terminate this Agreement at any time if
-you violate its terms. Upon termination, you will immediately destroy the
-Software.
-
-APPLICABLE LAWS. Claims arising under this Agreement shall be governed by the
-laws of California, excluding its principles of conflict of laws and the United
-Nations Convention on Contracts for the Sale of Goods. You may not export the
-Software in violation of applicable export laws and regulations. Intel is not
-obligated under any other agreements unless they are in writing and signed by
-an authorized representative
-of Intel.
-
-GOVERNMENT RESTRICTED RIGHTS. The Software is provided with "RESTRICTED RIGHTS."
-Use, duplication, or disclosure by the Government is subject to restrictions as
-set forth in FAR52.227-14 and DFAR252.227-7013 et seq. or their successors. Use
-of the Software by the Government constitutes acknowledgment of Intel's
-proprietary rights therein. Contractor or Manufacturer is Intel Corporation,
-2200 Mission College Blvd., Santa Clara, CA 95052.
-
-EOF
-
- echo -n "Do you agree with these terms [y/N] ? "
- read answer
-
- if [ "${answer}" != "y" -a "${answer}" != "Y" ]; then
- exit 1
- else
- exit 0
- fi
- ;;
-*)
- ;;
-esac
diff --git a/net/iwi-firmware-kmod/Makefile b/net/iwi-firmware-kmod/Makefile
deleted file mode 100644
index 2536953250fb..000000000000
--- a/net/iwi-firmware-kmod/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-# New ports collection makefile for: iwi-firmware-kmod
-# Date created: Mar 16 2006
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= iwi-firmware
-PORTREVISION= 3
-CATEGORIES= net sysutils kld
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT= Intel PRO/Wireless 2200 Firmware Kernel Module
-
-MASTERDIR= ${.CURDIR}/../ipw-firmware-kmod
-DISTINFO_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${.CURDIR}/pkg-descr
-
-DRIVERNAME= iwi
-FWVERSION= 3.0
-FWNAME= ipw2200-fw-${FWVERSION}
-FIRMWARES= ${FWNAME}/ipw2200-bss.fw:${DRIVERNAME}_bss \
- ${FWNAME}/ipw2200-ibss.fw:${DRIVERNAME}_ibss \
- ${FWNAME}/ipw2200-sniffer.fw:${DRIVERNAME}_monitor \
-
-MIN6OSVERSION= 601102
-MIN7OSVERSION= 700014
-
-.include "${MASTERDIR}/Makefile"
diff --git a/net/iwi-firmware-kmod/distinfo b/net/iwi-firmware-kmod/distinfo
deleted file mode 100644
index e472b30ada60..000000000000
--- a/net/iwi-firmware-kmod/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (ipw2200-fw-3.0.tgz) = a77e007e6f4c834899b059860182ad0440f82a776b13ec0520e1bffc6ced75ea
-SIZE (ipw2200-fw-3.0.tgz) = 269999
diff --git a/net/iwi-firmware-kmod/pkg-descr b/net/iwi-firmware-kmod/pkg-descr
deleted file mode 100644
index 23a4ef91206d..000000000000
--- a/net/iwi-firmware-kmod/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This project was created by Intel to enable support for the Intel
-PRO/Wireless 2200 Network Connection mini PCI adapter. This project
-(IPW2200) is intended to be a community effort as much as is possible
-given some working constraints (mainly, no HW documentation is available).
-
-WWW: http://ipw2200.sourceforge.net/
diff --git a/net/iwi-firmware-kmod/pkg-plist b/net/iwi-firmware-kmod/pkg-plist
deleted file mode 100644
index c84efe6c3b98..000000000000
--- a/net/iwi-firmware-kmod/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@cwd %%KMODDIR%%
-%%DRIVERNAME%%_bss.ko
-%%DRIVERNAME%%_ibss.ko
-%%DRIVERNAME%%_monitor.ko
diff --git a/net/iwi-firmware/Makefile b/net/iwi-firmware/Makefile
deleted file mode 100644
index 300a4aa9d155..000000000000
--- a/net/iwi-firmware/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-# New ports collection makefile for: iwi-firmware
-# Date created: Jun 11 2005
-# Whom: Florent Thoumie <flz@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= iwi-firmware
-RELNAME= ipw2200
-PORTVERSION= 2.4
-PORTREVISION= 8
-CATEGORIES= net sysutils kld
-
-MAINTAINER= flz@FreeBSD.org
-COMMENT= Intel PRO/Wireless 2200 Driver Firmware
-
-MASTERDIR= ${.CURDIR}/../ipw-firmware
-DISTINFO_FILE= ${.CURDIR}/distinfo
-PLIST= ${.CURDIR}/pkg-plist
-DESCR= ${.CURDIR}/pkg-descr
-FILESDIR= ${.CURDIR}/files
-
-DRIVERNAME= iwi
-DRIVERVERSION= 1.3.4
-FIRMWARES= ipw-${PORTVERSION}-boot.fw:${DRIVERNAME}-boot.fw \
- ipw-${PORTVERSION}-bss.fw:${DRIVERNAME}-bss.fw \
- ipw-${PORTVERSION}-bss_ucode.fw:${DRIVERNAME}-ucode-bss.fw \
- ipw-${PORTVERSION}-ibss.fw:${DRIVERNAME}-ibss.fw \
- ipw-${PORTVERSION}-ibss_ucode.fw:${DRIVERNAME}-ucode-ibss.fw \
- ipw-${PORTVERSION}-sniffer.fw:${DRIVERNAME}-sniffer.fw \
- ipw-${PORTVERSION}-sniffer_ucode.fw:${DRIVERNAME}-ucode-sniffer.fw
-
-MIN7OSVERSION= 700006
-MAX6OSVERSION= 602105
-
-.include "${MASTERDIR}/Makefile"
diff --git a/net/iwi-firmware/distinfo b/net/iwi-firmware/distinfo
deleted file mode 100644
index c502c2422388..000000000000
--- a/net/iwi-firmware/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (ipw2200-fw-2.4.tgz) = bdf882541b1deb52ebd4eac846367d32f8a4c8f76d3c2795a09e5f256a6d6b7b
-SIZE (ipw2200-fw-2.4.tgz) = 270419
-SHA256 (iwi-freebsd-1.3.4.tgz) = 8f03b7c25e709ebe6795ac8534a1a75042a7221614b5942ebd5493da80f298b5
-SIZE (iwi-freebsd-1.3.4.tgz) = 22272
diff --git a/net/iwi-firmware/files/iwi.sh.in b/net/iwi-firmware/files/iwi.sh.in
deleted file mode 100644
index 5de1210e9c24..000000000000
--- a/net/iwi-firmware/files/iwi.sh.in
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: %%DRIVERNAME%%
-# REQUIRE: mountcritlocal
-# BEFORE: ipfilter
-# KEYWORD: shutdown
-
-# Add the following line to /etc/rc.conf to enable `%%DRIVERNAME%%':
-#
-# %%DRIVERNAME%%_enable="YES"
-#
-
-. /etc/rc.subr
-
-name="%%DRIVERNAME%%"
-rcvar=%%DRIVERNAME%%_enable
-
-start_cmd="%%DRIVERNAME%%_start_cmd"
-stop_cmd="%%DRIVERNAME%%_stop_cmd"
-
-load_rc_config "$name"
-: ${%%DRIVERNAME%%_enable="NO"}
-: ${%%DRIVERNAME%%_interfaces="%%DRIVERNAME%%0"}
-
-command="%%PREFIX%%/sbin/%%DRIVERNAME%%control"
-
-%%DRIVERNAME%%_start_cmd()
-{
- echo -n "Starting %%DRIVERNAME%%"
- for i in ${%%DRIVERNAME%%_interfaces}; do
- eval _mode=\$%%DRIVERNAME%%_mode_${i}
- case ${_mode} in
- ""|bss|ibss|sniffer)
- ;;
- *)
- echo "${_mode} - Possible values for %%DRIVERNAME%%_mode_${i} are bss|ibss|sniffer."
- exit 1
- ;;
- esac
-
- eval _mode=\$_%%DRIVERNAME%%_file_${i}
- echo -n " [${i}:${_mode:=bss}]"
- ${command} -i ${i} -d %%FWDIR%% -m ${_mode:=bss}
- done
- echo "."
-}
-
-%%DRIVERNAME%%_stop_cmd()
-{
- echo "Stopping %%DRIVERNAME%%."
- for i in ${%%DRIVERNAME%%_interfaces}; do
- ${command} -i ${i} -k
- done
-}
-
-run_rc_command "$1"
diff --git a/net/iwi-firmware/files/pkg-message.in b/net/iwi-firmware/files/pkg-message.in
deleted file mode 100644
index edb6bd72d1ae..000000000000
--- a/net/iwi-firmware/files/pkg-message.in
+++ /dev/null
@@ -1,40 +0,0 @@
-------------------------------------------------------------------
-This port has installed following files in %%FWDIR%%:
-
- - LICENSE.%%DRIVERNAME%% : License terms,
- - %%DRIVERNAME%%-boot.fw : Boot mode firmware,
- - %%DRIVERNAME%%-bss.fw : BSS mode firmware,
- - %%DRIVERNAME%%-ucode-bss.fw : BSS mode micro-code,
- - %%DRIVERNAME%%-ibss.fw : IBSS mode firmware,
- - %%DRIVERNAME%%-ucode-ibss.fw : IBSS mode micro-code,
- - %%DRIVERNAME%%-sniffer.fw : Sniffer mode firmware,
- - %%DRIVERNAME%%-ucode-sniffer.fw : Sniffer mode micro-code.
-
-Ensure you've read license terms carefully before you use this
-firmware.
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%%You must choose the correct mode depending on how you want to
-%%DONT_NEED_CONTROL%%use your adapter.
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%%For instance, to download firmware for BSS mode:
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%% # %%DRIVERNAME%%control -i %%DRIVERNAME%%0 -d %%FWDIR%% -m bss
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%%The port has installed a startup script (%%DRIVERNAME%%.sh). Add these lines
-%%DONT_NEED_CONTROL%%to /etc/rc.conf to use it :
-%%DONT_NEED_CONTROL%%
-%%DONT_NEED_CONTROL%% - %%DRIVERNAME%%_enable (bool) : defaults to "NO", set it to "YES" to
-%%DONT_NEED_CONTROL%% use the startup script.
-%%DONT_NEED_CONTROL%% - %%DRIVERNAME%%_interfaces (str) : defaults to "%%DRIVERNAME%%0", override it to
-%%DONT_NEED_CONTROL%% change to interface names list (optional).
-%%DONT_NEED_CONTROL%% - %%DRIVERNAME%%_mode_<iface> (str) : defaults to "bss", possible values
-%%DONT_NEED_CONTROL%% are bss, ibss and sniffer (optional).
-%%MIGHT_NEED_MODULE%%
-%%MIGHT_NEED_MODULE%%Note:
-%%MIGHT_NEED_MODULE%%
-%%MIGHT_NEED_MODULE%%This port requires %%DRIVERNAME%%(4) driver which has not been MFC'ed to
-%%MIGHT_NEED_MODULE%%RELENG_5. Point your web browser at [1] and install it by hand
-%%MIGHT_NEED_MODULE%%if not already done or rebuild the port with WITH_MODULE=yes.
-%%MIGHT_NEED_MODULE%%
-%%MIGHT_NEED_MODULE%%[1] http://damien.bergamini.free.fr/ipw/
-------------------------------------------------------------------
diff --git a/net/iwi-firmware/pkg-descr b/net/iwi-firmware/pkg-descr
deleted file mode 100644
index 23a4ef91206d..000000000000
--- a/net/iwi-firmware/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-This project was created by Intel to enable support for the Intel
-PRO/Wireless 2200 Network Connection mini PCI adapter. This project
-(IPW2200) is intended to be a community effort as much as is possible
-given some working constraints (mainly, no HW documentation is available).
-
-WWW: http://ipw2200.sourceforge.net/
diff --git a/net/iwi-firmware/pkg-plist b/net/iwi-firmware/pkg-plist
deleted file mode 100644
index 5ab2c606c2fb..000000000000
--- a/net/iwi-firmware/pkg-plist
+++ /dev/null
@@ -1,15 +0,0 @@
-@cwd /
-%%WITH_CONTROL%%usr/sbin/%%DRIVERNAME%%control
-%%MTREE_DIRRM%%@exec mkdir -p %%FWDIR%%
-@cwd %%FWDIR%%
-LICENSE.%%DRIVERNAME%%
-%%DRIVERNAME%%-boot.fw
-%%DRIVERNAME%%-bss.fw
-%%DRIVERNAME%%-ucode-bss.fw
-%%DRIVERNAME%%-ibss.fw
-%%DRIVERNAME%%-ucode-ibss.fw
-%%DRIVERNAME%%-sniffer.fw
-%%DRIVERNAME%%-ucode-sniffer.fw
-%%MTREE_DIRRM%%@unexec rmdir %%FWDIR%% 2>/dev/null || true
-%%WITH_MODULE%%@cwd /
-%%WITH_MODULE%%%%KMODDIR%%/if_%%DRIVERNAME%%.ko