aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/devmon/Makefile2
-rw-r--r--net-mgmt/kismet/Makefile2
-rw-r--r--net-mgmt/nagios-check_email_delivery/Makefile2
-rw-r--r--net-mgmt/net-snmp/Makefile2
-rw-r--r--net-mgmt/phpweathermap/Makefile6
-rw-r--r--net-mgmt/spectools/Makefile2
-rw-r--r--net-mgmt/weathermap/Makefile6
-rw-r--r--net-mgmt/weathermap/pkg-plist14
8 files changed, 20 insertions, 16 deletions
diff --git a/net-mgmt/devmon/Makefile b/net-mgmt/devmon/Makefile
index 2576ac21b9a9..708feb8a525e 100644
--- a/net-mgmt/devmon/Makefile
+++ b/net-mgmt/devmon/Makefile
@@ -25,7 +25,7 @@ GROUPS= devmon
SUB_LIST= USERS=${USERS} \
GROUPS=${GROUPS}
-OPTIONS_DEFINE= MYSQL
+OPTIONS_DEFINE= MYSQL DOCS
REINPLACE_ARGS= -i ''
diff --git a/net-mgmt/kismet/Makefile b/net-mgmt/kismet/Makefile
index 84fd58417c2c..98249db5feaf 100644
--- a/net-mgmt/kismet/Makefile
+++ b/net-mgmt/kismet/Makefile
@@ -21,7 +21,7 @@ USES= gmake tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= PCRE PLUGINS SETUID
+OPTIONS_DEFINE= PCRE PLUGINS SETUID DOCS EXAMPLES
OPTIONS_DEFAULT= PCRE PLUGINS SETUID
SETUID_DESC= Use privilege separation
diff --git a/net-mgmt/nagios-check_email_delivery/Makefile b/net-mgmt/nagios-check_email_delivery/Makefile
index f4688b560799..cf389e3559fd 100644
--- a/net-mgmt/nagios-check_email_delivery/Makefile
+++ b/net-mgmt/nagios-check_email_delivery/Makefile
@@ -35,6 +35,8 @@ DOC_FILES= check_email_delivery.html check_email_delivery.pod \
PORTSCOUT= ignore:1
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
do-install:
diff --git a/net-mgmt/net-snmp/Makefile b/net-mgmt/net-snmp/Makefile
index bf67673b1293..90f30306caf1 100644
--- a/net-mgmt/net-snmp/Makefile
+++ b/net-mgmt/net-snmp/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libpkg.so:${PORTSDIR}/ports-mgmt/pkg
.endif
OPTIONS_DEFINE= IPV6 MFD_REWRITES PERL PERL_EMBEDDED PYTHON DUMMY TKMIB \
- DMALLOC MYSQL AX_SOCKONLY UNPRIVILEGED SMUX
+ DMALLOC MYSQL AX_SOCKONLY UNPRIVILEGED SMUX DOCS
OPTIONS_DEFAULT=IPV6 PERL PERL_EMBEDDED DUMMY SMUX
MFD_REWRITES_DESC= Build with 64-bit Interface Counters
diff --git a/net-mgmt/phpweathermap/Makefile b/net-mgmt/phpweathermap/Makefile
index df44b30b2ed2..d5b9e91dee72 100644
--- a/net-mgmt/phpweathermap/Makefile
+++ b/net-mgmt/phpweathermap/Makefile
@@ -34,7 +34,9 @@ WRKSRC= ${WRKDIR}/weathermap
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
post-patch:
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' ${WRKSRC}/editor.php
${REINPLACE_CMD} -e 's|%%DATADIR%%|${DATADIR}|g' \
@@ -66,4 +68,4 @@ post-install:
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 461aaae01da8..b472fbdc6f87 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -22,7 +22,7 @@ USES= gmake pkgconfig
PORTDOCS= README
-OPTIONS_DEFINE= GTK2 NCURSES
+OPTIONS_DEFINE= GTK2 NCURSES DOCS
OPTIONS_DEFAULT= GTK2 NCURSES
ALL_TARGET= spectool_net spectool_raw
diff --git a/net-mgmt/weathermap/Makefile b/net-mgmt/weathermap/Makefile
index 7272fbd85b4d..52e04862484c 100644
--- a/net-mgmt/weathermap/Makefile
+++ b/net-mgmt/weathermap/Makefile
@@ -18,7 +18,7 @@ USES= perl5 shebangfix
NO_BUILD= yes
SHEBANG_FILES= weathermap
-OPTIONS_DEFINE= WGET
+OPTIONS_DEFINE= WGET DOCS EXAMPLES
WGET_DESC= WGET support
PORTDOCS= README LICENSE INSTALL
@@ -28,7 +28,7 @@ CONFIGURE_ARGS= --with-gd-lib=${LOCALBASE}/lib \
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MWGET}
RUN_DEPENDS+= wget:${PORTSDIR}/ftp/wget
@@ -50,4 +50,4 @@ do-install:
cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/weathermap/pkg-plist b/net-mgmt/weathermap/pkg-plist
index 306504b816a9..2b095e04b53b 100644
--- a/net-mgmt/weathermap/pkg-plist
+++ b/net-mgmt/weathermap/pkg-plist
@@ -1,10 +1,10 @@
bin/weathermap
-%%EXAMPLESDIR%%/weathermap.conf
-%%EXAMPLESDIR%%/weathermap.html
-%%EXAMPLESDIR%%/weathermap.png
-%%EXAMPLESDIR%%/overlib_mini.js
-%%EXAMPLESDIR%%/weathermap-background.png
-%%EXAMPLESDIR%%/weathermap-overlib.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weathermap.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weathermap.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weathermap.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/overlib_mini.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weathermap-background.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/weathermap-overlib.html
@sample etc/weathermap/weathermap.conf.sample
@dirrmtry etc/weathermap
-@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%