aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/Makefile1
-rw-r--r--astro/py-horoscopegenerator/Makefile22
-rw-r--r--astro/py-horoscopegenerator/distinfo3
-rw-r--r--astro/py-horoscopegenerator/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 7483cf4cf132..358e3e61e9a8 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -82,6 +82,7 @@
SUBDIR += py-aipy
SUBDIR += py-astLib
SUBDIR += py-astropy
+ SUBDIR += py-horoscopegenerator
SUBDIR += py-pyfits
SUBDIR += py-pymetar
SUBDIR += py-pywapi
diff --git a/astro/py-horoscopegenerator/Makefile b/astro/py-horoscopegenerator/Makefile
new file mode 100644
index 000000000000..16c7ee1c8afe
--- /dev/null
+++ b/astro/py-horoscopegenerator/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= horoscopegenerator
+PORTVERSION= 0.1.8
+CATEGORIES= astro python
+MASTER_SITES= CHEESESHOP
+DISTNAME= ${PORTNAME:S/h/H/:S/g/G/}-${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= kevlo@FreeBSD.org
+COMMENT= Generate horoscopes using context-free grammar
+
+LICENSE= MIT
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=0:devel/py-six \
+ ${PYTHON_PKGNAMEPREFIX}nltk>0:textproc/py-nltk
+
+.include <bsd.port.mk>
diff --git a/astro/py-horoscopegenerator/distinfo b/astro/py-horoscopegenerator/distinfo
new file mode 100644
index 000000000000..a2db3877e91b
--- /dev/null
+++ b/astro/py-horoscopegenerator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1470381700
+SHA256 (HoroscopeGenerator-0.1.8.tar.gz) = 96b9f577f7024d131bd3a080a2e177494fa41a36d803bd5f0ec21133bad90073
+SIZE (HoroscopeGenerator-0.1.8.tar.gz) = 6443
diff --git a/astro/py-horoscopegenerator/pkg-descr b/astro/py-horoscopegenerator/pkg-descr
new file mode 100644
index 000000000000..6a015eee6b5a
--- /dev/null
+++ b/astro/py-horoscopegenerator/pkg-descr
@@ -0,0 +1,4 @@
+The HoroscopeGenerator produces horoscopes on demand using context-free
+grammar.
+
+WWW: https://github.com/mouse-reeve/horoscope-generator