aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--ports-mgmt/pkg/Makefile15
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/pkg-plist10
3 files changed, 17 insertions, 12 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 36941bfc1af0..aec467d81aa3 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= pkg
-DISTVERSION= 1.0-beta8
+DISTVERSION= 1.0-beta9
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/
@@ -16,7 +16,7 @@ COMMENT= New generation package manager
LICENSE= BSD
-USE_BZIP2= yes
+USE_XZ= yes
USE_LDCONFIG= yes
MANCOMPRESSED= yes
@@ -43,14 +43,6 @@ MAN8= pkg.8 \
pkg-which.8
MAN5= pkg.conf.5
-PLIST_FILES= sbin/pkg \
- sbin/pkg-static \
- sbin/pkg2ng \
- include/pkg.h \
- lib/libpkg.so.0 \
- lib/libpkg.so \
- lib/libpkg.a
-
.include <bsd.port.pre.mk>
#define PKG_DEPENDS to nothing to avoid infinite loop looking for pkg :)
@@ -67,6 +59,9 @@ IGNORE= not supported on 7.x or early 8.0
.endif
post-install:
+ @${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|g' ${WRKSRC}/scripts/periodic/410.pkg-audit
+ @${MKDIR} ${PREFIX}/etc/periodic/security
+ @${INSTALL_SCRIPT} ${WRKSRC}/scripts/periodic/410.pkg-audit ${PREFIX}/etc/periodic/security
@${INSTALL_SCRIPT} ${WRKSRC}/ports/pkg2ng ${PREFIX}/sbin
@${CAT} ${PKGMESSAGE}
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index 493581718782..44e4676de44b 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.0-beta8.tar.bz2) = 3b772dcdb99af385e54ed5a4bbca631ae54e005c3c6d5afeda03119c367d6860
-SIZE (pkg-1.0-beta8.tar.bz2) = 1477364
+SHA256 (pkg-1.0-beta9.tar.xz) = acf1e8db9a0921009f0fdec0365b76f823b0483fabf2c2eeed4015c21955588f
+SIZE (pkg-1.0-beta9.tar.xz) = 1298464
diff --git a/ports-mgmt/pkg/pkg-plist b/ports-mgmt/pkg/pkg-plist
new file mode 100644
index 000000000000..07132dc2ebfe
--- /dev/null
+++ b/ports-mgmt/pkg/pkg-plist
@@ -0,0 +1,10 @@
+sbin/pkg
+sbin/pkg-static
+sbin/pkg2ng
+include/pkg.h
+lib/libpkg.so.0
+lib/libpkg.so
+lib/libpkg.a
+etc/periodic/security/410.pkg-audit
+@dirrmtry etc/periodic/security
+@dirrmtry etc/periodic