aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--astro/roadmap/Makefile2
-rw-r--r--audio/gmixer/Makefile7
-rw-r--r--audio/nekobee/Makefile1
-rw-r--r--audio/trommler/Makefile2
-rw-r--r--comms/xnecview/Makefile7
-rw-r--r--emulators/bochs/Makefile2
-rw-r--r--emulators/uae/Makefile2
-rw-r--r--games/qtads/Makefile2
-rw-r--r--games/senken/Makefile6
-rw-r--r--graphics/mypaint/Makefile2
-rw-r--r--graphics/pho/Makefile2
-rw-r--r--graphics/pqiv/Makefile1
-rw-r--r--graphics/qiv/Makefile2
-rw-r--r--graphics/xzgv/Makefile8
-rw-r--r--math/ump/Makefile8
-rw-r--r--multimedia/quark/Makefile3
-rw-r--r--net/sobby/Makefile7
-rw-r--r--print/qpdfview/Makefile1
-rw-r--r--science/g3data/Makefile7
-rw-r--r--science/v_sim/Makefile2
-rw-r--r--security/putty/Makefile2
-rw-r--r--sysutils/thefish/Makefile1
-rw-r--r--textproc/ibus-qt/Makefile2
-rw-r--r--x11-clocks/wmtimer/Makefile2
-rw-r--r--x11-toolkits/pure-gtk/Makefile1
-rw-r--r--x11/wmctrl/Makefile7
-rw-r--r--x11/yalias/Makefile7
27 files changed, 36 insertions, 60 deletions
diff --git a/astro/roadmap/Makefile b/astro/roadmap/Makefile
index e466a4e42938..6be3466bbba9 100644
--- a/astro/roadmap/Makefile
+++ b/astro/roadmap/Makefile
@@ -19,7 +19,7 @@ INSTALL_WRKSRC= ${WRKSRC}/src
MAKE_JOBS_UNSAFE= yes
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= gtk20
MAKE_ARGS= INSTALLDIR="${PREFIX}" CC="${CC}" CXX="${CXX}"
diff --git a/audio/gmixer/Makefile b/audio/gmixer/Makefile
index 4b831f77c978..edb30a69b21d 100644
--- a/audio/gmixer/Makefile
+++ b/audio/gmixer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gmixer
-# Date created: 25 February 1999
-# Whom: Chris Piazza <cpiazza@FreeBSD.org>
-#
+# Created by: Chris Piazza <cpiazza@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gmixer
PORTVERSION= 0.98c
@@ -17,6 +13,7 @@ COMMENT= X11/gtk+ mixer control
ALL_TARGET= gmixer
+USES= pkgconfig
USE_GNOME= gtk12
PLIST_FILES= bin/gmixer share/pixmaps/gmixer.xpm
diff --git a/audio/nekobee/Makefile b/audio/nekobee/Makefile
index ec2256282baf..95f9edea90d8 100644
--- a/audio/nekobee/Makefile
+++ b/audio/nekobee/Makefile
@@ -21,6 +21,7 @@ USE_GITHUB= yes
GH_ACCOUNT= gordonjcp
GH_COMMIT= 3f4737f
+USES= pkgconfig
USE_GNOME= gtk20
CPPFLAGS+= -I${LOCALBASE}/include/dssi -I${LOCALBASE}/include
diff --git a/audio/trommler/Makefile b/audio/trommler/Makefile
index 19c3318b3dd1..839911125843 100644
--- a/audio/trommler/Makefile
+++ b/audio/trommler/Makefile
@@ -13,7 +13,7 @@ COMMENT= GTK+2 based drum machine
LICENSE= GPLv2
-USES= gmake
+USES= gmake pkgconfig
USE_GNOME= gtk20
WRKSRC= ${WRKDIR}/Trommler
diff --git a/comms/xnecview/Makefile b/comms/xnecview/Makefile
index 11d2a8a31dea..a3542551727b 100644
--- a/comms/xnecview/Makefile
+++ b/comms/xnecview/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: xnecview
-# Date created: 2006-03-18
-# Whom: Søren Straarup <xride@x12.dk>
-#
+# Created by: Søren Straarup <xride@x12.dk>
# $FreeBSD$
PORTNAME= xnecview
@@ -17,8 +14,8 @@ COMMENT= A X viewer of nec2c data
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
RUN_DEPENDS= nec2c:${PORTSDIR}/comms/nec2c
+USES= gmake pkgconfig
USE_GNOME= gtk20
-USE_GMAKE= yes
MAN1= xnecview.1
PLIST_FILES= bin/xnecview
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index 13eaf99a9030..3d60c321ac7e 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -74,7 +74,7 @@ VMX_DESC= Enable Virtialization extensions
VOODOO_DESC= Enable 3dfx Voodoo Graphics emulation
X86_64_DESC= Enable x86-64 instructions support
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= ac_cv_header_alsa_asoundlib_h=no
CONFIGURE_ARGS= --disable-docbook --disable-instrumentation
diff --git a/emulators/uae/Makefile b/emulators/uae/Makefile
index 7b22aaf1b8ab..148125845dee 100644
--- a/emulators/uae/Makefile
+++ b/emulators/uae/Makefile
@@ -15,7 +15,7 @@ LICENSE= GPLv2
CONFLICTS= e-uae-[0-9]*
USE_BZIP2= yes
-USES= gmake
+USES= gmake pkgconfig
USE_AUTOTOOLS= autoconf
CONFIGURE_ARGS= --enable-sound
USE_GNOME= gtk20
diff --git a/games/qtads/Makefile b/games/qtads/Makefile
index 48d90dd3f9b2..a6b216bc3151 100644
--- a/games/qtads/Makefile
+++ b/games/qtads/Makefile
@@ -11,8 +11,8 @@ COMMENT= Cross-platform multimedia interpreter for TADS games
LICENSE= GPLv2
+USES= gmake pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
USE_QT4= gui moc_build network qmake_build rcc_build uic_build
USE_SDL= sdl mixer sound
diff --git a/games/senken/Makefile b/games/senken/Makefile
index a2da624265bc..cdfa6dc204bd 100644
--- a/games/senken/Makefile
+++ b/games/senken/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: senken
-# Date created: 15 January 2003
-# Whom: tmartin@andrew.cmu.edu
-#
+# Created by: tmartin@andrew.cmu.edu
# $FreeBSD$
PORTNAME= senken
@@ -14,6 +11,7 @@ MASTER_SITE_SUBDIR= distfiles
MAINTAINER= ports@FreeBSD.org
COMMENT= A city simulation game
+USES= pkgconfig
USE_GNOME= gtk20
USE_SDL= image sdl
GNU_CONFIGURE= yes
diff --git a/graphics/mypaint/Makefile b/graphics/mypaint/Makefile
index d4837b20d36f..200da39db4a2 100644
--- a/graphics/mypaint/Makefile
+++ b/graphics/mypaint/Makefile
@@ -24,7 +24,7 @@ USE_GNOME= glib20 pygtk2
USE_PYTHON= yes
USE_SCONS= yes
SCONS_ARGS= prefix="${PREFIX}"
-USES= gettext
+USES= gettext pkgconfig
INSTALLS_ICONS= yes
SUB_FILES= pkg-install
diff --git a/graphics/pho/Makefile b/graphics/pho/Makefile
index 0ba9edc3a908..83d942b08ab9 100644
--- a/graphics/pho/Makefile
+++ b/graphics/pho/Makefile
@@ -11,7 +11,7 @@ COMMENT= Lightweight image viewer
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gtk20
MAKE_ARGS= INSTALLPREFIX="${PREFIX}"
ALL_TARGET= ${PORTNAME}
diff --git a/graphics/pqiv/Makefile b/graphics/pqiv/Makefile
index 6626525fb1a6..5231d9ba3955 100644
--- a/graphics/pqiv/Makefile
+++ b/graphics/pqiv/Makefile
@@ -27,6 +27,7 @@ GH_ACCOUNT= phillipberndt
WRKSRC= ${WRKDIR}/${DISTNAME}
+USES= pkgconfig
USE_BZIP2= yes
USE_GNOME= gtk20
USE_CSTD= gnu89
diff --git a/graphics/qiv/Makefile b/graphics/qiv/Makefile
index 39031ac8fa19..2c6deb19af0f 100644
--- a/graphics/qiv/Makefile
+++ b/graphics/qiv/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= Imlib2.5:${PORTSDIR}/graphics/imlib2
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake pkgconfig
USE_GNOME= gtk20
diff --git a/graphics/xzgv/Makefile b/graphics/xzgv/Makefile
index b341ff994fa0..ac46e5d303a3 100644
--- a/graphics/xzgv/Makefile
+++ b/graphics/xzgv/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: xzgv
-# Date created: 7 Oct 2000
-# Whom: Norio Suzuki <nosuzuki@e-mail.ne.jp>
-#
+# Created by: Norio Suzuki <nosuzuki@e-mail.ne.jp>
# $FreeBSD$
-#
PORTNAME= xzgv
PORTVERSION= 0.9
@@ -16,8 +12,8 @@ COMMENT= An image viewer with thumbnail-based file selector for X
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
+USES= gmake pkgconfig
USE_GNOME= imlib gdkpixbuf gtk20
-USE_GMAKE= yes
MAN1= xzgv.1
PLIST_FILES= bin/xzgv
diff --git a/math/ump/Makefile b/math/ump/Makefile
index a8ca210c283f..af805bc29d63 100644
--- a/math/ump/Makefile
+++ b/math/ump/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ump
-# Date created: 2006-04-20
-# Whom: Nicola Vitale <nivit@email.it>
-#
+# Created by: Nicola Vitale <nivit@email.it>
# $FreeBSD$
-#
PORTNAME= ump
PORTVERSION= 0.8.6
@@ -17,8 +13,8 @@ COMMENT= A graphical, easy to use math program
CONFLICTS= ump-1.[0-9]*
LATEST_LINK= math-ump
+USES= gmake pkgconfig
USE_BZIP2= yes
-USE_GMAKE= yes
USE_GNOME= gtk20
USE_GL= glu
diff --git a/multimedia/quark/Makefile b/multimedia/quark/Makefile
index 519c0cb73c3c..50d5ce5d1440 100644
--- a/multimedia/quark/Makefile
+++ b/multimedia/quark/Makefile
@@ -15,9 +15,8 @@ LIB_DEPENDS= xine.2:${PORTSDIR}/multimedia/libxine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= pathfix gettext
+USES= pathfix gettext gmake pkgconfig
USE_GNOME= gnomeprefix gnomevfs2
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/net/sobby/Makefile b/net/sobby/Makefile
index 9ef4e99c3aac..fb5e79569ed5 100644
--- a/net/sobby/Makefile
+++ b/net/sobby/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: sobby
-# Date created: 2005-10-14
-# Whom: Andreas Kohn <andreas@syndrom23.de>
-#
+# Created by: Andreas Kohn <andreas@syndrom23.de>
# $FreeBSD$
-#
PORTNAME= sobby
PORTVERSION= 0.4.8
@@ -22,6 +18,7 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
xml++-2.6.2:${PORTSDIR}/textproc/libxml++26 \
glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+USES= pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-zeroconf
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 8bc73e030d76..241fdc7d0d0f 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -14,6 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= poppler-qt4:${PORTSDIR}/graphics/poppler-qt4 \
cups:${PORTSDIR}/print/cups-client
+USES= pkgconfig
USE_QT4= corelib dbus gui imageformats linguist_build moc_build \
qmake_build rcc_build sql sql-sqlite3_run svg xml
QMAKEFLAGS+= QMAKE_CFLAGS_RELEASE="" QMAKE_CXXFLAGS_RELEASE=""
diff --git a/science/g3data/Makefile b/science/g3data/Makefile
index a813be978c93..6a41401132b1 100644
--- a/science/g3data/Makefile
+++ b/science/g3data/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: g3data
-# Date created: 2006-09-15
-# Whom: trasz <trasz@pin.if.uz.zgora.pl>
-#
+# Created by: trasz <trasz@pin.if.uz.zgora.pl>
# $FreeBSD$
-#
PORTNAME= g3data
PORTVERSION= 1.5.3
@@ -18,6 +14,7 @@ BUILD_DEPENDS= nsgmls:${PORTSDIR}/textproc/jade \
${LOCALBASE}/share/sgml/docbook/utils-0.6.14/helpers/docbook2man-spec.pl:${PORTSDIR}/textproc/docbook-utils \
${LOCALBASE}/share/sgml/docbook/4.1/dtd/docbook.dtd:${PORTSDIR}/textproc/docbook-410
+USES= pkgconfig
USE_GNOME= gtk20
ALL_TARGET=
MAN1= g3data.1
diff --git a/science/v_sim/Makefile b/science/v_sim/Makefile
index cc9b6d35cee9..487df9a2d5d3 100644
--- a/science/v_sim/Makefile
+++ b/science/v_sim/Makefile
@@ -17,11 +17,11 @@ LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
+USES= gmake pkgconfig
USE_BZIP2= yes
USE_FORTRAN= yes
USE_GNOME= gtk20
USE_GL= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc
CPPFLAGS+= ${CFLAGS} -I${LOCALBASE}/include
diff --git a/security/putty/Makefile b/security/putty/Makefile
index 123ed2f3396a..cf36ef60ef4c 100644
--- a/security/putty/Makefile
+++ b/security/putty/Makefile
@@ -12,7 +12,7 @@ MASTER_SITE_SUBDIR= ${PORTVERSION}
MAINTAINER= mandree@FreeBSD.org
COMMENT= Secure shell and telnet client
-USE_GMAKE= yes
+USES= gmake pkgconfig
WRKSRC= ${WRKDIR}/${DISTNAME}/unix
MAKEFILE= Makefile.gtk
diff --git a/sysutils/thefish/Makefile b/sysutils/thefish/Makefile
index a97647837cf6..761c603db0b9 100644
--- a/sysutils/thefish/Makefile
+++ b/sysutils/thefish/Makefile
@@ -11,6 +11,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Gtk+/ncurses rc.conf editor/management tool
+USES= pkgconfig
WANT_GNOME= yes
#OPTIONS_SINGLE= X11
diff --git a/textproc/ibus-qt/Makefile b/textproc/ibus-qt/Makefile
index 63c97c6f88bf..4ede6f660bc9 100644
--- a/textproc/ibus-qt/Makefile
+++ b/textproc/ibus-qt/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ibus-1.0.pc:${PORTSDIR}/textproc/ibu
${LOCALBASE}/bin/icu-config:${PORTSDIR}/devel/icu
USE_QT4= gui dbus moc_build qmake_build moc_build uic_build rcc_build
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DDOCDIR=${PREFIX}/share/doc/ibus-qt
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-clocks/wmtimer/Makefile b/x11-clocks/wmtimer/Makefile
index 7d0620140800..1013bc1f1d7f 100644
--- a/x11-clocks/wmtimer/Makefile
+++ b/x11-clocks/wmtimer/Makefile
@@ -15,7 +15,7 @@ COMMENT= Multi-Function timer dockapp for WindowMaker
WRKSRC= ${WRKDIR}/${DISTNAME}/wmtimer
PORTDOCS= README
PLIST_FILES= bin/wmtimer
-USES= gmake
+USES= gmake pkgconfig
USE_CSTD= gnu89
USE_XORG= x11 xau xcomposite xcursor xdamage xdmcp xext xfixes xi \
xinerama xpm xrandr xrender
diff --git a/x11-toolkits/pure-gtk/Makefile b/x11-toolkits/pure-gtk/Makefile
index 53ec02fe0839..7511540660d2 100644
--- a/x11-toolkits/pure-gtk/Makefile
+++ b/x11-toolkits/pure-gtk/Makefile
@@ -10,6 +10,7 @@ COMMENT= A set of Pure language bindings for GTK+
LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
+USES= pkgconfig
USE_PURE= ffi
USE_GNOME= glib20 gtk20 atk pango
diff --git a/x11/wmctrl/Makefile b/x11/wmctrl/Makefile
index b0e00ddf55e3..8defe28bcb1e 100644
--- a/x11/wmctrl/Makefile
+++ b/x11/wmctrl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wmctrl
-# Date created: Feb 10 2004
-# Whom: Florent Thoumie <flz@xbsd.org>
-#
+# Created by: Florent Thoumie <flz@xbsd.org>
# $FreeBSD$
-#
PORTNAME= wmctrl
PORTVERSION= 1.07
@@ -14,6 +10,7 @@ MASTER_SITES= http://sweb.cz/tripie/utils/wmctrl/dist/
MAINTAINER= flz@FreeBSD.org
COMMENT= Command line tool to interact with an EWMH/NetWM compatible X managers
+USES= pkgconfig
GNU_CONFIGURE= yes
USE_XORG= x11 xmu xext xt
USE_GNOME= glib20
diff --git a/x11/yalias/Makefile b/x11/yalias/Makefile
index 27c1f8174586..bf2c700c0c6c 100644
--- a/x11/yalias/Makefile
+++ b/x11/yalias/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: yalias
-# Date created: 8 September 2003
-# Whom: Tim Bishop <tim@bishnet.net>
-#
+# Created by: Tim Bishop <tim@bishnet.net>
# $FreeBSD$
-#
PORTNAME= yalias
PORTVERSION= 0.7
@@ -16,6 +12,7 @@ MASTER_SITES= http://offog.org/files/ \
MAINTAINER= tdb@FreeBSD.org
COMMENT= An enhanced execution box with regex pattern matching
+USES= pkgconfig
USE_GNOME= gtk20
ALL_TARGET= yalias