aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/munin-master/Makefile2
-rw-r--r--sysutils/munin-master/files/patch-master-__bin-munin-check.in20
2 files changed, 21 insertions, 1 deletions
diff --git a/sysutils/munin-master/Makefile b/sysutils/munin-master/Makefile
index 47049db20b0c..5be36e0dd63b 100644
--- a/sysutils/munin-master/Makefile
+++ b/sysutils/munin-master/Makefile
@@ -7,7 +7,7 @@
PORTNAME= munin
PORTVERSION= 1.4.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils perl5
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION}
PKGNAMESUFFIX= -master
diff --git a/sysutils/munin-master/files/patch-master-__bin-munin-check.in b/sysutils/munin-master/files/patch-master-__bin-munin-check.in
new file mode 100644
index 000000000000..9dc12e7bf20f
--- /dev/null
+++ b/sysutils/munin-master/files/patch-master-__bin-munin-check.in
@@ -0,0 +1,20 @@
+--- master/_bin/munin-check.in.orig 2009-12-29 17:03:49.000000000 +0100
++++ master/_bin/munin-check.in 2010-12-02 23:48:25.854543201 +0100
+@@ -78,7 +78,7 @@
+ object=$1; shift || exit 1
+ correctowner=$1; shift || exit 1
+
+- owner=$(stat -c%U $object)
++ owner=$(stat -f%Su $object)
+ if [ "$owner" != "$correctowner" ]; then
+ echo "# $object : Wrong owner ($owner != $correctowner)";
+ if [ "$PLEASE_FIXME" = "true" ]; then
+@@ -108,7 +108,7 @@
+ object=$1; shift || exit 1
+ correctperm=$1; shift || exit 1
+
+- perm=$(stat -c%a $object)
++ perm=$(stat -f%OLp $object)
+ if [ "$perm" != "$correctperm" ]; then
+ echo "# $object : Wrong permissions ($perm != $correctperm)";
+ if [ "$PLEASE_FIXME" = "true" ]; then